Expert
Expert

ESX Server wont reconnect to Virtual Center

I have an ESX 3.5 U2 server that wont reconnect to Virtual Center.

It originally quit communicating with VC because of a blocked LUN reservation.

After restarting the system it still wont come back. I've tried every combination of things I could find in the forum.

I've deleted the vpxa users, restarted vmware-vpxa, vmware-mgmt, xinetd, and vmware-vmkauthd.

I've removed the host completely from VC, removed the vpxa user, and restarted the ESX server.

The login is successful and the import wizard allws me to see all of the VMs on the host but after registering it, it can't connect or import its VMs.

Error is:

Unable to contact the specified host (host). This might be because the host is not available on the network, there's a network configuration problem, or the management services on the host are not responding.

When I first enter password and try to connect:

Dec 5 16:06:47 pdxesx03 vmware-hostd[3743]: Accepted password for user vpxuser from 127.0.0.1

Dec 5 16:06:47 pdxesx03 xinetd[2114]: START: vmware-authd pid=7416 from=10.61.2.10

Dec 5 16:06:47 pdxesx03 vmware-hostd[3743]: Accepted password for user vpxuser from 127.0.0.1

Dec 5 16:06:54 pdxesx03 vmware-hostd[3743]: Accepted password for user root from 127.0.0.1

After hitting next:

Dec 5 16:08:05 pdxesx03 vmware-hostd[3743]: Accepted password for user root from 127.0.0.1

Dec 5 16:08:05 pdxesx03 passwd(pam_unix)[7444]: password changed for vpxuser

Dec 5 16:08:05 pdxesx03 vmware-authd(pam_unix)[3743]: authentication failure; logname= uid=0 euid=0 tty= ruser= rhost= user=root

Dec 5 16:08:08 pdxesx03 xinetd[2114]: START: vmware-authd pid=7446 from=10.61.2.10

Dec 5 16:08:08 pdxesx03 vmware-hostd[3743]: Accepted password for user vpxuser from 127.0.0.1

The pam files are configured identically to my other hosts.

# cat /etc/pam.d/vmware-authd

#%PAM-1.0

auth required pam_stack.so service=system-auth

account required pam_stack.so service=system-auth

# cat /etc/pam.d/system-auth

#%PAM-1.0

  1. Autogenerated by esxcfg-auth

account required /lib/security/$ISA/pam_unix.so

auth required /lib/security/$ISA/pam_env.so

auth sufficient /lib/security/$ISA/pam_unix.so likeauth nullok

auth required /lib/security/$ISA/pam_deny.so

password required /lib/security/$ISA/pam_passwdqc.so min=disabled,24,12,8,7 similar=deny match=4

password sufficient /lib/security/$ISA/pam_unix.so nullok use_authtok md5 shadow

password required /lib/security/$ISA/pam_deny.so

session required /lib/security/$ISA/pam_limits.so

session required /lib/security/$ISA/pam_unix.so

Any ideas?

0 Kudos
3 Replies
Contributor
Contributor

Have you tested connecting that host to a test VC server? if that works add your other hosts to the new VC server.

0 Kudos
Hot Shot
Hot Shot

Hello,

Try:

  1. Connecting to the host directly via Vi Client.

  2. Once the Vi Client connected, try

  • Restart the Host.

  • Once it's restarted, put the host in Maintenance Mode.

  • Open your VC and check, you can see your Host as it's in Maintenance Mode?

  • If not, then Add your Host to the VC while it's in Maintenance Mode.

  • If You can see your host from the VC it's in Maintenance Mode, Disconnected and Remove it from the VC DataCenter.

  • Restart your Host and try to try to add it once again.

If you are unable to do so, then build a Temp VC "VM" and try to connect the Host to the Temp VC, once it;'s connected fine, then do the following:

  1. Put in Maintenance Mode.

  2. Disconnct it from the VC DataCenter

  3. Remove it from the DataCenter

  4. Perior adding to your old VC, it;s better to Restart your old VC.

  5. And add it to your old VC.

Hope it helps!

Best Regards,

Hussain Al Sayed

Best Regards, Hussain Al Sayed Consider awarding points for "correct" or "helpful".
Expert
Expert

I couldn't get it to connect to another VC either. It seems that the vpx agent was corrupted. Removing the agent (rpm -e VMware-vpxa-x.x.x-xxxxx) and then re-adding fixed the issue.

I found the answer here. http://communities.vmware.com/message/842838#842838

Thank you for you help.

0 Kudos