boabie
Contributor
Contributor

Adding server to HA cluster error

Jump to solution

Hi

I am getting the following error when trying to add a host to an HA cluster.

hostipaddrsdiffer: cmd remove failed: ft_gethostbyname and hostname -i return different addresses 192.168.19.12 and 127.0.0.1

Below is my hosts file. The IP of this server has been changed previously and I think it may have something to do with it. I have noticed the hosts file differs from my other server in that the 127.0.0.1 line points to localhost.localdomain localhost

Problem server hosts file

  1. Do not remove the following line, or various programs

  2. that require network functionality will fail.

127.0.0.1 esx03.ad.xyz.com

192.168.19.12 esx03.ad.xyz.com (<<<< correct IP)

Good server hosts file

  1. Do not remove the following line, or various programs

  2. that require network functionality will fail.

127.0.0.1 localhost.localdomain localhost

192.168.19.11 esx01.ad.xyz.com

Should I change the 127.0.0.1 line on the problem server to match the line of the good server or will that break it?

Thanks for any replies

Robert McArthur - VCP
0 Kudos
1 Solution

Accepted Solutions
Patrick_Miller
Enthusiast
Enthusiast

Yes, change it to read localhost.localdomain localhost. Should clear it right up.

View solution in original post

0 Kudos
3 Replies
RUG201110141
Enthusiast
Enthusiast

My hosts file looks like the following

127.0.0.1 localhost.localdomain localhost

192.168.0.10 machinename.mydomain.com machinename

Then I have all the other IP addresses of all of the other ESX servers in the cluster in the file also similar to the format above.

Patrick_Miller
Enthusiast
Enthusiast

Yes, change it to read localhost.localdomain localhost. Should clear it right up.

View solution in original post

0 Kudos
boabie
Contributor
Contributor

Thanks guys thats it sorted Smiley Happy

Robert McArthur - VCP
0 Kudos