ThomasVing
Contributor
Contributor

Can't start my wm after increasing disk size

Hi

In an attempt to increase disk size of one of our vm's, using the VMWare ESXI Web client, the GUI asked me to remove any snapshots.
I only had one, and removed it. So far all good.

No the GUI told me the disk size was 0 bytes.
It also said: VMware ESX cannot find the virtual disk "DEV_SMARTMAESTRO_SRV-000001.vmdk

After some "Googeling" I found this article saying  about "Unregister" and the register the VM again.
I was able to unregister the WM successfully, 
Also able to re-registering using the original vmdk file (without 000001) and rebooting

Now gives me error: Disk consolidation for VM DEV_SMARTMAESTRO_SRV has failed: Detected an invalid snapshot configuration.
when trying the command "Consolidate" also give me error "Disk consolidation for VM DEV_SMARTMAESTRO_SRV has failed: Detected an invalid snapshot configuration"

Please help!!

 

 

 

 

 

0 Kudos
7 Replies
niyijr
Enthusiast
Enthusiast

Can you try migrating the VM to another datastore?

________________________________________________________
Please KUDO helpful posts and mark the thread as solved if answered
0 Kudos
ThomasVing
Contributor
Contributor

Hi

Thank you for taking your time to answer me, I truly appreciate that.

I have found that "backing" points to nnn-000001.vmdk file, that really doesn't exists anymore (since I removed the snapshot)
Would it be risk free to try to just change the "backing" file, by clinking the "backing" file link and in the datastore browser just change to the corresponding .vmdk file (I would assume the actual file name is nnnn-flat.vmdk, this is really confusing!)

 

ThomasVing_3-1626344996844.png

 

 

ThomasVing_2-1626344825800.png

 

Best regards

 

 

 

 

0 Kudos
scott28tt
VMware Employee
VMware Employee

1. Do you have a backup?

2. Have you tried creating a new snapshot then deleting all snapshots?

 


-------------------------------------------------------------------------------------------------------------------------------------------------------------

Although I am a VMware employee I contribute to VMware Communities voluntarily (ie. not in any official capacity)
VMware Training & Certification blog
0 Kudos
ThomasVing
Contributor
Contributor

Hi

 

No I do not have a backup, but the original 60Gb vmdk file is still there.
Creating a new snappshot does not work, gives error:Failed-File was not found.

 

I'm a beginner at this stuff, and my college who perhaps know this slightly more than I do is on vacation.
Is it possible to buy support and get the problem resolved quicker?. I'm a bit afraid of actually worsening the case by applying "trial and error". The data on the machine is quite important.

0 Kudos
a_p_
Leadership
Leadership

>>> I only had one, and removed it. So far all good.
How exactly did you do this?

The screenshot with the VM's files still shows the snapshot's data (sesparse) file, but its descriptor file is missing.

Please run
cd /vmfs/volumes/MIKT/DEV_SMARTMAESTRO_SRV
ls -lisa
from the command line to list all of the VM's files, and post the result. In addition to this, run
cat DEV_SMARTMAESTRO_SRV.vmdk
and post that command's the output too.

André

 

0 Kudos
ThomasVing
Contributor
Contributor

Hi

I removed the snapshot using the WebGUI, simply using the "Manage Snapshot" dialog, selected the "one-and-only" snapshot I had and pressed "Delete Snapshot". Unfortunately I did not turn of the machine prior to this action.

Ok, for the rest of your comments that I truly appreciate... But I do not understand how I can access command line on the server. I'm not running vm on my local PC, it's a "self contained server" with several vm's.

As I told you, I'm a beginner in vmWare! I have tried Putty and SSH to connect, but can't find any way to access the server file system?
(And this is why I'm reaching out for professional help, it would probably take an experienced guy like you 5 minutes to fix my issue...:-)

Kind regards

 


 

 

 

0 Kudos
a_p_
Leadership
Leadership

You are on the right track already. In order to access the host's command line via e.g. putty, it's necessary to enable the SSH service on the ESXi host, because it's disabled by default for security reasons. There are several ways to do this, one of them is to right click the host in the web GUI, and enable SSH from the Services menu item.

André

0 Kudos