TryllZ
Hot Shot
Hot Shot

Workstation Deployment Error : The host does not have sufficient memory resources to satisfy the reservation

Jump to solution

Hi,

I have vCenter 6.7, and NSX 6.4.6 OVFs. 3 ESXi Hosts with 8GB RAM each in a vSAN setup.

I'm trying to deploy NSX-V into workstation, both vCenter and NSX-V are deployed as VMs in workstation deployed via OVF, NSX is integrated into vCenter.

The NSX Controller deploys successfully but fails on Power On with the error : The host does not have sufficient memory resources to satisfy the reservation.

DRS is enabled, HA is disabled as well (based on my finding Admission Control can be disabled to get rid of this error but I'm not using HA at all).

Any thoughts.

1 Solution

Accepted Solutions
MostafaElSayedF
Enthusiast
Enthusiast

I think this is lap setup not a production so you can dedicate to run the controller in one host. and increase it with additional 2Gb Ram i phased the same issue but i disable the vsan. i think it can work if you increase the host with 1 to 2 gb of ram. and try to create 1 DLR and 1 ESG as you will find a problem in there resources. i think if you are insist to enable the vsan with nsx in the lab environment try the two node setup in vsan and increase your compute resources in the 2 esxi hosts.   

I hope this answer your question and i hope that this become answer or helpful comment for you. also, for More details and more information just follow my blog http://www.syncgates.com.

I hope this answer your question and i hope that this become answer or helpful comment for you. also, for More details and more information just follow my blog https://www.syncgates.com Mostafa Fahmy

View solution in original post

4 Replies
Alex_Romeo
Leadership
Leadership

Hi,

There are not many ideas, you have to increase the RAM memory. 8 GB is too little.

Of the total 8 GB of RAM memory of ESXi hosts, how much is available?

System Requirements for NSX Data Center for vSphere

(page 34 attached)

Tip   For optimal performance, you should reserve memory for the NSX Manager virtual appliance. A memory reservation is a guaranteed lower bound on the amount of physical memory that the host reserves for a virtual machine, even when memory is overcommitted. Set the reservation to a level that ensures NSX Manager has sufficient memory to run efficiently.

ARomeo

Blog: https://www.aleadmin.it/
MostafaElSayedF
Enthusiast
Enthusiast

I think this is lap setup not a production so you can dedicate to run the controller in one host. and increase it with additional 2Gb Ram i phased the same issue but i disable the vsan. i think it can work if you increase the host with 1 to 2 gb of ram. and try to create 1 DLR and 1 ESG as you will find a problem in there resources. i think if you are insist to enable the vsan with nsx in the lab environment try the two node setup in vsan and increase your compute resources in the 2 esxi hosts.   

I hope this answer your question and i hope that this become answer or helpful comment for you. also, for More details and more information just follow my blog http://www.syncgates.com.

I hope this answer your question and i hope that this become answer or helpful comment for you. also, for More details and more information just follow my blog https://www.syncgates.com Mostafa Fahmy

View solution in original post

TryllZ
Hot Shot
Hot Shot

Apologies for the delayed response.

Thanks AlessandroRomeo68 & MostafaElSayedFahmy

This is a lab setup.

And I solved the problem by reducing VCSA, NSX RAM and increasing each ESXi servers RAM, and deleting postgre VM-ID to allow editing settings of the NSX controllers to be able to run.

Thanks to all, appreciate every ones help.

TryllZ
Hot Shot
Hot Shot

Thanks MostafaElSayedFahmy for the link, it was very beneficial in understanding the NSX setup.