diddyone
Contributor
Contributor

Could not open /dev/vmmon: Broken pipe.

Jump to solution

upgraded to mojave on mac vmfusion is no longer working same problem as everyone else.

would greatly appreciate the help.

71 Replies
Mikero
Community Manager
Community Manager

Original thread is from 2 years ago and was resolved... I'm going to lock this and advise if folks to start new threads as they are having different issues than OP even if the error messages are the same.

-
Michael Roy - PM/PMM: Fusion & Workstation
justcoastin
Contributor
Contributor

Thanks @RickShu the reboot worked fine without any other modifications.

Only found this out accidentally as there was no option to open terminal after rebooting into recovery mode (MacBook Pro running 10.15.6).

The choice of "Allow apps downloaded from" was set to "App Store and identified developers", but that didn't help.

justcoastin
Contributor
Contributor

Thanks for your help @lurch999 but there was no option to open terminal after rebooting into recovery mode (MacBook Pro 10.15.6).

As it turned out it didn't matter. Simply rebooting fixed the problem. 😊

0 Kudos
rachitb
Contributor
Contributor

do you know if this solution will work on latest Mac OS Big Sur 11.0.1 ? I tried but no success.

0 Kudos
dlhotka
Champion
Champion

Fusion 12 should work with a fresh install on Big Sur

0 Kudos
rachitb
Contributor
Contributor

Thanks for the quick reply. but the thing is I have corporate license for 11.5 and v12 needs another license purchase, which is not a easy path at my end. would a patch or fix come in 11.5 for Big Sur compatibility ?

0 Kudos
ELinder
Contributor
Contributor

Ever since I installed the Security Update 2020-7 on my iMacPro with Mojave 10.14.6 I get these broken pipes error messages when I try to launchan existing VM or create a new one. I have tried literally everything in this thread. Nothing has worked so far.

Is there anything else I can try? I'm using Fusion 11.5.7. I can't go to Fusion 12 and Catalina or Big Sur since I need to stay on Mojave for some other apps.

Erich

0 Kudos
kevinp2
Enthusiast
Enthusiast

I ran into this problem with Mojave 10.14.6 and VMWare Fusion 11.5.7 

I tried many of the solutions in this thread but none of them worked other than turning SIP off (csrutil disable)  I wasn't comfortable with leaving SIP off.

I finally found the solution in this Github post: kOSKextReturnNotLoadable on Mojave 10.14.6

The solution that I executed was to delete the folder /private/var/db/KernelExtensionManagement and reboot.  Upon the reboot, and starting VMWare, the folder was recreated with the correct settings and file permissions.

 

Tags (1)
ELinder
Contributor
Contributor

THANK YOU! Deleting that folder did the trick, Fusion is running now.

Erich

ironfugu
Contributor
Contributor

Thank you! This method finally did it for me. Running Catalina

After spending a few hours trying other methods suggested by vmware 

https://kb.vmware.com/s/article/80467

or

https://www.youtube.com/watch?v=EMmRkr1uGVw

 

0 Kudos
sefanzed
Contributor
Contributor

AMAZING!  FINALLY A SOLUTION!

This has been dogging me since the last Mojave update...  Like Ironfugu, I spent hours chasing my tail doing all of the backflips suggested by VMware and others...  Nothing worked...  But this incredibly simple fix solved the issue completely!

My thanks to POPUP!

0 Kudos
alary
Contributor
Contributor

usr/sbin/spctl kext-consent add EG7KH642X6

didn't work for me. I have been playing with this for way too long!

Running Mojave BTW...

0 Kudos