diddyone
Contributor
Contributor

Could not open /dev/vmmon: Broken pipe.

Jump to solution

upgraded to mojave on mac vmfusion is no longer working same problem as everyone else.

would greatly appreciate the help.

1 Solution

Accepted Solutions
lurch999
Contributor
Contributor

This solution works for cases where the "Allow" button does not appear in Security & Privacy > General:

Using Terminal, get the TeamIdentifier value from the VMWare Fusion version you're using (the % is the prompt, so omit that):

   % codesign -dv --verbose=4 /Applications/VMware\ Fusion.app

From the results of that command, find the "TeamIdentifier" value, for example:

   TeamIdentifier=EG7KH642X6

Write that down, and note this is case-sensitive.

Reboot your Mac into Recovery Mode (hold down Command + R at boot)

In Recovery Mode, open Terminal, then:

  % /usr/sbin/spctl kext-consent add EG7KH642X6

Reboot, and you should be good to go now.

___________________________________________________________________________

Did you find this helpful? Let us know by completing this survey (takes 1 minute!)

View solution in original post

71 Replies
RickShu
VMware Employee
VMware Employee

Hi diddyone,

Please check the System Preferences==>Security & Privacy==>general, make sure the choice of "Allow apps downloaded from" is App Store and identified developers.

Also, try to reboot the host after the installation of Fusion and see if it helps.

I hope it helps.

-Rick

bubbashred
Contributor
Contributor

Checked preferences and they are good.  Rebooted and get the same error.  any thoughts.  On new mac air with mojave

fixed thanks to user pointing out.

This is usually due to the security restrictions about identified developers of Mac OS X applications, to solve it just go to System Preferences > Security & Privacy  and verify if VMWare is allowed to run and there is no mentioning of a blocked application.

regards

carlsuetw
Contributor
Contributor

On Google, this seems to be a regular issue with the 2018 MacBook and MacBook pros. I was able to do a full removal and add administrator user, downgrade my normal user's permissions to standard user and install on the new admin. I was able to return to my user to admin and remove the new admin and VMware continued to work for a day or two but then it went back to not working correctly. I think it might be time VMware actually looked at this as an issue that needs to be fixed.

bocaboy20111014
Contributor
Contributor

I've got the same problem with VMWare running with Mojave on a 2017 iMac. I don't seem to be able to solve it running 11.0.2.

[Groan]

0 Kudos
bocaboy20111014
Contributor
Contributor

I found the answer to this on YouTube. It worked for me. Very simple fix in System Prefs/Security and Privacy.

How to fix VMware Could not open /dev/vmmon: No such file or directory for Mac - YouTube

0 Kudos
carlsuetw
Contributor
Contributor

Having the same issue here on 2018 macbook pro with 11.0.0 and 11.0.2 after upgrading the option to allow vmmon was available in system preferences security but after restart vmmon is blocked again.  VMWare please fix this issue!

0 Kudos
arso96
Contributor
Contributor

This is usually due to the security restrictions about identified developers of Mac OS X applications, to solve it just go to System Preferences > Security & Privacy  and verify if VMWare is allowed to run and there is no mentioning of a blocked application.

regards

https://appsync.biz/dafont/ https://downloader.vip/mapquest/ https://appsync.biz/filehippo/

carlsuetw
Contributor
Contributor

There seems to be a new bug in Mojave that this does not fix the issue of. The only way to temporarily fix it is to fully remove VMWare restart and reinstall then the blocked kext comes up. MacOS seems to be removing the vmmon kext after my review on reboot. The System Preferences > Security & Privacy fix is only available after a complete removal (manually in terminal), restart and reinstall.

bubbashred
Contributor
Contributor

Thx.  This fixed it

0 Kudos
bubbashred
Contributor
Contributor

This is usually due to the security restrictions about identified developers of Mac OS X applications, to solve it just go to System Preferences > Security & Privacy  and verify if VMWare is allowed to run and there is no mentioning of a blocked application.

regards

0 Kudos
Martinpc
Contributor
Contributor

I'm having the same problem on a 2017 Macbook Pro running High Sierra. There is no option to allow apps in the System Preferences>Security and Privacy. I'm running the trial version.

0 Kudos
Andreas0972
Contributor
Contributor

I have the same issue as well and I so far I have:

  • Made sure Virtual Box is uninstalled fully (I used to have that)
  • Rebooted and run csrutil disable under Command+R terminal
  • Checked System Preferences and made sure VMWare is checked off in the Accessibility privacy settings (I never got anything on the general tab)
  • kextstat | grep vmware is showing only two running kexts (not four):
    • com.vmware.kext.vmci (90.8.1)

    • com.vmware.kext.vmnet (1095.22.96)
  • sudo kextutil /Applications/VMware\ Fusion.app/Contents/Library/kexts/vmmon.kext is showing the following

Disabling KextAudit: SIP is off

(kernel) Kext com.vmware.kext.vmx86 start failed (result 0x5).

(kernel) Kext com.vmware.kext.vmx86 failed to load (0xdc008017).

(kernel) Failed to load kext com.vmware.kext.vmx86 (error 0xdc008017).

Failed to load /Applications/VMware Fusion.app/Contents/Library/kexts/vmmon.kext - (libkern/kext) kext (kmod) start/stop routine failed.

  • I have installed, reboot, uninstalled, reboot, installed again...

I have an existing virtual machine with Windows 10 that I used to run with VMWare 8 (a while ago) and I realize that version is not compatible with Mac Mojave so I removed that and downloaded a trial version of VMWare 11 before I did all the steps above...

chidcram
Contributor
Contributor

Had the same problem. Went  to Settings -> Security & Privacy -> Full Disk Access and add "VMWare Fusion.app" from the app directory. After restarting fusion I no longer get the error.

pastedImage_0.png

baxter888
Contributor
Contributor

Absolut the same problem with Mojave 10.14.3 (18D42) and Professional Version 11.0.2 (10952296)

0 Kudos
Splaktar
Enthusiast
Enthusiast

Thank you very much! This finally solved it for me. I had to reboot my laptop after manually adding the Full Disk Access for WMware Fusion.

0 Kudos
RodK965
Contributor
Contributor

I have added full disc access and rebooted, still have the same issue

I am running Mojave 10.14.3 and have selected Windows 10 x64

I would really appreciate help to get this fixed ASAP

Cheers

Rod

0 Kudos
baifuquan0861
Contributor
Contributor

打不开 /dev/vmmon: 断裂管道  怎么解决呀? 最新的问题呢  macOS Mojave 10.14.3 (18D109)  

VMware Fusion 专业版 11.0.2 (10952296)

每次启动

打不开 /dev/vmmon: 断裂管道。

请确保已载入内核模块 vmmon’。

初始化显示器设备失败。

0 Kudos
baifuquan0861
Contributor
Contributor

打不开 /dev/vmmon: 断裂管道  怎么解决呀? 最新的问题呢  macOS Mojave 10.14.3 (18D109) 

VMware Fusion 专业版 11.0.2 (10952296)

每次启动

打不开 /dev/vmmon: 断裂管道。

请确保已载入内核模块 vmmon’。

初始化显示器设备失败。

0 Kudos
glukxxx
Contributor
Contributor

I have the same problem.. MacBook pro2018 MacOS Mojave and win10 bootcamp

0 Kudos