TGM_Sentia
Contributor
Contributor

DNS not working

Jump to solution

I installed our first SHD(v2.0.4) appliance without any issues during the installation, but after logging into the GUI and try to check a vcenter, I noticed that it couldn't do DNS resolution. I then tested though the console, and it can reach the devices IP addresses but no FQDNs, this also applies to external DNS resolution.

How do I reset the appliance configured DNS servers, I don't seem to be able to do it through the GUI.

0 Kudos
1 Solution

Accepted Solutions
TGM_Sentia
Contributor
Contributor

Thanks for your reply Ram

I checked the DNS entry, it seemed correct, but I changed anyway and rebooted, and now it works

Thanks !!

PS. Sorry for posting in the wrong forum, it is my first post inhere 🙂

/Tommy

View solution in original post

0 Kudos
5 Replies
Lutz1998
Contributor
Contributor

I think you have used wrong forum.

can you try here https://communities.vmware.com/t5/Skyline-Health-Diagnostics-SHD/bd-p/Skyline-Health-Diagnostics-SHD

or moderators should move this to the above mentioned forum

my blog - http://vcp7cram.com
0 Kudos
sjesse
Leadership
Leadership

I just moved this, I agree the Skyline section is better.

ksram
VMware Employee
VMware Employee

Is static IP configuration used for SHD VM? If yes please check the network configuration for correct DNS settings? Configuration is stored in the file: /etc/systemd/network/99-static-en.network

It must have an entry for DNS server under [Network] section.


Sample Configuration:

[Match]
Name=eth0

[Network]
Address=192.168.1.10/28
Gateway=192.168.1.1
DNS=192.168.1.2

Once corrected please restart the VM.

Thanks

-Ram

TGM_Sentia
Contributor
Contributor

Thanks for your reply Ram

I checked the DNS entry, it seemed correct, but I changed anyway and rebooted, and now it works

Thanks !!

PS. Sorry for posting in the wrong forum, it is my first post inhere 🙂

/Tommy

0 Kudos
ksram
VMware Employee
VMware Employee

Thanks for the update.

-Ram

0 Kudos