tankywoo
Contributor
Contributor

vim-cmd proxysvc/remove_service "/sdk" httpsWithRedirect and Failed to login: Invalid response code: 400 Bad Request

Jump to solution

I executed vim-cmd proxysvc/remove_service "/sdk" httpsWithRedirect by mistake.

and now, I can't execute vim-cmd 、esxcli and some other commands. and I can't login by vcenter。

~ # vim-cmd proxysvc/service_list

Failed to login: Invalid response code: 400 Bad Request

~ # esxcli network ip connection list

Connect to localhost failed: Connection failure

I have reboot for several times.

The document: http://pubs.vmware.com/vsphere-51/index.jsp?topic=%2Fcom.vmware.vsphere.security.doc%2FGUID-0EF83EA7...

Changes are effective immediately and persist across reboots.

but why I have rebooted, and still can't login?

Tags (2)
0 Kudos
1 Solution

Accepted Solutions
tankywoo
Contributor
Contributor

I have solved this problem.

  • vi /etc/vmware/rhttpproxy/endpoints.conf
  • add this line: /sdk local 8307 redirect allow
  • the restart rhttpproxy service: /etc/init.d/rhttpproxy restart

View solution in original post

0 Kudos
4 Replies
john23
Commander
Commander

Can you check the hostd (host agent ) is running.

Check web service status as well.


Thanks -A Read my blogs: www.openwriteup.com
0 Kudos
tankywoo
Contributor
Contributor

hostd is running:

~ # /etc/init.d/vpxa  status

vpxa is running

~ # /etc/init.d/hostd status

hostd is running.

How to check web service status?

TankyWoo@Mac-OS::~/ » telnet 192.168.0.200 80

Trying 192.168.0.200...

Connected to 192.168.0.200.

Escape character is '^]'.

0 Kudos
tankywoo
Contributor
Contributor

/etc/vmware/hostd # /etc/init.d/rhttpproxy status

rhttpproxy is running.

This is web service ? It is also running

0 Kudos
tankywoo
Contributor
Contributor

I have solved this problem.

  • vi /etc/vmware/rhttpproxy/endpoints.conf
  • add this line: /sdk local 8307 redirect allow
  • the restart rhttpproxy service: /etc/init.d/rhttpproxy restart

View solution in original post

0 Kudos