VMware Cloud Community
yangzhenginfo
Contributor
Contributor

Unable to create Filesystem, please see VMkernel log for more details: Failed to create VMFS on device naa.6589cfc00000022d3b9872e459f4b72c:4

I use FreeNAS 11.2 to make iSCSI disk share.

I config esxi's iSCSI settings,then I can see FreeNAS iSCSI Disk in esxi's  Storage->Device. The esxi's version that I use is 6.7 update2.

FA5A2094-868B-47cb-9DFC-F480B7E7D0BF.png

I try to use the FreeNAS iSCSI Disk to create Vmfs Datastore.At last step,I click 'finish' , the following error occured.

Unable to create Filesystem, please see VMkernel log for more details: Failed to create VMFS on device naa.6589cfc00000022d3b9872e459f4b72c:4

And the /var/log/vmkernel.log :

2020-01-09T12:55:03.264Z cpu2:2143383 opID=347e7229)World: 11943: VC opID esxui-65b-b200 maps to vmkernel opID 347e7229

2020-01-09T12:55:03.264Z cpu2:2143383 opID=347e7229)NVDManagement: 1461: No nvdimms found on the system

2020-01-09T12:55:20.657Z cpu5:2143385 opID=ad32fa9a)World: 11943: VC opID esxui-a200-b20b maps to vmkernel opID ad32fa9a

2020-01-09T12:55:20.657Z cpu5:2143385 opID=ad32fa9a)LVM: 10410: Initialized naa.6589cfc00000022d3b9872e459f4b72c:5, devID 5e1722b8-bb3fa3b9-35c3-001018c01de0

2020-01-09T12:55:20.663Z cpu5:2143385 opID=ad32fa9a)LVM: 10504: Zero volumeSize specified: using available space (34339815936).

2020-01-09T12:55:20.678Z cpu5:2143385 opID=ad32fa9a)WARNING: Vol3: 3155: aa/5e1722b8-bf7b8be8-c4d8-001018c01de0: Invalid CG offset 65536

2020-01-09T12:55:20.678Z cpu5:2143385 opID=ad32fa9a)FSS: 2350: Failed to create FS on dev [5e1722b8-ac2c993e-4741-001018c01de0] fs [aa] type [vmfs6] fbSize 1048576 => Bad parameter

2020-01-09T12:55:23.663Z cpu5:2143067)LVM: 16760: One or more LVM devices have been discovered.

How could I sove thi problem?

21 Replies
gsmith1
Contributor
Contributor

Hi all

Is there anyone out there still having this issue? I'm experiencing the same behavior on a new TrueNAS Scale setup that is correctly configured as per above (zvol, etc etc). Everything was working 100% fine on VMFS6 on this server. I had to rebuild it and created the iscsi shares in exactly the same way as before (and the same way as a mirrored server that's still working) - but I can only create a VMFS5 datatsore, not VMFS6. If I try to do via the CLI, I get the same "invalid argument" error.

I'm running the latest release - TrueNAS-SCALE-22.02-RC.2

Any help gratefully received!

Many thanks

Reply
0 Kudos
isd728
Contributor
Contributor

I delete the zvol.  Scrubbed the pool. Added the zvol back. using default options, 16k.  Confirmed by clicking advanced options.

Did the sharing and set the lun to 1.

My defaults for blocks were 512 as well.

Reply
0 Kudos