buckmaster
Enthusiast
Enthusiast

No boot after clean install

Jump to solution

I have a generic Intel motherboard with a sata ich9 controller, home lab.  It has ran esx4 fine ever since esx4 beta.  When I load esx5 to hard drive or usb drive on reboot the monitor just displays a cursor.  When inserting the esx5 installer cd and rebooting you have two choices 1. Install Esx or 2. Boot from local HD.  When selecting boot from local HD, esx5 will boot from the previous install?  Seems like the bootloader is not correct.  Any ideas?

Thanks

Tom Miller
0 Kudos
1 Solution

Accepted Solutions
admin
Immortal
Immortal

By default ESXi 5.0 uses GPT based partitions tables and not MBR like it did previously.  This allows you to have disks which are greater than 2TB in size, but some systems are incompatible with it (possibly including yours) or need to have the correct BIOS setting.

You can try changing your BIOS to see if it's compatible with EFI or will work in "legacy/compatibility mode".  Alternatively you can reinstall and use the "formatwithmbr" setting at the boot prompt which will cause the partitions to be set up the way they were in ESX 4.x.  Just add it in the same way you would to tell the machine to do a scripted install.

Hope that helps..

--Patrick.

View solution in original post

0 Kudos
25 Replies
nalfonso14
Enthusiast
Enthusiast

Hi!, first check the hardware compatibility matrix http://www.vmware.com/go/hcl..

When you select Local HD, in boot loader, the esxi 5 instalation is abort and process to run esxi preinstalled..

Nicolas Alfonso Sr Virtualization Architect ***Consider awarding points for "helpful" and/or "correct" answers.***
0 Kudos
nalfonso14
Enthusiast
Enthusiast

if your hardware is in HCL its compatible to esxi... see any error in boot??? check if you see also

http://kb.vmware.com/1017162

Nicolas Alfonso Sr Virtualization Architect ***Consider awarding points for "helpful" and/or "correct" answers.***
0 Kudos
nkrishnan
Expert
Expert

Also make sure that you have choosen right booting method (either EFI or BIOS). Use the same that you used it during the installation of ESX5.0 and check it

--Nithin
0 Kudos
buckmaster
Enthusiast
Enthusiast

dead link?

http://kb.vmware.com/1017162

Tom Miller
0 Kudos
nalfonso14
Enthusiast
Enthusiast

ups sorry try this

http://kb.vmware.com/kb/1017162

Nicolas Alfonso Sr Virtualization Architect ***Consider awarding points for "helpful" and/or "correct" answers.***
0 Kudos
buckmaster
Enthusiast
Enthusiast

Thanks.  I'll give this a try when I get home.  Strange.  There must be something different about the boot process from esx4 and esx5?

Tom Miller
0 Kudos
admin
Immortal
Immortal

By default ESXi 5.0 uses GPT based partitions tables and not MBR like it did previously.  This allows you to have disks which are greater than 2TB in size, but some systems are incompatible with it (possibly including yours) or need to have the correct BIOS setting.

You can try changing your BIOS to see if it's compatible with EFI or will work in "legacy/compatibility mode".  Alternatively you can reinstall and use the "formatwithmbr" setting at the boot prompt which will cause the partitions to be set up the way they were in ESX 4.x.  Just add it in the same way you would to tell the machine to do a scripted install.

Hope that helps..

--Patrick.

0 Kudos
buckmaster
Enthusiast
Enthusiast

Patrick you ROCK!!!

I've been struggling with this since RC with no solution.  Adding the boot option fixed my issue.  How in the world did you know about the boot option?

Tom Miller
0 Kudos
admin
Immortal
Immortal

I designed the installer and demanded that we have that feature.  😄

One of the key features for the 5.0 release was that we wanted to support 2+TB disks.  We thought everyone would have BIOSes which were compatible with GPT when we started putting together the requirements back in 2009.  Since we were going to be migrating everyone over from ESX based partition tables onto the partition layout that ESXi uses, we figured we should start getting everyone to use GPT as well.  It works with any system on our HCL, but we knew there were bound to be some people out there with first generation 64 bit systems which didn't support EFI or BIOS based GPT.  We just didn't know how many people it would effect so we left in the option to partition with either.

On a related note, we also had a problem with migrating VMFS partitions from MBR to GPT which would have caused the VMFS partition to potentially have been clipped due to the secondary boot record.  If you upgrade from ESX 4.x or ESXi 4.x you still end up with an MBR partition table and not a GPT based one.  If you'd used VUM or the installation CD to upgrade your 4.x based system you wouldn't have run into this problem, but probably would have been scratching your head when you tried re-installing from scratch.  😄

Thanks,

--Patrick.

0 Kudos
buckmaster
Enthusiast
Enthusiast

Thanks again Patrick.  I really appreciate you taking the time to respond.  This is my home lab that I learn vSphere with.  So I know it's not on the HCL I'm just trying to learn on my home budget.  My vendor Intel for my motherboard "Intel® Desktop Board DQ35JO" stopped suppling BIOS updates in Dec 2010 so a BIOS upgrade was not an option.  It has a E8400 processor an even runs FT VM's.  Now when I'm on the road an need to reboot the ESX server I won't have to have the wife place the ESX installer CD in my server to boot with. Smiley Wink

Tom Miller
0 Kudos
volleyballdan
Contributor
Contributor

Patrick, the formatwithmbr seems to help me as well..mostly. Here's what I'm doing and my issue. I run esxi5 bood CD.  do shift + O.  Erase runweasel...type in "formatwithmbr".  I'm not sure if this syntax is correct.  Anyway, ESXi5 loads great this way.  Issue is still upon reboot it won't load.  I've seen once after about 20 minutes it does load but this isn't acceptable.  MB is on HCL, so I'm stuck, and need help.  Thanks.

0 Kudos
admin
Immortal
Immortal

volleyballdan:  Don't erase the "runweasel" command.  It's was causes the installer to start.  Without it you're just booting ESXi and nothing more.  Add the "formatwithmbr" and you should end up in the installer (weasel) and your drive with be formatted in a way that your BIOS can understand.

0 Kudos
wdbarker
Enthusiast
Enthusiast

For anyone trying to duplicate these successes, "add" means type a space and formatwithmbr. I first tried a comma, and that didn't help. I didn't try a plus sign because a space worked. So, by "boot prompt" they mean the prompt you get after hitting Shift-O. And by add, they mean a space delimited addition of the string. "runweasel formatwithmbr". Clear as mud? I have no idea why it's so important to be obscure with these tips.

Oh, but "Thanks anyway" I really appreciate having only 3 things to try instead of the hundreds I'd have had on my own looking into the bootloader with no doc! Thanks Patrick!

0 Kudos
admin
Immortal
Immortal

wdbarker:  I wasn't trying to be obscure;  I just didn't have access to a machine to test it out before I replied to the post.  I'm glad you got it to work despite not having clear directions.

Incidentally, I haven't worked on the installer for over a year, but I have talked with the dev. manager to get some better documentation.  Hopefully that will be forthcoming, probably in the way of a KB article.

0 Kudos
wdbarker
Enthusiast
Enthusiast

Yes, my post probably sounded a bit rough. Please know that I’m very glad to have the information. I’ve been working with another vendor’s software lately and their doc is filled with items that appear to say something simple, but turn into a 20 minute research project just to figure out what they said. I really should have written:

For anyone trying to duplicate these successes, the boot prompt appears after you hit Shift-O during the boot process. You will see runweasel already in the boot prompt field. Left arrow to the end, add a space and formatwithmbr and press enter. The prompt will look like runweasel formatwithmbr

Thanks Patrick!

or maybe said nothing at all. My apologies.

Dan

0 Kudos
thnworld
Contributor
Contributor

I also have the same problem with my x58 chipset with i7-920 systems.  it got to the point where it has ""Relocating Modules and starting up the Kernel.."" then reboots automatically.  Can someone help?  I tried to swap ot the graphic cards as well as disabling everything and only booting off the usb drive but none prevailed.  Same result, rebooting cycle.

0 Kudos
reffervasu
Contributor
Contributor

thanks wdbarker it is worked for me on intel 945 gcnl mather board

0 Kudos
salmanearn
Contributor
Contributor

Any idea i am getting a error. During initial install I press Shift-O when prompted.I  Add formatwithmbr to the options, proceed with install. Soon after this when it start loading

/tboot.b00

I got this error


Multiboot header is not found

/tboot.b00: Kernal is either invalid or corrupted

Fatal error:36 (Bad Type)

Thanks

0 Kudos
salmanearn
Contributor
Contributor

I have calcualted MD5SUM its perfectly fine .Any guess i am quit lost in that situation .

0 Kudos