PaulGab
Contributor
Contributor

ESXi 5 - Longmode is disabled for this virtual machine.

Jump to solution

Hi,

I've installed ESXi 5.0.0, 469512 onto a Dell Optiplex 755 with an Intel Core2 Duo E8400 @ 3.00GHz with 4GB RAM. In the BIOS (version A21) I have the following options enabled:

Performance-

Virtualization: On

VT for Direct I/O: On

Trusted Execution: On

Security-

TPM Security: On

TPM Activation: Active

Execute Disable: On

I'm unable to run any 64bit OSs. For example, when I try to start up vMA 5.0 VM, I get the following Virtual Machine Message:

"This virtual machine is configured for 64-bit guest operating systems. However, 64-bit operation is not possible.

Longmode is disabled for this virtual machine.
For more detailed information, see http://vmware.com/info?id=152.
Continue without 64-bit support?"

I've run the "Processor Check for 64-Bit Compatibility" and if confirms that I can run 64bit guest OSs.

I've tried adding vhv.allow = "TRUE"  to /etc/vmware/config, but this has made no difference.

In the vmware.log file is it does meantion "Software virtualization is incompatible with long mode on this platform. Disabling longmode." I've attached the full log file for all the details.

Any help will be greatly appreciated.

Thanks Paul.

Tags (2)
0 Kudos
1 Solution

Accepted Solutions
a_p_
Leadership
Leadership

According to the log file

Common: MSR  0x3a = 0x3 --> currently "0011" , should be "x1x1"

VT-x is not enabled (Bits 0 + 2 required)

There were other discussions, where enabling "Trusted Execution" caused issues. I' suggest you configure the BIOS settings as follows:

Performance-

Virtualization: On (assuming this is VT-x)

VT for Direct I/O: Off (unless you need it)

Trusted Execution: Off

Security-

TPM Security: Off

TPM Activation: Inactive

Execute Disable: On

After modifying any of the settings, you may need to power cycle the system!

André

View solution in original post

0 Kudos
7 Replies
Dave_Mishchenko
Immortal
Immortal

The vhv.allow option is not required unless you plan to run nested VMs.  You'll need the 3 following settings enabled and it sounds like you have 2.  Is the 3rd enabled?  Did you power off the host after changing the BIOS settings?

  • No-Execute Memory Protection
  • Execute Disable
  • Virtualization Technology (VT)
0 Kudos
PaulGab
Contributor
Contributor

Hi Dave,

There is no "No-Execute Memory Protection" option in the BIOS. The host has been rebooted many times since enabling these options and the guest OS has never booted.

Paul

0 Kudos
a_p_
Leadership
Leadership

According to the log file

Common: MSR  0x3a = 0x3 --> currently "0011" , should be "x1x1"

VT-x is not enabled (Bits 0 + 2 required)

There were other discussions, where enabling "Trusted Execution" caused issues. I' suggest you configure the BIOS settings as follows:

Performance-

Virtualization: On (assuming this is VT-x)

VT for Direct I/O: Off (unless you need it)

Trusted Execution: Off

Security-

TPM Security: Off

TPM Activation: Inactive

Execute Disable: On

After modifying any of the settings, you may need to power cycle the system!

André

0 Kudos
PaulGab
Contributor
Contributor

Thanks André,

Your suggestions have worked.

Thanks Paul.

0 Kudos
buckmaster
Enthusiast
Enthusiast

Same error message, different situation.  Been running everything fine for some time.  Shut everything down to replace a battery in my UPS.  Turn on servers, and one host running my DC came up with the error above.  VT-Tech was turned off?  Wonder how that could happen?  Battery onboard server seemed fine as date and time were correct.  After turning VT-Tech back on and restarting the host my DC autostarted as it always has.  Any ideas would be appreciated.

Thanks tom

Tom Miller
0 Kudos
STaTiLuS
Contributor
Contributor

I am pretty sure that while this process does support a 64bit host and does support Virtual guests; it does not support 64 bit VM's I was only able to get 32 bit machines installed.  Feel free to correct me if I am wrong.

0 Kudos
admin
Immortal
Immortal

If we are still talking about the E8400, it does support 64-bit guests.

0 Kudos