technova
Contributor
Contributor

"internal error has occured-Error #1009" appears intermittently



Hi,


We are observing "internal error has occured-Error #1009" error intermittently while quick navigation web client plugin.


Does point out for possible reasons for the issue.


Thanks in Advance.

0 Kudos
13 Replies
technova
Contributor
Contributor



Could any one point out for possible reasons of the issue?

0 Kudos
laurentsd
VMware Employee
VMware Employee

technova, 3 quick things to help you use of this forum:

1) This is the "Web Client SDK" community, for answering questions specific to Web Client plugin development.  For general Web Client user questions you need to contact VMware support.

2) When posting questions in any forum you need to provide the minimal information like the version of the software you are using, the steps you were doing, logs,  etc.

In this case you added a screen-shot which is good, but you didn't include the stack trace that comes with the error message.

3) It doesn't look good to post at 6:05 and ask why you didn't get an answer at 6:11 🙂

Thanks.

0 Kudos
technova
Contributor
Contributor


Hi, Apologies for late reply.

-actually the second comment was for correcting English of "Does point out for possible reasons for the issue."  statement.  Smiley Happy


-Below are the logs for the issue.

1) [2014-04-01 16:35:24.290] ERROR data-service-pool-7772        com.vmware.vise.data.query.impl.DataServiceImpl                   Error occurred while executing query: 


QuerySpec


   QueryName: urn:vmomi:HostSystem:host-83:C1C4449A-EC25-4B8C-AA9B-07C94A88CC8A.properties


   ResourceSpec


      Constraint: CompositeConstraint


         TargetType: null


         Conjoiner: OR


         Constraint: ObjectIdentityConstraint


            TargetType: null


            Target: ManagedObjectReference: type = HostSystem, value = host-83, serverGuid = C1C4449A-EC25-4B8C-AA9B-07C94A88CC8A


         Constraint: ObjectIdentityConstraint


            TargetType: null


            Target: ManagedObjectReference: type = Datastore, value = datastore-87, serverGuid = C1C4449A-EC25-4B8C-AA9B-07C94A88CC8A


         Constraint: ObjectIdentityConstraint


            TargetType: null


            Target: ManagedObjectReference: type = Datastore, value = datastore-88, serverGuid = C1C4449A-EC25-4B8C-AA9B-07C94A88CC8A


      PropertySpec[2]


         ProviderType: HostSystem


         Relationship: null


         Properties[1]


            PropertyName: name


         ProviderType: Datastore


         Relationship: null


         Properties[1]


            PropertyName: name


   ResultSpec:


      Offset: null


      MaxResultCount: null


      OrderingCriteria


         OrderPropertySpec[1]


            ProviderType: Object


            Relationship: null


            SortType: ASCENDING


            OrderingProperties[1]


               PropertyName: name


 java.lang.IllegalArgumentException: DataAdapter.invalidQuerySpec


at com.hs.hsvi.DataAdapter.processQuery(DataAdapter.java:446)


at com.hs.hsvi.DataAdapter.getData(DataAdapter.java:430)


at com.vmware.vise.data.query.impl.DataAdapterUtil.getDataFromAdapter(DataAdapterUtil.java:126)


at com.vmware.vise.data.query.impl.DataAdapterUtil.getResultFromAdapter(DataAdapterUtil.java:92)


at com.vmware.vise.data.query.impl.DataAdapterUtil.access$000(DataAdapterUtil.java:31)


at com.vmware.vise.data.query.impl.DataAdapterUtil$1.run(DataAdapterUtil.java:69)


at com.vmware.vise.util.concurrent.ExecutorUtil$1.run(ExecutorUtil.java:185)


at com.vmware.vise.util.concurrent.ExecutorUtil$ThreadContextPropagatingRunnable.run(ExecutorUtil.java:573)


at java.util.concurrent.ThreadPoolExecutor$Worker.runTask(Unknown Source)


at java.util.concurrent.ThreadPoolExecutor$Worker.run(Unknown Source)


at java.lang.Thread.run(Unknown Source)


Thanks in Advance for valuable help. 🙂

0 Kudos
laurentsd
VMware Employee
VMware Employee

You are still not giving enough information:

- If this is an error using the product as is please contact VMware support.

- If this is an error while using your own plugin I have not idea what you are trying to do but the fact that TargetType is null in your QuerySpec doesn't look good.

0 Kudos
technova
Contributor
Contributor


Hi,



This is an error while using our own plugin developed using "vSphere web client 5.1 SDK" .



This is error is seen randomly , no specific steps have been identified to reproduce this.



Kindly let me know what further inputs would help resolve this issue.



Thanks & Regards, 


0 Kudos
laurentsd
VMware Employee
VMware Employee

Get the Flex stack trace next time it happens.  Either in the error dialog itself or in the Flex log.

0 Kudos
technova
Contributor
Contributor



Hi Laurent,


Please find attached text file having flex logs.


Thanks & Regards,

0 Kudos
laurentsd
VMware Employee
VMware Employee



According to the log the 2 instances of "null object reference" happen in your code... you're in the only one who can debug that:


TypeError: Error #1009: Cannot access a property or method of a null object reference.



                at com.hs.hsvi.views.HomeView::GettingStartedTab/onGetServerName()[E:\Bc\WebClient\hsvi-ui\swf\src\main\flex\com\hs\hsvi\views\HomeView\GettingStartedTab.mxml:127]




TypeError: Error #1009: Cannot access a property or method of a null object reference.



                at com.hs.hsvi.views.configurationWizard::ConfigurationWizardMediator/isSaveDataResponce()[E:\hsvi-ui\swf\src\main\flex\com\hs\hsvi\views\configurationWizard\ConfigurationWizardMediator.as:592]



0 Kudos
apanse
Contributor
Contributor

Hi Laurentsd,

Observed the same error 1009 while navigation in UI.

Stack trace

TypeError: Error #1009: Cannot access a property or method of a null object reference.

  at mx.containers::TabNavigator/keyDownHandler()

The stack trace contains no trace from plugin.

Thanks ,

0 Kudos
laurentsd
VMware Employee
VMware Employee

1009 is a very generic error so it is not related to technova's problem and it'd be better to open a new thread.  Please indicate which version you are using, whether it happens without your plugin in the picture and if you have a way to reproduce it.

0 Kudos
apanse
Contributor
Contributor

Hi Laurentsd,

This is seen in the same environment as mentioned in earlier comments by Technova.

There is no specific way to reproduce it. This was observed while navigation.

The version being used in 5.1 .

This did not reproduce latter so very difficult to say if it happens without our plugin in picture .

Thanks & Regards,

0 Kudos
davidhill
Contributor
Contributor

Spent a long time researching this error!  Eventually got the fix from GSS.

Here is a link to my blog article that documents how to fix this issue.

http://www.davidhill.co/2015/06/error-1009-vsphere-web-client/

Hope it helps.

0 Kudos
laurentsd
VMware Employee
VMware Employee

hi David,

Thanks for posting this blog, it's good to have connections with GSS 🙂

I'll forward the info to the Web Client team for them to improve the handling of staled objects coming from the SerenityDB cache.

0 Kudos