VMware Cloud Community
Kahonu84
Hot Shot
Hot Shot
Jump to solution

vSphere client on a Windows 10 machine - mouse problems inside VM consoles

Aloha,


I just upgraded to Windows 10 Pro. I am also using vSphere client 5.5.0 Build 1618071.

When managing vm's all is good and right with the world. But when I access

a vm console - either by the tab or opening a stand-alone console window the mouse

becomes very erratic on the vm desktop. Movement is unpredictable. Right clicking

on an icon sometimes opens the proper context sensitive menu. And when I do get

the menu, selecting the desired action is next to impossible.


Has anyone else experienced this and has a solution???


Mahalo,

           Bill



1 Solution
21 Replies
Kahonu84
Hot Shot
Hot Shot
Jump to solution

Bump.. This is driving me crazy having to go back to my old 7 machine to accommodate this..

Reply
0 Kudos
greco827
Expert
Expert
Jump to solution

I'm not very familiar with Windows 10, but can hardware acceleration be turned up?

If you find this or any other answer useful please mark the answer as correct or helpful https://communities.vmware.com/people/greco827/blog
Reply
0 Kudos
mohdhanifk
Enthusiast
Enthusiast
Jump to solution

Hi,

I haven't checked in Windows 10 but similar issue reported in windows 2012 server and fixed by performing below steps.

Go to control panel
Click on mouse and open.

Go to pointers
Uncheck “Enable  pointer shadow” and Apply.

Now the cursor movement will be normal and will not be sluggish.

Reply
0 Kudos
chaithu4u
Enthusiast
Enthusiast
Jump to solution

  • Update the mouse driver in Windows so that it is detected again.

    To update the mouse driver:
    1. Right-click My Computer and click Manage.
    2. Click Device Manager > Mouse > VMware Pointing Device > Upgrade.
  • In the vSphere Client, set the video card resolution to 1024x768.

    To set the video card resolution:
    1. In the vSphere Client, right-click the virtual machine and click Edit Settings.
    2. Click Select Video Card and then click Check reserve memory for the following selection.
    3. Set the value to 1024x768.
    Note: This makes the console large enough to function correctly. However, you are restricted to use only this resolution and you cannot change the resolution in the guest operating system.

  • In the vSphere Client, update the configuration parameters of the virtual machine and set mouse.vusb.enable and vmmouse.present to false.

    To update the configuration parameters of the virtual machine:

    1. Right-click the virtual machine and click Edit Settings.
    2. Click Advanced > General > Configuration parameters.
    3. Click Add rows and add these rows:

      mouse.vusb.enable = false
      vmmouse.present = false
  • If the virtual machine in question was originally imported from one of the Microsoft virtual platforms, there might be some values in the system registry which were left over from Microsoft's Virtual Machine Additions (the equivalent of VMware Tools).

    To remove the left over values from the registry:
balarajugopinat
Enthusiast
Enthusiast
Jump to solution

Reply
0 Kudos
Kahonu84
Hot Shot
Hot Shot
Jump to solution

Aloha,

"Enable pointer shadow" is already unchecked. The rest of the responses point

to "fixing the VM". I know the problem isn't the VMs as the consoles are well-

behaved in Win7/8. There is some funky interaction with Win10.

More ideas please.

Mahalo,

            Bill

Reply
0 Kudos
w00tm3
Contributor
Contributor
Jump to solution

This fixed it for me but this was in VMware Workstation 11.  Might be worth a shot.

Reply
0 Kudos
Kahonu84
Hot Shot
Hot Shot
Jump to solution

​What fixed it for you?

Reply
0 Kudos
Kahonu84
Hot Shot
Hot Shot
Jump to solution

My god that worked!!! You're my new best friend.


Mahalo x 1000,

                       Bill

mattdabrowski
Contributor
Contributor
Jump to solution

Great...glad I could help.

Reply
0 Kudos
seijirou
Contributor
Contributor
Jump to solution

mattdabrowski

Just wanted to thank you for this;  I found this thread in a google search of the same issue also using Win10 to run the client software and your DPI compatibility setting also resolved the problem for me.

seijirou
Contributor
Contributor
Jump to solution

Kahonu84

Consider marking this one resolved so that the answer is highlighted?

Reply
0 Kudos
eymbert
Contributor
Contributor
Jump to solution

Thank you mattdabrowski‌! It worked for me, too. I was about to get crazy with this issue... Thank you, man.

mattdabrowski
Contributor
Contributor
Jump to solution

Best friends get jobs for friends in places like Hawaii. Smiley Happy

Reply
0 Kudos
aytekeltas
Contributor
Contributor
Jump to solution

I personally registered communities just to thank you. You are the man mattdabrowskiSmiley Happy

Reply
0 Kudos
mattdabrowski
Contributor
Contributor
Jump to solution

aytekeltas thanks...can't take all of the credit...I did find it somewhere else

Reply
0 Kudos
mowglihope
Contributor
Contributor
Jump to solution

holy moly i feel alive. for the very first time i can use vSphere without wanting to throw my computer out the window. thank you mattdabrowski

Reply
0 Kudos
IDATAAB
Contributor
Contributor
Jump to solution

Uninstalling the 5.5 client from my Windows 10, downloading it again from my vCenter and reinstalling solved the problem for me.

Reply
0 Kudos