Maxzanna
Contributor
Contributor

Virtual center dos'nt starts anymore, failed to find reference in database

Hi everybody,

i have this problem today, restarting the virtual center server the vmware virtual server dos'nt starts.

I have seen in the vpxlog the follow:

VM has invalid name

Invalid VM. Removing /vpx/vm/#2900/

Delete failed for /vpx/vm/#2900/

Failed to initialize: vim.fault.DatabaseError

Failed to intialize VMware VirtualCenter. Shutting down...

as I see in the message: i have try to delete from the table dbo.VPX_VM

the id 2900, but now when i try to start the service i get the follow:

VmdbCtxGet: Failed to get /vpx/vm/#2900/_private/managedObjImpl/ (Null cross reference)

Failed to initialize: vmodl.fault.ManagedObjectNotFound

Failed to intialize VMware VirtualCenter. Shutting down...

I have virtualcenter ver 2.0.1 build 40644 ed esx 3.01, the database is msde and is in local.

Where I can delete others reference about id 2900?

Please I'm new about virtual and esx operating system, anybody can help me

thanks very much for the help

Max

0 Kudos
1 Reply
GBromage
Expert
Expert

Hi Maxzanna!

What's you'll need to do is use something like MS Access to connect into the MSDE database.

The error is cause by there being a Virtual Machine listed the VPX_ENTITY table, and not in the VPX_VM table (or the other way around.) Check the ID or ENTITY_ID fields to find the entity number 2900 - that's the one that has the problem.

Hope that helps,

Greg

I hope this information helps you. If it does, please consider awarding points with the 'Helpful' or 'Correct' buttons. If it doesn't help you, please ask for clarification!
0 Kudos