uadeshpande
Contributor
Contributor

A general system error occurred: Failed to start HACore profile on node

while anabling Vcenter HA following error occured:

A general system error occurred: Failed to start HACore profile on node

What is the reason?

9 Replies
daphnissov
Immortal
Immortal

Could be several things. Are you using DNS on your vCSA and have proper forward and reverse records in place? Are you using NTP across your environment? Since you've posted no details on your setup, it's impossible to know.

0 Kudos
sapreaper
Contributor
Contributor

I have the same issue... I have been reading a ton of issues with VCHA enabling. But have not figured this out yet.

Yes we have everything FQDN, DNS, all on a local STRATUM-1 NTP etc. Been there done that...

Manually destroyed the VCHA from VCSA etc, rebooted etc, keeps failing after 90% with exact error  Smiley Sad

0 Kudos
Vijay2027
Expert
Expert

Encountered similar issue recently. Below steps helped me in resolving the issue.

Before enabling VCHA:

  • Login to vCSA (active node) with root credentials via SSH.
  • Modify statsmonitor service config for vMon

                sed -i '/StartTimeout/d' /etc/vmware/vmware-vmon/svcCfgfiles/statsmonitor.json

                sed -i '/ApiHealthFile/a "StartTimeout": 600,' /etc/vmware/vmware-vmon/svcCfgfiles/statsmonitor.json

  • Reload vMon service config through SIGHUP

               kill -HUP $(cat /var/run/vmon.pid)​

  • Stop and start statmonitor service.

​​​                /usr/lib/vmware-vmon/vmon-cli -k statsmonitor

                /usr/lib/vmware-vmon/vmon-cli -i statsmonitor​

  • Enable VCHA.

Please do take snapshot before you make any changes.

If this does not fix the issue attach vpxd.log to the thread.

Location: /var/log/vmwrae/vpxd/

sapreaper
Contributor
Contributor

Thanks, I did get it working without all of that just prior to your post.

See if I can remember the order but:

After failure I rebooted the witness and peer.

Logged into the console of my main active vcsa

shell> destroy-vcha -f

I noticed if you try to run <service vmware-vcha start>, you get a mask error.

<systemctl unmask vmware-vcha>

then <service vmware-vcha start>

This then caused the active vcsa to reboot....

Once up I went to the web client, clicked on vcenter, configure, vCenter HA, edit and enable. 

In about 5 min it ran through the "sync" and all came back green

0 Kudos
finney1
Contributor
Contributor

Thanks, that worked for me!

0 Kudos
WuGeDe
Enthusiast
Enthusiast

sapreaper What have you done in detail after you ran into that error?

Have you powered off and deleted the already deployed peer and whitness before you did the steps mentioned in your post?

0 Kudos
lpprikej
Contributor
Contributor

this was a long time ago but if you read my steps, doing a 'destroy-vcha -f' takes the Passive and Witness offline and destroys them. So yes the PASSIVE and WITNESS were removed.

0 Kudos
WuGeDe
Enthusiast
Enthusiast

sapreaper​ thank you for your reply.

i was wondering because i did the steps you did but the peer and witness were sill there and powered on after.

0 Kudos
jhoekema
Contributor
Contributor

I was running into a similar error with one of my vCenter setups. I connected to it via SSH and immediately received a prompt to change the password as the current one had expired. Once I updated that, I was able to complete the HA setup without any issues.

0 Kudos