JoeBeaty
Enthusiast
Enthusiast

WSO UEM 2005 issues with on-prem?

I'm getting ready to upgrade from 1907 and was wondering if anyone has upgraded to to 2005 on-prem.  If you have upgraded, did you experience any issues. 

I'm upgrading to get to the latest version and also resolve an issue where the VMWare Tunnel (via the UAG) will lose it credentials every 6 months and stop working.  Also, there was an issue where the tunnel settings page wouldn't load because of a similar issue.

I could go to 2001 but will be in the same boat soon enough where I need to upgrade.

Any feedback is appreciated.

Joe Beaty

Labels (1)
32 Replies
chengtmskcc
Expert
Expert

Hi Joe,

We are going to upgrade our SaaS environment from 1907 also to 2005. We decided 2006 is too new and not stable enough. Plus I've seen lots of bugs that were resolved in 2005.

Best,

Tom

0 Kudos
HimanshuMishra
Enthusiast
Enthusiast

I am also planning to update from 1907 to 2001 or 2005. I updated the dev environment to 2001 patch 17. One thing I observed is a new setting in hub - "Lock App". This is different than device passcode. Users will need to enter the hub password every time they want to access hub. This is new and we dont want it. I could not find a setting to disable or hide the "Lock app". Vmware support is looking into it.

Setting Passcodes for the Workspace ONE Intelligent Hub App  mentions the behavior but we never had this option in production environment. Not sure how it will impact the existing enrolled devices.

0 Kudos
JoeBeaty
Enthusiast
Enthusiast

Thanks for the comments...looks like not many have gone to 2005 but will have to take my chances.  There is a patch available so hopefully it fixes most 2005 base bugs.

0 Kudos
AaronWhittaker
Enthusiast
Enthusiast

When you do I would love to hear about your experience. We are planning to do the upgrade in the next few months but have been hindered by other higher priority work.

ThomasBeckerTho
Enthusiast
Enthusiast

HimanshuMishra

I am pretty sure this has to do with the WS1 Apps security settings.

Check your settings under "Apps > Settings and Policies > Security Policies > Authentication Type".

If it is set to "Passcode" it will always need a passcode to unlock. I don't know if VMware already enabled SSO for all WS1 Apps but if so you need to enter a passcode for all your WS1 Apps except Tunnel.

Excluding the Intelligent Hub doesn't seem to be an option.

We also freshly upgraded vom 18.09 to 20.05. So far it doesn't run very well. Everything is loading very slow. Devices take very long to enroll and to receive all configs.

Be aware that you need to upgrade you DB to 20.01 and then to 20.05 because, you guessed it, of a bug!

HimanshuMishra
Enthusiast
Enthusiast

ThomasBeckerThomasBecker1​ you fixed it.  Smiley Happy

I disabled the authentication type and it fixed the hub. Lock app option is gone. Thank you!!

0 Kudos
chengtmskcc
Expert
Expert

Just curious, do you know how that setting was enabled? Could it be enabled for other apps that you or your team may not be aware of?

And question for everyone else, how often do you upgrade your UEM console?

0 Kudos
AaronWhittaker
Enthusiast
Enthusiast

We have only upgraded once, from 9.2.3.6 to 1903 (technically twice as it had to go to 9.7 then 1903). I would like to upgrade more often, basically N-1 or even N after its been out a few months but there are always higher priorities that get in the way.

0 Kudos
chengtmskcc
Expert
Expert

I hear ya. When I was an on-premises customer, upgrade involves more than just the DS/CS servers but the SEG, UAG, etc. so we could upgrade maybe once a year at most.

Now as a SaaS customer, we try to upgrade maybe twice a year but like you said it's also difficult due to other priorities such as work related to the pandemic.

0 Kudos
JoeBeaty
Enthusiast
Enthusiast

I had not read about the need to go to 20.01 and then 20.05 for the DB.  Do you know if this is documented anywhere?  Maybe I need to call VMWare to discuss prior to upgrading.

0 Kudos
chengtmskcc
Expert
Expert

Here you go.

VMware Knowledge Base

JoeBeaty
Enthusiast
Enthusiast

Thank you for this.  It has saved me some grief as I plan on doing the upgrade later on Wednesday evening when support probably is not available.

0 Kudos
HimanshuMishra
Enthusiast
Enthusiast

chengtmskcc

Authentication Type Setting is enabled at global but overridden at child OGs in production. It is set as disabled.

I thought it is a new feature in 2001. Good learning.

Do you know if there are any major issue with 2001 ? Is it stable enough ? Planning to upgrade from 1907 to 2001 patch 21.

Thanks

0 Kudos
chengtmskcc
Expert
Expert

Why not go to 20.05? I've read through the KBs and I think it's stable enough to upgrade our environment (19.07) to.

0 Kudos
HimanshuMishra
Enthusiast
Enthusiast

Hi JoeBeaty

Did you upgrade to 2005 ?

0 Kudos
JoeBeaty
Enthusiast
Enthusiast

I did upgrade last Wednesday to 2005.  So far everything is working great and I have had no issues reported.  There are some nice enhancements especially with filters where you can choose and click apply instead of making a choice, waiting for it to update and then making the next filter choice.  The console is much faster to respond as well.

I did follow some advise and ran the 2001 DB upgrade and then did the 2005 DB upgrade and that worked without issue.

One thing I did notice is the Intelligence Hub would not connect initially.  After a few hours, updated on all our Macs automatically and recognized enrollment.

0 Kudos
chengtmskcc
Expert
Expert

We upgraded our UAT SaaS environment from 1907 to 2005 yesterday. No issue so far.

When I upgraded our ACC today to match the same version, however, I encountered the error below and ended up having to re-install ACC from scratch. Anyone else experienced the same issue?

Snapshot 2020-07-15 11.34.38.pngSnapshot 2020-07-15 11.35.03.png

0 Kudos
AaronWhittaker
Enthusiast
Enthusiast

Awesome. I think we will look at doing ours in the next few weeks.

Quick question for you, last time we did an upgrade a bunch of files were left on the ACN from the previous versions. Did that happen with yours? Are they fine to just remove?

pastedImage_0.png

0 Kudos
chengtmskcc
Expert
Expert

Looks like your current version is 19.3. Considering support for 9.2 was long gone, you can safely delete those folders and files.

0 Kudos