gulster
Contributor
Contributor

vmware error "creating a quiesced snapshot failed because (user-supplied) custom pre-freeze script in the virtual machine exited with a non-zero return code"

When trying to create a backup of a vm that lives in a VI3 environment, I am receiving the following error from the vm when it tries to suspend the guest OS for the snapshot. I am using NetBackup to perform the backup and it appears to work fine until the suspend. Any help would be great, the error I get is posted below. Oh, and this is a Solaris 10 vm with tools installed.

vmware error "creating a quiesced snapshot failed because (user-supplied) custom pre-freeze script in the virtual machine exited with a non-zero return code"

0 Kudos
28 Replies
Pmarsha1
Enthusiast
Enthusiast

I've had the same issue on two VM's when using VCB.

The first one had a CD mounted and was then rebooted. This fixed the issue.

The second is still ongoing but it doesn't have a CD mounted BUT I haven't rebooted the VM yet.

Have you tried a reboot as I reckon the problem will likely go away.

0 Kudos
green27614
Contributor
Contributor

I do not know what causes this but I have found with two of my servers the rebooting of the ESX host makes this go away.

If this does not work there is n undocumented workaround (guess the coders at VMWARE never thought it would come in handy).

Open your config.js file and add this line to it anywhere:

NO_QUIESCE=""

This will keep the snapshot manager from quiescing the VM. This is a good thing to use for SQL servers and EXchange servers- in case you never noticed the information store "breaks" on exchange when you quiesce it. This stops this from happening.

However, the best solution is to reboot the host

Eddie

Eddie
0 Kudos
Pmarsha1
Enthusiast
Enthusiast

Sorry mate but rebooting an ESX host isn't really a viable solution for live services. An ESX host should stay up for years.

Setting a machine not to quiesce is another bad idea as this means the snapshots will be like a server having the power pulled on it and sometimes it won't recover.

So don't stop the machine quiescing without good reason and accepting the possible consequences.

Like my previous post, rebooting the VM has worked for me on numerous occaisions.

0 Kudos
green27614
Contributor
Contributor

If that solution is not a good one for you then good luck in finding another one.

I too tried rebooting the VM to no avail.

I offered what I found that worked in my environment having the same exact issue.

As with all solutions- your mileage will vary. Incidentally- the rebooting part- came directly from VMware as a last ditch resort.






Eddie

Eddie
0 Kudos
gulster
Contributor
Contributor

Oddly enough I uninstalled VMtools and got it to work. I am guessing the removal of vmware tools got rid of the pre-freeze quiesced snapshot process and allowed the vm to be backup. Weird I know, I am going to file a bug with Vmware to bring this issue to their attention. I have a feeling I am going to experience the same situation with Ubuntu 7.10 server, but I am still in the preliminary stages. If someone has setup Ubuntu 7.10 server with VMware tools and been able to back it up with VCB please let me know whether or not you were successful. Thanks

Gulster

0 Kudos
mike_laspina
Champion
Champion

Before the backup starts you must snapshot the VM usually with a script like this

vmware-cmd /vmfs/volumes/461e38c7-e35e9760-3cfd-00145e7b2384/VMName/VMName.vmx createsnapshot bs "Daily backup job snapshot." 1 1

and then remove the snapshot afterwards with

vmware-cmd /vmfs/volumes/461e38c7-e35e9760-3cfd-00145e7b2384/VMName/VMName.vmx removesnapshots

There should be a pre and post function in the backup app.

I use TSM so I can't tell you what NetBackup requires.

http://blog.laspina.ca/ vExpert 2009
0 Kudos
yaines
Contributor
Contributor

I have to agree with the above point. I'm trying to backup 7 VM's with vcbSnapAll and I kept getting the above error when backing up the Exchange VM and the File Server VM. All others worked fine. I saw this thread and as we do not use Consolidated Backup, there was no config.js file. I'd tried rebooting the VM but still the error appeared. However, when I removed the VMware tools and rebooted again, the VM backs up fine now.

Definitely worth a try but be warned - you will have to reboot the VM to complete the uninstallation!

0 Kudos
hugop
Hot Shot
Hot Shot

A VMotion of the troublesome VM to another host will also fix this problem.

0 Kudos
depping
Leadership
Leadership

look into this article, and try the work around described for Sun Solaris, might also work.

http://www.yellow-bricks.com/2008/04/29/vcb-and-solaris-32-bit-vms/

Duncan

My virtualisation blog:

0 Kudos
Jim_MT
Contributor
Contributor

Use the "-Q 0" option on the vcbMounter command line. The problems seems to be with the current version of VMtools.

0 Kudos
timfnb
Contributor
Contributor

My environment is:

BackupExec 11d

VCB 1.1.0.64559 (running on my backupserver)

BackupExec was set to run pre/post commands to mount/dismount the snapshot volumes

I was getting this error message after upgrading to ESX 3.5 and upgrading all of the tools. Before that, I wasn't receving this error and my backups were working fine. After the upgrade, snapshots would take so long that the VCB would time out. It would then leave the snapshot out there.

Last night, I removed the vmtools from 2 of my servers. It seemed to fix the problems I was having.

List of problems we were having:

1) On domain controllers, they would quit synchronizing changes

2) SQL Servers would halfway respond to requests or not at all

3) Oracle Servers would stop responding to requests

4) Snapshots would take forever to make from the VCB program (even manually)

0 Kudos
acarrascoctti
Contributor
Contributor

I've solve the problem reinstalling VMware tools in the vm.

0 Kudos
Jim_MT
Contributor
Contributor

It's noit fully a vm-tools issue even though in some instances it resolves the problem. It is a known bug in ESX 3.5.x and is on VMWare's list to rectify. Until then - the -Q 0 option takes care of the problem.

0 Kudos
chrille
Contributor
Contributor

Hi !

I solved the problem by migrate the server to antoher host Smiley Happy

/Christer Sundqvist

0 Kudos
senny
Contributor
Contributor

You solved may problem also. Option -Q 0 works.

But question: what does it do ?? I can't find any information about this option ...

If I'm blind please let me know ...

0 Kudos
Jim_MT
Contributor
Contributor

-Q 0 is an undocumented option - from what I understand it basically tells VCB not to look for any pre/post scripts.

0 Kudos
Gabriele_Solier
Contributor
Contributor

Hi !

I solved the problem by migrate the server to antoher host Smiley Happy

0 Kudos
tburger
Contributor
Contributor

Simple reinstall of vmware-tools and reboot of vm solved the problem.

Guest was Debian Linux 4.0r5

0 Kudos
calvinso
Contributor
Contributor

I solved all my 7 Fedora Core guest by the following steps

1. Reinstall VMware-tools, restart vmware-tools and network service

If 1 can't solve, goto 2

2. Migrate the vm to another host.

0 Kudos