informelYves
Contributor
Contributor

autostart VM from ESXI 6.5 web client

I just installed a new ESXI 6.5 server as a learning tool and have several VM already installed

I am using the web interface ( so, I did not installed anything on my laptop) and I am trying to find out the setting that would enable me to startup up a VM automatically.

Are  there options missing in the HTML client ?

18 Replies
rcporto
Leadership
Leadership

Click on the Virtual Machines on the left panel, select a virtual machine on the right panel, right click on the virtual machine and on Autostart, click on Increase Priority or Decrease Priority. And make sure Autostart is enabled click on Manage on the left panel, and click on Autostart.

---

Richardson Porto
Senior Infrastructure Specialist
LinkedIn: http://linkedin.com/in/richardsonporto
informelYves
Contributor
Contributor

Silly me

I had done the increase priority already, but did not saw that I had to enable it after that.

Thanks for the answer.

note "and click on Autostart." does not work for me, I have to click on edit to change the setting,

0 Kudos
glenndemm
Contributor
Contributor

Extra information:

on overview of virtual machines, you can add autostart information by right-clicking column header > Select Columns.

check Autostart order, Start Delay

some confusion over the wording:  increase priority seems to increase the start order (as in later start) - but could be caused by sluggish webclient

hth

0 Kudos
Squareball
Contributor
Contributor

Hi,

I have the same issue with a standalone ESX 6.5 server.

I've configured the host and client settings using the web client to allow a single server to auto start but it doesn't start. I've also checked the configuration from the full client and all looked fine.

I've even added the autostart parameter to the VM's vmx file but no joy.

So, I'm in a position where autostart worked fine with ESX 6.0 but doesn't work with 6.5.


Any ideas?

Sean

0 Kudos
dBottaro
Contributor
Contributor

Hi,

I'll simply echo the web interface to change the AutoStart priority is does not function as expected.  I have globally enabled AutoStart as described above and my guests DO start correctly.

However, the text in the increase/decrease priority is absolutely misleading.  It would indicate the higher the number, the earlier the autostart -- this is not the case.

The numbering is the same as old versions of VMWare where the autostart number is literally the order the guests will start in.

Also, sometimes the increase/decrease options don't actually DO anything on some guest listings.

Just my experience,

Dennis

0 Kudos
Nosella
Contributor
Contributor

Hi Yves

Guess you're looking about this steps:

1) On the left panel choose "Host and Cluster"

2) select the host with your Vms you want automatically power on

3) On the right panel click on "Configure"

4) Then on the "Virtual Machine" menù choose "VM Startup/Shutdown"

5) And then click on "Edit" to configure your VMs to auto startup and or shutdown

5Steps.png

Hope this can help you

Enjoy whit VmWare

Maurizio

zeusAtlanta
Contributor
Contributor

Nosella, your screen capture is from the vSphere web client.  This topic is for the ESXi web client which is quite different, unfortunately.

I too have the issue with priorities not changing, although at least at the moment I can't increase the priority (just doesn't do anything) but I can manipulate the list by decreasing other machines and achieve the desired order.

Presumably as others have said 1 starts first, then 2, and so on.  That isn't clear, nor documented, and is the complete opposite of what the button claims (decreasing a machine at order 2 changes it to 1, not 3).

It is somewhat mind blowing that there are these issues with the ESXi web client... doesn't give me a great feeling about relying on it in a small office (where we have no budget and vSphere is unnecessary and out of the question).

0 Kudos
JesserM
Contributor
Contributor

Hi,

There is a Autostart "Master Switch" in ESXi Web Client that must be set to "Yes".

esxi_autostart.png

After that you can set start delay and priority individually for your VMs.

Regards,

Jesser

K_Faisal
Enthusiast
Enthusiast

Does vCenter 6.5 has a new Function, do enabling Autostart in a host in HA Cluster will work?

Thank You.
0 Kudos
herdesh
Contributor
Contributor

Hello All,

I am using HTML client for managing VMware ESXi 6.5ui host and i'm trying to enable the Autostart feature.

For this, i have done the following this:

    1. Under the option Host -> Manager -> Autostart, i have enabled the autostart feature.
    2. Also enabled the Autostart feature by right clicking the VM.

My Question

When i restart the host, Autostart feature (enabled in STEP1) automatically  goes disabled.

Thanks in advance..!!!!!

0 Kudos
sp46887
Contributor
Contributor

I had the same problem with ESXi 6.5. Some VMs didn't autostart after bringing ESXi host up. I'm using the embedded web client.

Solution:

I simply de-registered and re-registered the VMs and now all is working.

It seems to be an issue, hopefully fixed in newer versions.

BarryChung
Contributor
Contributor

VMWare ESXi 6.5 AutoStart.PNG

  1. Right Click on any column and left click on "Select columns" -> check "Autostart order".
  2. Right Click on the VM with "Autostart order: Unset" -> "Autostart" -> "Increase" to enable autostart and set the order.
  3. Keep decreasing the "autostart order" on an VM until lower than "1", it becomes "Unset" which will disable "Autostart"

PS.  Make sure you have enabled the Autostart under "Host" -> "Manage" -> "System" -> "Autostart".

0 Kudos
AdeyWare
Contributor
Contributor

Hi ,

My ESXi 6.5 did not autostart VMs on power up of the server. The other posts are correct in that auto startup needs to be enabled,

This did not work until I had Patched my ESXI 6.5 server with the updates, it is now far less "buggy" and everything now works so much better.

https://my.vmware.com/group/vmware/patch#search  to see all the patches.  Use putty to apply the patches.

regards

Ade

isukhov
Contributor
Contributor

Tried all these recommendations regarding enabling auto-start in WEB interface of standalone ESXi 6.5.0 build 4887370 and it were useless

Unregister/Register VM did not work also

It looks like WEB interface has some issue with setting up variables, for quick fix CLI can be used.

https://serverfault.com/questions/788350/how-do-i-tell-esxi-5-5-to-autostart-virtual-machines-from-s...

[root@localhost:~] vim-cmd hostsvc/autostartmanager/get_autostartseq

(vim.host.AutoStartManager.AutoPowerInfo) [

   (vim.host.AutoStartManager.AutoPowerInfo) {

      key = 'vim.VirtualMachine:3',

      startOrder = 1,

      startDelay = -1,

      waitForHeartbeat = "systemDefault",

      startAction = "powerOn",

      stopDelay = -1,

      stopAction = "systemDefault"

   }

]

[root@localhost:~] vim-cmd vmsvc/getallvms

Vmid    Name                  File                   Guest OS       Version   Annotation

3      CentOS7   [SSDslot4] CentOS7/CentOS7.vmx   centos7_64Guest   vmx-13             

[root@localhost:~] vim-cmd hostsvc/autostartmanager/enable_autostart true

Enabled AutoStart

[root@localhost:~] vim-cmd hostsvc/autostartmanager/update_autostartentry 3 powerOn 5 1 systemDefault 1 systemDefault

1Updated AutoStart order.

[root@localhost:~] vim-cmd hostsvc/autostartmanager/get_autostartseq

(vim.host.AutoStartManager.AutoPowerInfo) [

   (vim.host.AutoStartManager.AutoPowerInfo) {

      key = 'vim.VirtualMachine:3',

      startOrder = 1,

      startDelay = 5,

      waitForHeartbeat = "systemDefault",

      startAction = "powerOn",

      stopDelay = 1,

      stopAction = "systemDefault"

   }

]

0 Kudos
daphnissov
Immortal
Immortal

You are very behind on patches, including Update 1. Apply all patches and try again.

0 Kudos
ohlssrog
Contributor
Contributor

Notice.

This can only be found in flashversion, not available in html5

0 Kudos
PsYcHLT
Contributor
Contributor

Yo uare life saver!

0 Kudos
cicco171
Enthusiast
Enthusiast

Old question but could help someone

I've find the solution on this post

autostart VM from ESXI 6.5 web client — mecdata.it

0 Kudos