Shafay2000
Enthusiast
Enthusiast

HP P420i/P440i HBA Mode = on ( If you want to use embedded controller on DL series without the smart RAID and just as passthrough/HBA/ ITMode/JBOD controller

After weeks of trial and error, finally figured out how to bypass the "SMART RAID" feature on HP Embedded controller and use it for vSAN. Here is the procedure worth my time to share with you:

To enable hba mode on HP P420i RAID controller on ESXi 5.5 here is the procedure that worked for me … just now.. HPSSACLI for ESXi 5.5, vibs are available for individual download and its also built in the HP customized ESXi 5.5U1 iso .

syntax http://h10032.www1.hp.com/ctg/Manual/c03934591.pdf

Pre-reqs:

Make sure disks are wipe clean and no RAID exists

Make sure FW is latest v5.42

Make sure ESXi device driver is installed v5.5.0-44vmw.550.0.0.1331820  http://www.vibsdepot/hpq/feb2014-550/esxi-550-devicedrivers/hpsa-5.5.0-1487947.zip

Put host in MM, from ilo of ESXi in support mode (Alt+F1) execute the following

To View controller config using HPSSACLI with ESXCLI

~ # esxcli hpssacli cmd -q "controller slot=0 show config detail”

To enable HBA mode on P420i using HPSSACLI

~ # esxcli hpssacli cmd -q “controller slot=0 modify hbamode=on forced"

Reboot the host & perform a scan and walah … disks will show up in vSphere web client for vSAN

27 Replies
joergriether
Hot Shot
Hot Shot

Please check the VSAN HCL.

VMware Compatibility Guide: vsanio

As for this time, only indirect passthrough via detour with RAID0 is supported.

May one of the vmware engineers around can comment on this one.

0 Kudos
smonborgne
Enthusiast
Enthusiast

Hi,

I'm currently deploying a design based on hp p420 too and would be really interested regarding the support of this configuration.

It would make installation and hardware monitoring much easier if we could avoir using Raid 0.

Sylvain

0 Kudos
jesse_gardner
Enthusiast
Enthusiast

For what its worth, I'm in discussions with HP and VMware on the supportability of this configuration.  Just got the following back from VMware:

"...we are working with HP on getting JBOD support for this controller but this will take a while. Btw – this controller has exhibited poor performance in the past compared to H220i which supports JBOD mode by default.  Therefore, I recommend the customer procure H220 instead if possible."

0 Kudos
zdickinson
Expert
Expert

From the original post:  "built in the HP customized ESXi 5.5U1 iso"  I believe you're not supposed to use the customized ISOs, but to use the vanilla download from VMware.  Then install the HCL specified drivers, firmware, etc...  I would confirm with another source.  Thank you, Zach.

0 Kudos
SCMHenry
Enthusiast
Enthusiast

FWIW, the P440ar controller in the Gen9 series of servers supports passthrough mode by enabling HBA mode using the HPSSA.

Setting up VSAN was straightforward, but as I just did this today, no opportunity to evaluate performance or reliability yet.

Clipboard02.jpg

0 Kudos
crosdorff
Enthusiast
Enthusiast

The P440ar is not on the HCL (yet).

So don't use it in a production environment.

0 Kudos
rainer_d
Contributor
Contributor


So, the HCL has been updated and the controller is now on it:


http://www.vmware.com/resources/compatibility/search.php?deviceCategory=vsanio&productid=37445&devic...


But, it says "Disk hotplug feature is not supported on the driver."


What does that mean?


Isn't that the whole point of the pass-through mode?


 


 

0 Kudos
zdickinson
Expert
Expert

It means that passthrough mode is not supported, you will need to use RAID 0.  To replace a failed drive you cannot hot swap.  You will need to down the host, replace the drive, setup the new drive as RAID 0, and then have vSAN claim the disk if you have the cluster set to manual.  Thank you, Zach.

0 Kudos
SCMHenry
Enthusiast
Enthusiast

The P440 is now supported in passthrough mode according to the updated HCL.

0 Kudos
rainer_d
Contributor
Contributor


Interesting.


Seems somebody changed it almost right after I posted Smiley Wink


I must try the pass-through mode sometime - if it actually works like the H220 (or rather any LSI controller with IT firmware), a lot of our problems would be solved...


 


 

0 Kudos
Mackopes
Enthusiast
Enthusiast

Anyone have any more experience with these? (Doing passthrough mode with a P440ar?)

We are looking at implementing vSAN with DL380 gen9, and also have noticed the lack of hardware monitoring with the H220)

AK

0 Kudos
raz1
Contributor
Contributor

Hi,

I'm having problems getting this to work correctly.  I have 3 HP DL380 Gen 9 servers with P440AR, which is on the compatability list as Pass thru supported.  However, I'm not sure what settings I need...

If I enable HBA mode and disable Passthrough the host can see the local disk, although vsan wizard only recognises 8 of 10 Sata disks and non of the SSD (there are 2 of them)

If I enable HBA mode and enable passthrough the host cannot see any of the local disk

the esx install is a HP customised version so I don't think its a driver issue but I notice the hcl has the following footnote.  Do I need to install this driver? 

Footnotes  :Virtual SAN 6.0 can only support internal drives and cannot be used with the external capabilities of this controller.

Download driver from https://my.vmware.com/web/vmware/details?downloadGroup=DT-ESXI55-HP-HPSA-550741OEM&productId=353

0 Kudos
jonretting
Enthusiast
Enthusiast

Be sure to remove all existing partitions on your storage and flash disks. For example relable them using the host ESXi shell:

%$  partedUtil mklabel /dev/disks/naa.#### msdos; partedUtil mklabel /dev/disks/naa.#### gpt;

Or you could boot to a live ISO and use "parted" if you so choose.

Remanence of previous partitions will cause problems when associating disks/flash with a VSAN.

Good luck.

0 Kudos
magnusvr2
Contributor
Contributor

Thanks very much for this!

I just got this working on a customers DL380p (Gen8) with a P421i, card with esxi 6.0. The drives would show under Datastorage, but VSAN would not find them. There is also a H200-card with 8 drives, those work fine.

HBA Mode did not work, after switching to HBA mode I could see 0 drives on the P421i. I then had a look in the compability chart and found that only raid0 was a supported solution. But still no drives visible in VSAN.

The solution was to download and install the HP tools and HP driver from HP and install them via Update Manager. (The customer had not used the HP custom installer)

This one: https://my.vmware.com/web/vmware/details?downloadGroup=DT-ESXI55-HP-HPSA-550741OEM&productId=353

and this one: http://h20564.www2.hpe.com/hpsc/swd/public/detail?sp4ts.oid=5194969&swItemId=MTX_de3fef1d76d04a9abfd...  (HP ESXi Utilities Offline Bundle for VMware vSphere 6.0)

I put them into one Vmware Update manager package, installed, went into CLI and did these:

Check if there are any volumes on the drives of the P421i (Note: My server boots from SD-card, I have nothing to be careful about, on the p421. You may have a boot mirror that you don't want to delete!"

esxcli hpssacli cmd -q "controller slot=0 ld all show"

If so; delete them:(Note: My server boots from SD-card, I have nothing to be careful about, on the p421. You may have a boot mirror that you don't want to delete!)

esxcli hpssacli cmd -q "controller slot=0 ld1 delete forced"  (erases Logical disk 1)

create a pair of Raid 0's:

esxcli hpssacli cmd -q "controller slot=0 create type=ld drives=1I:2:1 raid=0"

esxcli hpssacli cmd -q "controller slot=0 create type=ld drives=1I:2:2 raid=0"

Rescan storage adapter through vmware gui.

Now, claim the drives in VSAN webgui.

KR

Magnus

0 Kudos
GeertW
Contributor
Contributor

Jesse wrote that VMware was working on getting JBOD support for this controller. However, HCL still states that only RAID0 is supported.

Anyone knows whether JBOD will ever be supported for this controller?

Regards, Geert

0 Kudos
JoeDDfS
Enthusiast
Enthusiast

Hi,

I have DL380 Gen9 with HBA mode enabled. vSAN 6.1 with proper HCL driver. I am unable to lit LEDs on drives. I have tire via GUI (seems ok, but no LEDs blinking) and via cmdline error appear: "HPSSACLI call in HPSAPlugin_SetLedState exited with code 1! (from lsu-hpsa-plugin)"

Have you anyone same experience?

thank you for your replies

0 Kudos
Mackopes
Enthusiast
Enthusiast

I believe this is a 'known issue' with the HP Driver. We need to bug HP about getting a proper driver that can blink the LED.

0 Kudos
mdegrasse
Contributor
Contributor

Flashing the LED on the drives is only supported by the P440 controller in RAID mode (not supported by VSAN).

This is stated in the Smart Array Documentation by HP Smiley Sad

I highlighted this in my blog

VMWare VSAN with HP DL380 Gen9 and P440 HBAs | pcdmarc

0 Kudos
Pupkin_Petr
Contributor
Contributor

mdegrassemdegrasse,

Read your article , there is the question. It is possible to use one HBA 440ar in conjunction with SAS Expander Card for 24 SFF disk?

0 Kudos