CamiloMesias
Contributor
Contributor

VM Web Console not working in Firefox in PAM

Hi,

I am trying to understand an issue where I can connect fine to the web console of a VM when accessing from a corporate browser, but not from a segregated PAM (privileged access management) system.

The PAM system has connectivity, and I can log in and browse the UI as far as the VM. It is based on Firefox running in a container in a Linux server in the cloud.

When I try to connect to a web console, from the corporate browser, a small popup appears and within that, the console is soon accessible, as a separate browser window.

When I try the same steps from the PAM system, the click to open the console replaces the browser window content with the popup content (no additional window appears). The content is the decorations from the console window - "Full screen" / "ctrl+alt+del" / "options" and the string wmks.connecting.

I can open a debug console and see a message "Dispatching ticket request" with some kind of ID following. But nothing else happens in the UI. I suspect that the main window being unloaded because the popup content replaces it, is destroying whatever would respond to that ticket request. Apart from that I don't have many clues.

Can anyone help or suggest any ideas?

0 Kudos
2 Replies
Sreec
VMware Employee
VMware Employee

Are you trying to access VCD VM Console VM via PAM or vCenter VM console?

Cheers,
Sree | VCIX-5X| VCAP-5X| VExpert 6x|Cisco Certified Specialist
Please KUDO helpful posts and mark the thread as solved if answered
Tags (1)
0 Kudos
CamiloMesias
Contributor
Contributor

Hi Sree,

I believe this is VCD not vCenter - accessed over the web,

-Camilo

0 Kudos