VMware Communities
matthewls
Enthusiast
Enthusiast

ws11 linux host win7 guest sound problems fixed

My Windows 7 virtual machine upgraded from workstation 10 to workstation 11 had several problems I reported before, including locking up the machine and crashing when I was trying to fix the audio. In workstation 10, both the microphone and the speakers piped through ALSA worked fine, whereas in 11 the sound was filled with static and the microphone input processing was both slow and barely working. My litmus test is Dragon NaturallySpeaking. The distorted sound output led me to test a Linux virtual machine in which the sound was perfect, suggesting that something about the Windows setup was incorrect.

In any case a knowledge base article on fusion led me to the fix, which was editing the.VMX file and commenting out "sound.virtualDev = "hdaudio."

I'm posting this in case anyone else has similar problems.

4 Replies
peterbucher
Contributor
Contributor

Can confirm this works in Windows 8.1 on VMare Workstation 11 :smileygrin:

Reply
0 Kudos
toineeetgerink
Contributor
Contributor

Thanx

That was the trick, now the sound is perfect

Regards Toine

Reply
0 Kudos
Lykaestria
Contributor
Contributor

Thanks a bunch, I had tried changing other settings in my guest and in my VMware settings but nothing seemed to fix the intermittent scratchy audio. Changing sound.virtualDev = "hdaudio." to #sound.virtualDev = "hdaudio." within the vmx file was the solution though.

jhiamnot
Contributor
Contributor

Thank you!  works in WS12 also --- host is debian jessie running a Win 8.1 work station

Thanks!

Reply
0 Kudos