vmApprentice01
Enthusiast
Enthusiast

will 15.5.6 work on Windows 10, version 1909 with hyper-V enabled?

Jump to solution

The release notes for 15.5.5 has 'Windows 10 20H1 build 19041.264 or newer' for Supported Host Operating System.

15.5.6 doesn't specify the minimum host.

I've got Windows 10, version 1909 with hyper-V.

20H1 doesn't even show up as a possible install.

Can I run 15.5.6 with hyper-V with version 1909?

Do I need to make any changes, such has disabling credential guard?

https://www.tenforums.com/tutorials/68935-enable-disable-credential-guard-windows-10-a.html

Thanks!

0 Kudos
1 Solution

Accepted Solutions
vmApprentice01
Enthusiast
Enthusiast

Had two new DELLs to experiment with.

I found that 15.5.6 would Not run on win10 1909 with hyper-v, but would run on Win10 2004.

View solution in original post

0 Kudos
5 Replies
a_p_
Leadership
Leadership

Version 15.5.6 fixed some nasty issues, but the system requirements remain the same as for version 15.5.5.

André

0 Kudos
vmApprentice01
Enthusiast
Enthusiast

Ok, but will 15.5.5 run on 1909?

I saw this thread which seemed to indicate 15.5.5 would run on an even Older 1809/1903 with credential guard disabled, but ... if so, why would the release notes seem to indicate the 20H1 requirement?

0 Kudos
Mits2020
Hot Shot
Hot Shot

There's much confusion about this... from what I understand:

1. If you need hyper-v features enabled and running concurrently with Workstation you need both WS version at least 15.5.5 & Win10 at least 2004 (aka 20H1)

2. If you don't need the hyper-v features you must disable them to run any version of WS earlier than 15.5.5

The above are necessary but not sufficient to guarantee 100% that someone with 1809/1903 will be able to run WS 15.5.5, therefore occasional weird cases appear in the WS Community and elsewhere. If you have available a second PC for experimenting, trial and error is the best strategy. If not, make restore points, backup VMs and try on your main PC, ensuring that you uninstall your current WS version completely before trying a new one and taking into account that the WS installers don't support downgrading very well.

The release notes are a bit vague and imho are a bit biased towards the needs and aspirations of people needing the latest and greatest stuff from Workstation together with the ever-changing bar of features/requirements set by Microsoft after each update. Beginners to virtualisation and users decided to stick with what works robustly are (and should be) hesitant to upgrade a system that just works. Therefore the questions like yours are totally valid, non-trivial and should be answered before experimenting with upgrades, especially given that each PC is its own mini-universe with its own maleficent ghost living inside©

I am afraid there are too many variables involved and somebody should compile a multidimensional compatibility matrix along several axis:

Win10 Home             ----   Win10 Pro+

Win Versions <2004 ----   Win Versions >2004

Hyper-V enabled       ----   Hyper-V disabled

Workstation              ----   Player

WS/P <15.5.5           ----   WS/P >15.5.5

hotvooboy
VMware Employee
VMware Employee

Hi vmApprentice01,

Thank you for posting your query in community.

In case of you want running Workstation on a Hyper-V Enabled Host,then the host OS  is require as win10 20H1, if you don't need to run Workstation on a Hyper-V Enabled Host, you can ignore this requirement.

Thanks.

0 Kudos
vmApprentice01
Enthusiast
Enthusiast

Had two new DELLs to experiment with.

I found that 15.5.6 would Not run on win10 1909 with hyper-v, but would run on Win10 2004.

0 Kudos