vmware_justnewb
Contributor
Contributor

""Binary translation is incompatible with long mode on this platform. Disabling long mode"

Hi,

VMware newbie here.

Just now installed VMware Workstation 9 on a Lenovo ThinkPad W520 running Windows 7 64-bit. The CPU for the ThinkPad is a Quad-Core CPU, specifically an Intel Core i7-2720QM.

I downloaded and ran VMware's utility "Processor Check for 64-Bit Compatibility"  (specifically, "VMware-guest64check-5.5.0-18463.exe") and the output from running that utility is a popup window, that has the following message:

"This host is capable of running a 64-bit guest operating system under this VMware product"

Everything looked OK at that point.

Then I obtained a VMware virtual image (of a Windows Server 2008 R2 machine), and opened it in VMware workstation, and clicked on

Power > Power On

and then a popup with the following message appeared:

"Binary translation is incompatible with long mode on this platform. Disabling long mode. Without long mode support, the virtual machine will not be able to run 64-bit code. For more details see http://vmware.com/info?id=152."

That's a problem for me, in that I do need to run 64-bit code.

If anyone knows how I can resolve this, it would be appreciated if you could let me know how.

17 Replies
vmware_justnewb
Contributor
Contributor

I am reporting back.

I was able to resolve the problem that I was experiencing.

Intel Virtualization Technology (VT) is "disabled" by default, in the BIOS of the Lenovo ThinkPad W520.

I shutdown the W520, then started it. Once the ThinkPad splash screen appeared, I pressed the F1 key to enter the BIOS.

Within the BIOS, I chose the "Security" option/tab. Under that option, I chose the "Virtualization" option.

Thereunder was the following:

Intel (R) Virtualization Technology  [Disabled]

I changed that to "Enabled".

Saved and Exited from the BIOS.

Now, when I open the VMware virtual machine, and then click on Power > Power On, I no longer get the popup message about not being to run 64-bit code.

I am very relieved that the problem is now resolved !

dancoleby
Contributor
Contributor

Really helpful. Thanks. Had the same problem on my Lenovo Yoga 13 and this solution worked a treat!

0 Kudos
sellersdo
Contributor
Contributor

Agree, this is a valuable reminder to always check the virtualization support in the BIOS.

To the VMware folks, two comments:

     1, A better error message than the text above would be a BIG HELP for your user community.

     2, When I received this on my HP machine I was familiar enough to guess what was wrong,

         however the error pointed me to:

          http://www.vmware.com/info?id=152

         and that link is broken.  (Results in an access denied error.)

        Similarly, two other links just sent to me by VMware support -- Access Denied

        Maybe check information server configuration?

0 Kudos
admin
Immortal
Immortal

Which version of Workstation are you running?  You should be getting a more informative message, like this:

VT-x.png

0 Kudos
Leeaa
Contributor
Contributor

I am running version 10.0.4 and I do not get the long message, I get the useless short one. I tried his fix and it did not solve it for me.

Lee

0 Kudos
admin
Immortal
Immortal

Can you post your vmware.log file (as an attachment)?

0 Kudos
Leeaa
Contributor
Contributor

PEBCAK

It works now.

Lee

0 Kudos
majidkurdi
Contributor
Contributor

hello

i have a problem

on install windows sever 2012 X64

pleas help me

thnnks for your help

majid.kurdi2@gamil.com

0 Kudos
Deep19
Contributor
Contributor

Hi all,

i have same problem and i did enable my VT on bios and tried to power on virtual machine but still same error.

is there anything beside enabling vt on bios??

thank you

0 Kudos
admin
Immortal
Immortal

0 Kudos
kimsharma1101
Contributor
Contributor

Hello, I am also getting the same error with these messages

Binary translation is incompatible with long mode on this platform. Disabling long mode. Without long mode support, the virtual machine will not be able to run 64-bit code. For more details see http://vmware.com/info?id=152.

Mac OS X is not supported with binary translation. To run Mac OS X you need a host on which VMware Workstation supports Intel VT-x or AMD-V.

And I enable the Visualization setting... but still getting the same error..

My System details are-

Processor: Intel(R) Premium (R) CPU B940 @ 2.00GZ

RAM: 2GB

system type: 64 bit

Window 7 service pack 1

I am trying to open Mac (OS X Mavericks 10.9 Retail VMware Image)  on VMware-workstation-full-9.0.0-812388

Please tell me any solution...It is very necessary for me to start my work..

0 Kudos
a_p_
Leadership
Leadership

There are a couple of points to mention in this case:

1. According to the Intel specs sheet, your CPU doesn't support VT-x

2. I'm afraid that even if you were able to run such VMs, you'd wouldn't be very happy without sufficient host resources (e.g. RAM)

3. Running OS X on non-Apple hardware violates Apple's EULA, i.e. you'd need e.g. a MAC with VMware Fusion

André

0 Kudos
chubbson
Contributor
Contributor

Got same problem.


First at all, im trying to configure hyper-v and vm ware to running at the same time.

Was following this link (hyper-v was installed first):

http://www.kurzhals.info/2014/01/using-hyper-v-windows-phone-emulator-and-vmware-workstation-paralle...


what i did:

ive deactivated hyper-v role by running following command in ps (admin mode)

> bcdedit /set hypervisorlaunchtype off

> (restarted computer)


i can run my vm player and start any win8 64bit os instance, everything works fine.

now i've activated the hyper-v role again by running following command in ps (admin mode)

> bcdedit /set hypervisorlaunchtype auto

> (restarted computer) 


(same issue without or with the config entry in vmx file  'vmx.nestedmode = "TRUE"')

if i try to start the vm player with the given win8 64bit os instance, im running in that failure too:

[Binary translation is incompatible with long mode in this platform. Disabling longmode ...]


ive checked the Intel Virtualization Technology in BIOS.

Its already enabled.


Now im stuck, how to configure vm vare and hyper-v in parallel mode

0 Kudos
admin
Immortal
Immortal

ive checked the Intel Virtualization Technology in BIOS.

Its already enabled.

Unfortunately, Hyper-V does not virtualize Intel Virtuialization Technology, so the virtual CPU on which you are running the management OS doesn't have this feature.

Now im stuck, how to configure vm vare and hyper-v in parallel mode

You can't.  Once you install Hyper-V, the management OS runs inside a Hyper-V VM.  Hyper-V takes over the machine and will not run in parallel with any other hypervisor.

In your current configuration, VMware is running under Hyper-V.  We can only use the CPU features that Hyper-V offers, and Intel Virtualization Technology is not one of them.

The alternative configuration is to run Hyper-V under VMware.  VMware does virtualize Intel Virtualization Technology, so you can run Hyper-V in a VMware VM.

0 Kudos
HEALER1212
Contributor
Contributor

Hello. am also getting the same error with these messages

binary translation is incompatible with long mode on this platform.Disabling long mode. without long mode support. the virtual machine will not be able to run 64-bit code. For more details see http://vmware/com/info?id=152.

Mac Os X is not supported with binary translation.To run Mac OS X you need a host on which VMware Workstation supports Intel VT-X or AMD-V.

And I enebled the visualization setting.... but still getting the same error...

my system details are-

processor:Inter(R)Oentium(R) CPU N3530 @ 2.16GHz (4 CPUs),~2.2GHz

RAM: 4GB

SYSTEM: WINDOWS 10 PRO 64-BIT

I'm trying to open Mac(OS X10.11 El Capitain VMware Image) on VMware -12 player non-commercial use only

please tell me a solution i need to start my work

0 Kudos
wila
Leadership
Leadership

Hello Chris,

Welcome at the VMware communities forum.

Unfortunately Apple does not allow you to run a virtual macOS or OS X on non-Apple branded hardware.

Since this violates Apple's EULA (and as such the VMware Community Terms of Use), any issues you have with trying to run macOS or OS X using VMware Workstation or VMware Workstation Player cannot be discussed at this forum.

You'll need to have apple hardware and use a product like VMware Fusion or VMware ESXi and run a virtual copy of macOS / OS X on that in order for us to be able to help you.

Hope you understand,

--

Wil

| Author of Vimalin. The virtual machine Backup app for VMware Fusion, VMware Workstation and Player |
| More info at vimalin.com | Twitter @wilva
0 Kudos
eldogg
Contributor
Contributor

Be advised - on my new Thinkpad P50, there are actually TWO places in the BIOS settings where the Intel Virtualization Technology has to be turned on in order for it to be enabled. There is a setting within the Processor settings and one within the Security settings. The one in the processor settings was enabled and I still received the error and was scratching my head. Both must be enabled.

0 Kudos