Armadillo201110
Contributor
Contributor

"incorrect vmx86.sys" problem with Workstation 8 on Windows 7 x64

Jump to solution

I've just upgraded to Workstation 8 (Windows 7 x64) and am getting the following error when I try to create VMs:

"Could not get vmx86 driver version: The handle is invalid. You have an incorrect version of driver "vmx86.sys". Try reinstalling VMware Workstation. Failed to initialize monitor device."

If I do, "Run As Administrator" I can get it to work.

Tried uninstalling and reinstalling.

VMPlayer doesn't seem to work either - even with "Run As Administrator". It just hangs.

I've also noticed that I can't edit the priority settings in the preferences - unless I do "Run As Administrator". I'm logged in as an administrator account.

So, there seems to be some generally permissions issue - although that still doesn't seem to fix Player.

0 Kudos
1 Solution

Accepted Solutions
Luca93z
Contributor
Contributor

I bet your firewall is Comodo.

I had the same warning! Follow the steps and you'll enjoy Workstation without Administrator's privileges:

1) Open Comodo

2) Go on Defense +'s Tab

3) Defense+ Settings

4) Execution Settings

5) on Exceptions add C:\Program Files (x86)\VMware\VMware Workstation\vmware-vmx.exe if u are using 32bit OS, else C:\Program Files (x86)\VMware\VMware Workstation\x64\vmware-vmx.exe!

Confirm pushing OK!

...

...

and enjoy your Workstation 8!

Sorry for my bad english.

See ya!

View solution in original post

0 Kudos
24 Replies
Felix-The-Cat
Enthusiast
Enthusiast

Hello Armadillo,

Thanks for posting and sorry to hear you have a problem with WS 8.

I'll rerout your concern to the right person, but to speed-up investigation, could you please give us more info regarding:

1. Host config.

2. You mention "just upgraded to Workstation 8", from ...?

3. Could you please attach UI Log (Help->About->UI log file)?

---------------

Cheers 

0 Kudos
admin
Immortal
Immortal

Please attach the vmware.log file from the VM's directory too.

Also, have you rebooted since installing Workstation?

0 Kudos
Armadillo201110
Contributor
Contributor

I'm away from the office for a few days, but I'll get those logs on my return. In the meantime, the answers to your other questions follow.  I upgrade to Workstation 8 from the latest version of 7.  I've rebooted after every install/uninstall.

0 Kudos
scmp
Contributor
Contributor

I am also having the same problem, how to solve?

0 Kudos
admin
Immortal
Immortal

scmp wrote:

I am also having the same problem, how to solve?

Could you provide the logs we asked for?

0 Kudos
eurocg
Contributor
Contributor

I am having the same issue.

Cannot run unles I choose "run as admin"

I have attached my log file and my machine is as follows:

Windows 7 Pro 64bit SP1

8180 Memory

Intel i7 Quad Core @ 1.6Ghz

0 Kudos
Krok
Contributor
Contributor

comodo firewall again?  Smiley Happy

same trouble,  work only with "run as admin"

bug report https://forums.comodo.com/bug-reports-cis/vmware-workstation-80-doesnt-function-properly-with-comodo...

0 Kudos
admin
Immortal
Immortal

I don't think you attached the correct UI log.  That log shows that you did manage to successfully power on a VM.

Also, the vmware.log from the VM's directory is more important.

Finally, does adding your user to the __vmware__ group help?

0 Kudos
eurocg
Contributor
Contributor

Here is the log showing the failure

0 Kudos
a_p_
Leadership
Leadership

FYI: The error does not seem to be related to only WS 8. In OS config fails after fresh VMware player installs. a user sees the same error message running VMware Player 3.1.x on Windows 7.

André

0 Kudos
Luca93z
Contributor
Contributor

I bet your firewall is Comodo.

I had the same warning! Follow the steps and you'll enjoy Workstation without Administrator's privileges:

1) Open Comodo

2) Go on Defense +'s Tab

3) Defense+ Settings

4) Execution Settings

5) on Exceptions add C:\Program Files (x86)\VMware\VMware Workstation\vmware-vmx.exe if u are using 32bit OS, else C:\Program Files (x86)\VMware\VMware Workstation\x64\vmware-vmx.exe!

Confirm pushing OK!

...

...

and enjoy your Workstation 8!

Sorry for my bad english.

See ya!

0 Kudos
Krok
Contributor
Contributor

Defence+ is totally disabled (not installed )  Smiley Happy

0 Kudos
komugi
Contributor
Contributor

The solution above does work, which seems to say, even when you disable Defense+ on Comodo, it isn't completely disabled, it seems. I added exclusion for all programs (extensions), and now Vmware works.

Odd since I had Defense+ disabled from the get go.

0 Kudos
Luca93z
Contributor
Contributor

Do that, then we will see if it works :smileysilly:

0 Kudos
Luca93z
Contributor
Contributor

Dude just do what i said, it's not necessary to except every exe.. it's not a good idea Smiley Happy do an exception for C:\Program Files (x86)\VMware\VMware Workstation\vmware-vmx.exe and stop :smileysilly: it will work! (if 64 bit -> C:\Program Files (x86)\VMware\VMware Workstation\x64\vmware-vmx.exe

0 Kudos
Krok
Contributor
Contributor

do you see smile in the end of clause?  it was for wastemakers from comodo

"solution" works

0 Kudos
Armadillo201110
Contributor
Contributor

Thanks. Yes, I do have Comodo and your clear instructions solved my problem.

0 Kudos
AMach
Contributor
Contributor

I've just installed VMware Player update to version 4.0.0 build 471780 (previously had version 3.1.4) and started having the same problem; I've added those exclusions to Comodo's Defense+ (but for "C:\Program Files (x86)\VMware\VMware Player\vmware-vmx.exe" and "C:\Program Files (x86)\VMware\VMware Player\x64\vmware-vmx.exe") and it worked.

So it's confirmed to work also for VMware Player (didn't have to do that on previous version, but only now with version 4.0.0).

Thanks.

0 Kudos
AMach
Contributor
Contributor

And congrats, Luca93z, since although being a Novice (as reported by Commnunity Forum), you've found the answer while Enthusiasts, Masters, VMware Employees, Gurus, vExperts didn't.

0 Kudos