HHelen
Contributor
Contributor

Workstation: Losing focus (mounse ungrabs) outside area of 640 x 480 (vga resolution)

Mouse cursor covers only an area of 640 x 480 (vga resolution), mouse cannot reach area left and below this are and ungrabs inside guest. It is only possible to do <ctrl><g> inside the vga area twice, after that only clicking in the menu brings back focus into the vga area again. Happens on every guest OS with resolution higher than 640x480 -since installing 6.5.3

Serching in alls databases give me the certainity: I'm the first one again™ to whom this happens Smiley Wink

Very annoying and therefoe very annoyinf custmer.

Tags (1)
0 Kudos
38 Replies
ciberandy
Contributor
Contributor

I've been having this exact problem for 2-3 months now and can't find a solution.

So, I was really happy to find this a few days ago:

I remove the "USB Device" from the VMware settings for the VM itelf.Unfortunately, this doesn't work for me. Even with the virtual PS/2 mouse, my Win XP show's this behaviour.

This is so annoying. sigh

My workaround now is to use a VNC client to connect to the virtual machine, but this can't be more than a workaround.

There has to be real solution, right?

VmWare guys, are you listening???

You have been doing such a wonderful work for the last 10 years (I am one of your first customers!)

Please don't screw it up now!

Please let me know if I can help somehow.

Here is some more information about the bug:

  • my OS is Ubuntu 9.04 (with all patches), 64bit on my workstation, 32bit on my laptop.

  • my (most used) guest OS is WinXP-SP3 (with all updates)

  • I've been trying with VmWare Workstation 6.5.1, 6.5.2, 6.5.3 - no difference

  • I restored a snapshot from April 2008 - same problem

  • I restored a snapshot from June 2007 - mouse ungrab works, but autograb doesn't (when entering the VmWare window with the mouse)

Hope this helps a bit to track down the bug.

Bye,

Andy.

edited by ciberandy (more technical information)

0 Kudos
298
Contributor
Contributor

Same problem here. This problem is extremely annoying and I'd appreciate it if VMWare could look into this and release a fix before Ubuntu 9.10 is released.

Host: Ubuntu Karmic, latest alpha version, out of the box install with pae kernel, VMWare Workstation 6.5.3 or Player 2.5.3 (same problem in both).

Guest 1: Windows 2000 Advanced Server, VMTools upgraded.

Guest 2: Debian 4, VMTools upgraded.

Whether the host is running Gnome with Compiz or Metacity makes no difference.

For me this problem exists only with WS 6.5.3 / P 2.5.3 on Ubuntu 9.10. I don't have this problem with any WS version on 9.04. I didn't try older WS versions on this new Ubuntu.

0 Kudos
fredsey
Contributor
Contributor

I researched this issue about a month ago and found this article:

http://forums.gentoo.org/viewtopic-t-783680.html

In summary, apparently the issue is the newer version of GTK. The somewhat good news is it looks like at least VMware 6.5.3 comes with it's own version of GTK. There's a wrapper script called wrapper-gtk24.sh with the distribution. According to this script, if you set the environment variable:

export VMWARE_USE_SHIPPED_GTK=yes

or

export VMWARE_USE_SHIPPED_GTK=force

before launching VMware, it seems to work just fine.

-f

0 Kudos
298
Contributor
Contributor

Thanks, fredsey. Works for me as well. This is really good. Smiley Happy

I simply edited /usr/bin/vmware and /usr/bin/vmplayer and added this variable setting in both of them.

0 Kudos
Bulgroz
Contributor
Contributor

I do not have internet at home since Friday due to a thunder strike nearby I suppose.

However, I managed to get the home VM working full screen by editing the VMX file (commmenting out the usb.xxx lines and also setting the vmmouse.present to FALSE (if I remember well)

A question of curiosity, since I am using KDE: Are VMplayer and VMware Workstation using QT or GTK under KDE?

0 Kudos
t2m
Contributor
Contributor

The "export VMWARE_USE_SHIPPED_GTK=force" trick works for me.

Thank you very much !

0 Kudos
HHelene
Contributor
Contributor

Sorry, that doesn't work for us.

We assume, that something must go wrong with USB/Mouse/Keybord. In that machine/board, where that kind of error appears, there we had trouble with edev in X, because mouse and keyboard appear twice: as a USB-(HID)-Device and as an ordinary ps2-device. Thats because "real" PS2-Device seems emulated via USB even there are these connectors. On starting XP as guest a warning tells, that there is a "ServerEngines SE USB Device". As told above, this double appearance of keyboard and mice triples, if we put in a USB-C Media Audio Device (because the server has no sound) and finds a third keyboard because of the keys for volume/mute (We need this as an alarming system replacing lacking SATA-Drive-lights in an array, it tells for example: "number one - number one" if the first drive has troubles ;-). Therefore always us-keybord is chosen and other automatically defaults of X - X seems to ignore xorg.conf completely.

Of course, we must move vmware to another machine for this one and only a kind of statistic Windows-Program for which we need vmware/XP and which is run approximately twice a week. Hopefully, one of VMware guys reads here into: On qemu this runs without problems and seems to be much less ressource consuming, but we test this in parallel a couple of weeks, so, if there is no solution within this time, we start with qemu...

wbr HHelen

0 Kudos
ciberandy
Contributor
Contributor

Hey, thanks so much! I made a shell alias:

alias vmware="VMWARE_USE_SHIPPED_GTK=force vmware"

and now it works like a charm. Finally, pooh.

I could even reenable the USB controller in the virtual machine -great!

Thanks so much!

Andy.

0 Kudos
alexlang
Contributor
Contributor

Hum, this is really strange. This does NOT work for me. The mouse will not ungrab even using this setting. I still have to disable the USB controller. Now, I'm not using 640x480, but rather 1920x1200. I don't know if that's an issue or not.

0 Kudos
Bulgroz
Contributor
Contributor

@alexlang : Have you tried setting vmmouse.present="FALSE" in your VMX file ?

0 Kudos
alexlang
Contributor
Contributor

Setting vmmouse.present has no apparent effect.

0 Kudos
HHelene
Contributor
Contributor

Well, all those fancy tips&hints do not change things real essential, that

export VMWARE_USE_SHIPPED_GTK=force

(or =yes) changes the appearence of vmware itself slightly, but not the 640x480-feature.

Another costumer tells us, that he has the same problem, since he changed host kernel to 2.6.29 (SuSE) on a laptop (Lenovo, with that finger print reader) and finds out so far, that that fingerprint reader appears also as a new keyboard or alike. Even stepping back to former 2.6.27 kernel does not reverse the vmware-behavior.

Sad.

wbr helen

0 Kudos
LinuxDude
Contributor
Contributor

I've added a line "export VMWARE_USE_SHIPPED_GTK=force" to /etc/vmware/bootstrap, the grabbing/ungrabbing problem is gone now.

Thanks!

p.s. I run Debian testing/unstable on Linux 2.6.31 with gtk2-engines 1:2.18.2-1, gtk2-engines-xfce 2.6.0-2, xserver-xorg 1:7.4+4, -- there's something fishy with gtk, even if one uses KDE.

Message was edited by: LinuxDude

0 Kudos
unclecameron
Contributor
Contributor

doesn't work for me either, the only thing I can use is Unity, that works....mostly.

-


Cameron

Selma, OR

0 Kudos
dibl
Enthusiast
Enthusiast

Excellent! Yes, that fixed it on Kubuntu 9.10. Thank you!

0 Kudos
lpiga
Contributor
Contributor

At first the VMWARE_USE_SHIPPED_GTK=force doesn't work for me.

Then I installed libcurl and everything is working now.

Thanks a lot

0 Kudos
hakir
Contributor
Contributor

Hi,

Well, all those fancy tips&hints do not change things real essential, that

export VMWARE_USE_SHIPPED_GTK=force

(or =yes) changes the appearence of vmware itself slightly, but not the 640x480-feature.

for me it works to get the mouse grab over the whole guest window, but starting vmplayer with -h somehost, I see the vms listed without name, just an icon, so I don't know which one to click :0.

Harald.

0 Kudos
mauro13
Contributor
Contributor

Works for me in Ubuntu 9.10 host kernel 2.6.31-14, VMware Player 3.0 install without problems, then the mouse and keyboard problem was fix with the add of the line export VMWARE_USE_SHIPPED_GTK=force at the end of the usr/bin/vmplayer and in the end of etc/vmware/bootstrap

Thanks for the help

0 Kudos
Yennix
Contributor
Contributor

Hi all,

I wanted to post back to this thread, see if I can provide a summary of what steps I took to fix this issue.

First, here's a breakdown of my environment, so you can decide if this post is relevant to you or not:

OS:

$ lsb_release -a
No LSB modules are available.
Distributor ID: Ubuntu
Description: Ubuntu 9.10
Release: 9.10
Codename: karmic
$ uname -a
Linux xxxxxx 2.6.31-20-generic #58-Ubuntu SMP Fri Mar 12 04:38:19 UTC 2010 x86_64 GNU/Linux

VMWare install:

VMware-server-2.0.2-203138.x86_64.tar.gz
Installed using the 9.10 instructions in this link:

Usage:

I'm trying to launch my guest VM's using the Firefox plugin "VMware Remote Console Plug-in 2.5.0.122581"
Further, I'm assuming that you dont want to be bothered with exporting the variable in your bashrc profile or manually in a console just prior to launching firefox (which I suspect might also work, but i haven't tried.)

So, the "VMWARE_USE_SHIPPED_GTK=force" variable worked for me, but not when i tried to insert it into /etc/init.d/vmware or /usr/bin/vmware.

When I investigated the environments of the vmx processes I started, I could prove VMWARE_uSE_SHIPPED_GTK was set, but when I tried to launch the Remote Console, it still wouldn't successfully grab my mouse outside of a view area larger than 640x480.

So, for me atleast, the variable was being set in the wrong place.

It took comment #25 of this link ( ) and comment 22 in this thread to clue me in that if I edit:

/home/<USERNAME>/.mozilla/firefox/<PROFILE>/extensions/VMwareVMRC@vmware.com/plugins/lib/wrapper-gtk24.sh
with the following. Put it up at the top, just after the shebang (#!) line:

#UGLY HACK WARNING
# This is to fix the stupid failure to grab mouse problem in remote
# console:
export VMWARE_USE_SHIPPED_GTK=force

Then the next time I opened a VMWare guest using the Remote Console, mouse grabbing was a-ok. And it works immediatly, no need to restart vmware.

The one caviet is that it only works for YOUR user account. You obviously have to either do this for every user's instance of the firefox plugin, or symlink the wrapper-gtk24.sh to some copy of the script that every one can access (not sure if that would work, i haven't tested it. Seems reasonable to try though).

0 Kudos