HHelen
Contributor
Contributor

Workstation: Losing focus (mounse ungrabs) outside area of 640 x 480 (vga resolution)

Mouse cursor covers only an area of 640 x 480 (vga resolution), mouse cannot reach area left and below this are and ungrabs inside guest. It is only possible to do <ctrl><g> inside the vga area twice, after that only clicking in the menu brings back focus into the vga area again. Happens on every guest OS with resolution higher than 640x480 -since installing 6.5.3

Serching in alls databases give me the certainity: I'm the first one again™ to whom this happens Smiley Wink

Very annoying and therefoe very annoyinf custmer.

Tags (1)
0 Kudos
38 Replies
jms
Contributor
Contributor

Same thing here. I even did clean install, played with grab settings and same thing happens with every setting combination. Host is Mandriva, guest is Windows7, xserver 1.6.3.901 and xinput 1.4.2.

0 Kudos
FredCote
Contributor
Contributor

I've been searching for this for a week. I have the same issue with player 2.5.3 and workstation 6.5.3 on ubuntu karmic (2.6.31rc8). I tried with/without vmtools, no luck in both configuration. I reinstalled the guest from scratch and even in the setup screen I lose the focus when I go outside of VGA. I tried some modifications in the .vmx file but no lock again.

On Ubuntu Jaunty (2.6.28) and fedora 11 (2.6.29) I don’t have this issue.

0 Kudos
KevinG
Immortal
Immortal

The VMware Tools provides a mouse driver that controls the auto grab and ungrab. The Tools also provide a video drive, without the VMware Tools installed you will have issues with the mouse and screen resolution

0 Kudos
FredCote
Contributor
Contributor

As I wrote before, I tried every versions I have of vmtools and also without vmtools and it didn't work. In every situations I have this issue. Therefore I don't think the problem is related to vmtools.

0 Kudos
KevinG
Immortal
Immortal

You need the VMware Tools installed and you need to have your guest OS correctly configured to use the Tools.

Since your guest is not a supported guest OS, it is most likely not configured correctly.

Post your xorg.conf file

0 Kudos
FredCote
Contributor
Contributor

I tried with different guest OS and nothing I tried works, even a simple Windows XP with vmtools. the unsupport part is on my host OS wich is Ubuntu Karmic with the kernel 2.6.31. All my vm works pretty well on Ubuntu Jaunty (2.6.28) and vmplayer 2.5.3.

By the way here is my xorg.conf from my host.

0 Kudos
FredCote
Contributor
Contributor

I just found out that even with "VMware Remote Console Plug-in" for firefox I have this issue (mouse ungrab over 640*480). My setup is:

Server side: Ubuntu 9.04 x86_64 server (kernel 2.6.28) with vmware server 2.01-156745.x86_64

Clent side: Ubuntu 9.10 x86_64 desktop (kernel 2.6.31) with firefox 3.5.2 and "VMware Remote Console Plug-in 2.5.0.122581" to acces the "vmware infrasrtucture web access" page

With another client, everything works ok (I tried Windows XP and Ubuntu 9.04)

0 Kudos
FredCote
Contributor
Contributor

Here is a video of this issue. As you can see, the mouse ungrab when I go outside of 640x480. You can also see that vmtools is installed and working (when I resize the screen). I wish to record more but the forum limit is 4.9mb.

If someone want to see more, Explain me what and I will post the video (I will host it myself if it's too big)

0 Kudos
KevinG
Immortal
Immortal

I just found out that even with "VMware Remote Console Plug-in" for firefox I have this issue (mouse ungrab over 640*480). My setup is:

So you are not using Workstation?

0 Kudos
FredCote
Contributor
Contributor

I had this issue on Player first, but then tried with Workstation. The problem was the same on both so I use Player to test because it's faster to install (and reinstall). Other user from this post seem to experiment this problem on workstation

0 Kudos
t2m
Contributor
Contributor

I have the same exact problem here : focus is lost when my pointer gets out of the 640x480 zone (from top-left corner) of the guest VM screen.

This is really painful.

Details:

- VMPlayer 2.5.3 on a Linux host (running recent drivers similar as Ubuntu 9.x), with a Windows XP Pro guest running the most recent version of VMTools I could find (the one from Workstation 6.5.3).

- The VMTool are properly installed and running, the mouse and display drivers are installed

I noticed another, simultaneous, issue : I have to explicitly give the focus to the guest VM (CTRL-G), vmplayer does not grab the mouse/keyboard automatically.

0 Kudos
FredCote
Contributor
Contributor

It's the same problem as mine. What kernel do you have on your host ubuntu ? 2.6.28 (for jaunty) or 2.6.31 (for karmic)

0 Kudos
t2m
Contributor
Contributor

FredCote:

It's the same problem as mine. What kernel do you have on your host ubuntu ? 2.6.28 (for jaunty) or 2.6.31 (for karmic)

I have 2.6.31rc7 here, but I'm not sure how it is related...

It might be related as well to a change in the X drivers for input

devices (such as evdev).

0 Kudos
FredCote
Contributor
Contributor

I have no way to tell because i'm not able to update the kernel to 2.6.31 on Ubuntu jaunty without updating X (I'm really not an expert). I don't rule out the kernel because when you start vmware (player or workstation) for the first time (and each time you update your kernel) it have to compile/recompile some modules. Old version (2.5.2 and 6.5.2) didn't work on the kernel 2.6.31 because they failed to compile these modules.

You're right about X that change alot in the new Ubuntu Karmic but once again, I'm not able to update package one by one to see which one is causing this. I will continu to try and post my result.

0 Kudos
alexlang
Contributor
Contributor

We've essentially got 3 threads now on the same topic.

If you disable USB, which force the mouse to the VMware mouse driver instead of the WinXP USB HID drivers, ungrab works. Now the question is how to get the mouse to use the VMware drivers without disabling USB support.

0 Kudos
t2m
Contributor
Contributor

I tried disabling the "HID-compliant mouse" drivers through the windows

device manager => it leaves me with a mouse pointer that can go beyond

the 640x480 area, but I can't click anymore Smiley Sad

At which level do you "disable USB" ?

- at the VM configuration level ? (through editing the vmx file, for

instance)

- somewhere else in the windows / system / device manager ?

( for reference, the other threads you mentioned are:

http://communities.vmware.com/message/1292437

http://communities.vmware.com/thread/229545 )

0 Kudos
alexlang
Contributor
Contributor

I remove the "USB Device" from the VMware settings for the VM itelf.

0 Kudos
Bulgroz
Contributor
Contributor

(Remark: this bug is also discussed there http://communities.vmware.com/message/1355397, but this thread seems the most relevant)

I have had the problem at home since about 1 month and a half, after ugrading the system and it is still there after ugrading from 2.5.0 to 2.5.2 then 2.5.3. I now use KDE 4.3.0, xorg 7.4, kernel 2.6.31rc6 (opensuse 11.2 M6) I do not know the build number of the VMtools, but the windows ISO was a priori extracted from the Workstation 6.5.3 bundle. It occurs with Win2K, XP and Seven rc1 VMs...

At work, I do not have the problem using an old Win2K VM with VMplayer 2.5.3 and VMtools build 80187 inside an opensuse 11.1 (KDE 4.24, xorg 7.4, kernel 2.6.27.29). If I look at the hardware config in the Win2K VM I have 2 USB HID mouse entries + 1 VMware pointing device and I have usb.present = "TRUE" in my vmx file. The mouse does not appear in the list of USB device in the "Devices" menu, so that it should not work if I understood correctly the previous messages

0 Kudos
alexlang
Contributor
Contributor

I thought that the answer would have been to delete the two mouse HID devices from the WinXP Device Manager and leave the VMware mouse driver. That seemed to disable the mouse all together though.

0 Kudos