jpreed
Contributor
Contributor

Workstation 6 + Linux + iPhone

Hey all,

I wasn't planning on getting an iPhone, but some peer pressure ensued and now I have one.

I've been trying to activate it for a couple days now using a Linux guest and XP SP2, but have had no success. The basic problem is that when I plug the device in, Windows chimes with its little "USB device connected" sound, but iTunes doesn't list the device in its device list. (I am therefore willing to chalk this up to a software problem inside the guest, but...)

I started with an XP SP 2 VM running under Workstation 5; had the same problems there (and in fact, got a warning about "slower than expected speeds," so I'm assuming that was the lack of USB 2.0 support in 5.x), so I installed WS 6, upgraded the virtual hardware, and tried again.

This time, when I first plug in the iPhone, Windows says "New Hardware Found: iPhone," and installs drivers. Again, I can plug/unplug the phone, and Windows beeps, but iTunes sees nothing.

Some relevant log files:

from vmware.log

Jul 01 15:58:15.176: vmx| USB: Found device [name:Apple\ iPhone vid:05ac pid:129

0 path:4/3 speed:high family:vendor,hid,imaging]

Jul 01 15:58:15.176: vmx| VMXVmdbLoadUsbDevices: New set of 1 USB devices

Other times I connected the phone, I've gotten this:

Jul 01 03:31:54.350: vmx| USB: Autoconnecting e004000405ac1290

Jul 01 03:31:54.351: vmx| USB: Found device [name:Apple\ iPhone vid:05ac pid:129

0 path:4/3 speed:high family:vendor,hid,imaging]

Jul 01 03:31:54.351: vmx| VMXVmdbLoadUsbDevices: New set of 1 USB devices

Jul 01 03:31:54.873: vmx| SOCKET 177 client closed connection

Jul 01 03:31:55.873: vmx| EHCI: setup data packet over run 8 0

Jul 01 03:31:55.884: vmx| EhciNewBulk: tdlengths = 18924, pipesize = 16392

Jul 01 03:31:55.886: vmx| EhciNewBulk: tdlengths = 18924, pipesize = 16392

Jul 01 03:31:55.888: vmx| EhciNewBulk: tdlengths = 18924, pipesize = 16392

Jul 01 03:31:55.889: vmx| EhciNewBulk: tdlengths = 18924, pipesize = 16392

Jul 01 03:31:55.891: vmx| EhciNewBulk: tdlengths = 18924, pipesize = 16392

Jul 01 03:31:55.892: vmx| EhciNewBulk: tdlengths = 18924, pipesize = 16392

...

Jul 01 03:31:59.346: vmx| EhciNewBulk: tdlengths = 18924, pipesize = 16392

Jul 01 03:31:59.348: vmx| EhciNewBulk: tdlengths = 18924, pipesize = 16392

Jul 01 03:31:59.349: vmx| EhciNewBulk: tdlengths = 18924, pipesize = 16392

Jul 01 03:31:59.351: vmx|

Jul 01 03:31:59.351: vmx| <<< Log Throttled >>

from dmesg:

usb 4-4: new high speed USB device using ehci_hcd and address 6

usb 4-4: configuration #1 chosen from 3 choices

usb 4-4: USB disconnect, address 6

A couple of questions:

When I did the upgrade from WS 5 -> 6, the VM saw the changes and wanted to reboot due to "new hardware." I'm wondering if because this copy of XP was installed on a VM that had no USB 2 support if something inside the VM is grabbing it as a USB 1 device and preventing iTunes from seeing it (or something similar).

Which is to ask: would re-installing Windows cleanly under Workstation 6 help this problem?

I'd really like to get this working under VMware, so I don't have to have a computer lying around \*just* for my phone. πŸ˜•

TIA,

preed

Message was edited by:

RDPetruska

Removed emoticon from subject line

0 Kudos
179 Replies
jpreed
Contributor
Contributor

I've been trying to activate it for a couple days now

using a Linux guest and XP SP2, but have had no

success.

Sorry, I meant a Linux host[/i] and an XP SP2 guest[/i].

Getting it to work in a Linux host certainly would be amusing... ...

0 Kudos
dgleser
Contributor
Contributor

I am seeing the same issue, I have FC7 (host) and windows xp pro sp2 (guest).

If I have photos stored in the phone the windows guest sees the device as a camera that it wants to download the pictures. But iTunes does not see the device.

0 Kudos
dgleser
Contributor
Contributor

Sorry, VMware Workstation 6.0

0 Kudos
admin
Immortal
Immortal

Yeah, we're aware of these incompatibilities with the iPhone. Someone fixed them today, although I can't comment when the fix will make it into a release.

(BTW, are you the same jpreed I'm thinking of?)

jpreed
Contributor
Contributor

Yeah, we're aware of these incompatibilities with the

iPhone. Someone fixed them today, although I can't

comment when the fix will make it into a release.

Gotcha... I suppose I could ask how long until I can make iTunes use my 80+ gig FLAC collection by mapping it into a VM, but... I won't put anyone on the hotseat. Smiley Wink

Is it safe to assume that the iPhone will "work" (for some value of work) with a future 6.x release?

(BTW, are you the same jpreed I'm thinking of?)

Don't know which jpreed you're thinking of... but if you're reminded of a certain (infamous?) ex-VMware build engineer, then yah... I do[/i] know him. Smiley Wink

Thanks for the help, James!

0 Kudos
admin
Immortal
Immortal

Is it safe to assume that the iPhone will "work" (for

some value of work) with a future 6.x release?

IMO it'd be pretty shameful if it didn't. Smiley Wink

0 Kudos
jtatum
Contributor
Contributor

Bummer. Was just trying this today and ran into the same issue. I was hoping it was something fixable on my end. This will add an ugly wrinkle to my sync scheme Smiley Happy

Thanks for keeping us up-to-date on the issue.

0 Kudos
dgleser
Contributor
Contributor

Is there any way I can be a test subject for the patch?

0 Kudos
dgleser
Contributor
Contributor

Buy, the way thanks for dealing with this issue so quickly.

0 Kudos
milli
Contributor
Contributor

I would very much like to be a beta patch tester too, if possible... I posted my log entries that I see over here, as the symptoms on that thread are identical:

http://www.vmware.com/community/thread.jspa?messageID=647089

And I put more detail here:

http://ubuntuforums.org/showthread.php?t=489841

0 Kudos
nate_sammons
Contributor
Contributor

Yes, how can I join the beta program for this fix? I would love to not have to reboot into XP to sync my iphone.

0 Kudos
woodb
Contributor
Contributor

I'd be a happy beta tester as well Smiley Happy

0 Kudos
milli
Contributor
Contributor

Hey VMware support, THANKS FOR NOTHING. Are they serious? Ubuntu is only the most poplular Linux flavor out there right now (distrowatch.com). This is really disappointing.

-


Dear Michael,

Thank you for the information.

Ubuntu 7.04 is not supported as a Host Operating System, as we have not

tested Ubuntu 7.04 as a Host.

In this case it won't be possible for me to troubleshot the issue further as

I won't get any update from the Engineering team as Ubuntu 7.04 is not tested

and certified by them.

Hence I would suggest you to install a supported Host configuration and then

try to reproduce this issue.

Looking forward to hearing from you.

Regards,

Paurin Dalal

Technical Support

VMware, Inc. (An EMC Company)

0 Kudos
admin
Immortal
Immortal

Hey VMware support, THANKS FOR NOTHING. Are they

serious? Ubuntu is only the most poplular Linux

flavor out there right now (distrowatch.com). This

is really disappointing.

Your post is belongs in its own thread. And if you were asking about iPhone compatibility, there's little point since we're already aware of the problem. There is no beta program for that specific patch (we ran into some complications).

As for Ubuntu hosts: we do officially support Ubuntu 5.04 - 6.06 hosts. I think 7.04 came out late enough in the Workstation 6.0 development and testing cycle that it didn't make the list.

I won't get any update from the Engineering team as Ubuntu 7.04

is not tested and certified by them.

Regrettably the person who responded to you is a bit misinformed. Many of the engineers use Ubuntu 7.04 on their development machines.

Message was edited by:

jameslin

0 Kudos
milli
Contributor
Contributor

Thanks jameslin. I'll terminate the support case since that is, unfortunately and as usual, proving a waste of time.

I'll just be patient and sit tight till a release with the fix(es) comes out.

FWIW, the Workstaion 6.0.0 tarball contains kernel drivers for Ubuntu 7.04 (2.6.20-15 kernel, which is what I'm still using).

0 Kudos
dgleser
Contributor
Contributor

jameslin ,

Any further word on the patch/fix?

0 Kudos
NoyoN
Contributor
Contributor

Hi!

I have same problem..

Any further word on the patch/fix?

Tks

0 Kudos
nate_sammons
Contributor
Contributor

bump -- any more news on an update to VMWare to fix this?

0 Kudos
mbcrispin3322
Contributor
Contributor

I am waiting for a fix as well. Smiley Happy

0 Kudos