alexlang
Contributor
Contributor

Workstation 6.5.2 (and 3), WinXP USB Mouse Driver versus VMware Mouse Driver

I'm running VMware Workstation 6.5.2 on Fedora 11 x86_64. With a newly converted WinXP partition on my old laptop and with USB enabled in the guest, the mouse acts as a USB mouse. With USB disabled in the guest, it acts as a PS/2 mouse.

Normally, that wouldn't be interesting with the following exception. When acting as a USB mouse, the mouse cannot exit the bounds of the WinXP window without hitting Ctrl-Alt. When actiing as a PS/2 mouse, it can.

From looking at the WinXP device manager, it seems that the USB mouse drivers are superceding the VMware Pointing Device driver.

How can I make sure that even with USB enabled in the guest, that the VMware mouse driver takes precedence over the HID USB mouse drivers??

Thanks!

0 Kudos
4 Replies
alexlang
Contributor
Contributor

As I've mentioned on a couple of other threads now, one of the side effects of this behavior is that with the mouse using the USB HID driver, the automatic ungrab doesn't work. When you disable USB support on the VM, the mouse uses the VMware driver and does work.

So, back to the original question... How can I make WinXP use the VMware mouse driver instead of the USB HID drivers?

0 Kudos
K-MaC
Expert
Expert

I assume that you have the VMware tools installed?

Cheers

Kevin

Cheers Kevin
0 Kudos
alexlang
Contributor
Contributor

K-mac,

Absolutely. I've installed as well as uninstalled and reinstalled.

0 Kudos
alexleezoot
Contributor
Contributor

I have the same issue in VMware Workstation 7 and finally solved it by "disabling" the 2 HID-compliant mouse within Device Manger. Do not uninstall as they just keep coming back. Disable top HID-compliant mouse and you still have control of mouse, disable 2nd one and you will lose mouse control. Use Ctrl-Esc to initiate your start menu and reboot system. Once system comes up mouse will be forced to use VMware Pointing Device. Alex

0 Kudos