moebiusstrip
Contributor
Contributor

VMware Workstation 7.1.4 on Linux Kernel 2.6.38-2

Patch for VMware Workstation 7.1.4 on Linux Kernel 2.6.38-2.

Tested on Debian Sid. 

The only needed modification is the removal of BKL from "vmnet".

0 Kudos
12 Replies
Joe666
Contributor
Contributor

Thank you very much for this. It works.

For those out there not so tech savy:

Download the patch, then:

cd /usr/lib/vmware/modules/source

untar vmnet.tar

patch -p1 < /path/to/patch/vmware-7.1.4-2.6.38-2-generic.patch

tar -cvf vmnet.tar

Then just run vmware and let it compile.

Thanks again.

0 Kudos
raiden201110141
Contributor
Contributor

worked on debian unstable with 2.6.38-2-amd64

thank you very much

0 Kudos
Noel
Expert
Expert

Works with Natty 2.6.38-8.  The GUI issue is also fixed by 7.1.4.

0 Kudos
lech
Contributor
Contributor

Works for me too, on Debian squeeze x64 with sid's 2.6.38 kernel (needed for some parts of the sandy bridge chipset).

Thanks!

Regards Christoph

0 Kudos
Waves201110141
Contributor
Contributor

Hi all

Please, could anyone help me...(step by step for dummies)?

       This command gave me an error: Bash...Not such directory or file

patch -p1 < /path/to/patch/vmware-7.1.4-2.6.38-2-generic.patch

tar -cvf vmnet.tar

Excuse me, because my terrible English

                                                          Thank's  a lot in advance

0 Kudos
continuum
Immortal
Immortal

you must replace /path/to/patch with the full path to the patch

example : you downloaded the patch to the directory /home/aunt-dororthies-favorite-sausage/vmware-7.1.4-2.6.38-2-generic.patch

then the line would be

patch -p1 < /home/aunt-dororthies-favorite-sausage/vmware-7.1.4-2.6.38-2-generic.patch

instead of

patch -p1 < /path/to/patch/vmware-7.1.4-2.6.38-2-generic.patch

Do you need support with a recovery problem ? - send a message via skype "sanbarrow"
0 Kudos
dezuu
Contributor
Contributor

Hello,

I've applied a new patch as above but Im getting this:

Apr 26 18:08:26.389: app-140130933835552| Trying to find a suitable PBM set for kernel 2.6.38-8-generic.
Apr 26 18:08:26.393: app-140130933835552| Trying to find a suitable PBM set for kernel 2.6.38-8-generic.
Apr 26 18:08:26.395: app-140130933835552| Trying to find a suitable PBM set for kernel 2.6.38-8-generic.
Apr 26 18:08:26.398: app-140130933835552| Trying to find a suitable PBM set for kernel 2.6.38-8-generic.
Apr 26 18:08:26.401: app-140130933835552| Trying to find a suitable PBM set for kernel 2.6.38-8-generic.
Apr 26 18:08:26.415: app-140130933835552| Your GCC version: 4.5
Apr 26 18:08:26.448: app-140130933835552| Your GCC version: 4.5
Apr 26 18:08:26.539: app-140130933835552| Trying to find a suitable PBM set for kernel 2.6.38-8-generic.
Apr 26 18:08:26.541: app-140130933835552| Trying to find a suitable PBM set for kernel 2.6.38-8-generic.
Apr 26 18:08:26.548: app-140130933835552| Trying to find a suitable PBM set for kernel 2.6.38-8-generic.
Apr 26 18:08:26.550: app-140130933835552| Trying to find a suitable PBM set for kernel 2.6.38-8-generic.
Apr 26 18:08:26.553: app-140130933835552| Trying to find a suitable PBM set for kernel 2.6.38-8-generic.
Apr 26 18:08:26.905: app-140130933835552| Trying to find a suitable PBM set for kernel 2.6.38-8-generic.
Apr 26 18:08:26.906: app-140130933835552| Building module vmmon.
Apr 26 18:08:26.906: app-140130933835552| Extracting the sources of the vmmon module.
Apr 26 18:08:26.948: app-140130933835552| Building module with command: /usr/bin/make -C /tmp/vmware-root/modules/vmmon-only auto-build SUPPORT_SMP=1 HEADER_DIR=/lib/modules/2.6.38-8-generic/build/include CC=/usr/bin/gcc GREP=/usr/bin/make IS_GCC_3=no VMCCVER=4.5.2
Apr 26 18:08:28.084: app-140130933835552| Failed to compile module vmmon!

Do you have any idea how to patch it guys?

0 Kudos
Waves201110141
Contributor
Contributor

Hi continuum and all guys

Thank's a lot for your quick reply Smiley Happy

Now gives me this mistake

can't find file to patch at input line 4

Perhaps you used the wrong -p or --strip option?

The text leading up to this was:

-------------------------------------------------------------------------

|diff -ruB orig/vmet-only/driver .c 2.6.38-2/vmet-only/driver.c

|--- orig/vmet-only/driver.c  2011 -03 -26 06:37:29 .000000000  +0100

|+++ 2.6.3.8-2/vmet-only/driver.c      2011 -03 -31 08:57:58.  255344346  +0200

Learning...

0 Kudos
kjuergen
Contributor
Contributor

Just installed 7.1.4 on Xubuntu 11.04 x86_64 (kernel 2.6.38-8-generic) and there's a crazy problem:

If I start it with sudo vmware it runs like a champ. In usermode (or from the user menu) all I see is a short blip of a window and it's gone.

To me this means that everything required to operate is there. Most likely some access rights are set wrong which prevents it from starting up.

(vmware-unity-helper:5895): GLib-WARNING **: /build/buildd/glib2.0-2.28.6/./glib/goption.c:2132: ignoring no-arg, optional-arg or filename flags (8) on option of type 0

is the line it gets stuck....

Any help to get it up and running would be appreciated. Naturally VMware support isn't of any help (as usual), they just refer you to the supported OS's. But why be surprised, they didn't provide help for a supported OS before (with paid support).

Juergen

0 Kudos
kjuergen
Contributor
Contributor

Thanks to Toz from the ubuntu forum (http://ubuntuforums.org/showthread.php?t=1774756) I had partial success with this:

aptitude install libgtkmm-2.4-1c2a

from: http://holyhandgrenade.org/blog/2010/10/using-system-gtk-with-vmware-workstation-on-linux/

Now Workstation starts up in user mode but it nags me every time with this shareware screen to accept the license. Somehow it can't write the info to disk that I have already accepted it several times.

At least it's somehow working and I can use my paid software with a bit of a hazzle.

Juergen

Toz was helpful again! Go into your home directory and as root change permission for all files in the .vmware directory to read/write for others and group and the world is good again.

Message was edited by: kjuergen, add info about getting rid of the nag-screen

0 Kudos
gharney
Contributor
Contributor

Working nicely on Linux Mint Debian Edition, so thanks.

0 Kudos
lexus201110141
Contributor
Contributor

Download the patch, then:

cd /usr/lib/vmware/modules/source

untar vmnet.tar

patch -p1 < /path/to/patch/vmware-7.1.4-2.6.38-2-generic.patch

tar -cvf vmnet.tar

Please what do you mean by then:

cd /usr/lib/vmware/modules/source

Do i type this into the terminal?  Where must i save the patch file to?

0 Kudos