CossakTarasBulb
Enthusiast
Enthusiast

VMware Workstation 10 networking bug/issue/problem

Jump to solution

Any ideas guys, this is really pissing me off, i having a hard time creating vms.

Replicated in 2 scenarios:

1st. During the creation of a Server 2008 r2, I removed the preconfigured networking adapter, and added 2 new adapters with preconfigured settings.  When the vm finished installing, installed vmware tools, the networking adapters were not installed.

Installed server 2008r2 and DID NOT delete the preconfigured adapter, and only modified it from default net to auto bridging, and added a 2nd adapter with custom bridging vmnet, when the vm finished installing the DEFAULT original adapter worked, 2nd not installed. 1st adapter ended up in device manager as INTEL pro 1000 mp, 2nd was in other devices Ethernet controller, and drive would not install.

  1. Installing esxi 5.0.0 update 2, the original adapter modified to bridging from nat, all installs fine.

When I deleted the original adapter, and added a new one, I get error VMFS Module Failed, no network adapters connected to the system or a suitable driver could not be located.

When I created a new vm, modified the existing adapter to bridging from NAT, and added a 2nd adapter, the vm installed and did not see the 2nd adapter at all. I reinstalled the esxi 5.0.0 onto this same vm, and came back with the same results, only seeing the 1st initial adapter.

This issue has been replicated on multiple hosts, win 7 64, server 2008r2, windows server 2012.

This issue did not exist on vmware workstation 9.

1 Solution

Accepted Solutions
dariusd
Leadership
Leadership

I've reproduced this problem here: Adding a virtual NIC by using the "Customize Hardware" button from inside the New Virtual Machine Wizard will cause the device to be created with no assigned device type.  Windows Server 2012 does not support the default vlance virtual network device.

You can work around this problem by configuring the additional ethernet<n>.virtualDev = "e1000e" lines manually, or by postponing the hardware customization until after the VM is first created – just go into the VM's settings later and add any required extra vNICs.

I've filed an internal bug report to have the New Virtual Machine Wizard corrected.

Thanks!

--

Darius

View solution in original post

0 Kudos
17 Replies
girishverma
Enthusiast
Enthusiast

I am having the same issue.

I am installing ESXi 5.5 within VMware Workstation 10.0

None of the added adapters are being recognized. Only primary Network Card is being recognized.(I am using the added adapters in bridged mode)

This is a Windows 8 HOST running Workstation 10.0

0 Kudos
CossakTarasBulb
Enthusiast
Enthusiast

Hello fellow vmware users.

I've since my last post put in a ticket with vmware, and their tech support guys has verified the issue on my side, and confirmed it on his side in a lab environment.

This issue has been submitted as an official bug report to the engineers. I'm waiting for a reply/fix/.1 update.

For now i went back t 9.0.2 because this issue makes the version 10.0.0 completely unusable.

0 Kudos
girishverma
Enthusiast
Enthusiast

Thanks for the feedback. This is quite annoying and am not sure how it was missed by QA dept. Would you please be able to share the fix if / when you get it. I also stumbled upon a bug but the guy from VMware was great and got a fix within 1 - 2 days and created a KB for it. Please see my post below:

https://communities.vmware.com/thread/457809?start=0&tstart=0

For now I have created a clone of my VM's which have been working well and thankfully all the existing adapters from before are working OK. I am just re installing the OS once again.

Awaiting on the fix.

0 Kudos
thegner
Contributor
Contributor

Maybe I'm late to the game, but I've found a work-around to this bug.

I deleted all NICs from the guest while it was powered off. I booted the guest, and while it was running added a new NIC in the configuration that I wanted. The NIC was immediately detected and all drivers were installed successfully.

Hope This Helps!

Travis Hegner

http://travishegner.com/

0 Kudos
kienast
Enthusiast
Enthusiast

Hello People,

I am having the exact same issue , has anyone found a fix for this ?

thanks

Da

0 Kudos
CossakTarasBulb
Enthusiast
Enthusiast

So, in my case, it seems to me that 10.0.0.1 version has this fixed. I have not encountered the bug after the update.

On my prime work station where it matters i still user the 9.02 what ever last 9x edition just to be safe.

0 Kudos
CossakTarasBulb
Enthusiast
Enthusiast

So my answer would be please update to the 10.0.0.1 version and after you do please test and verify and let us know.

I have tested on windows 7, 8, 8.1 and in server 2012 r2 ( i dont like hyperv). Seems to work for now.

0 Kudos
kienast
Enthusiast
Enthusiast

hi

I am using 10.0.1 build-1379776 and Windows 7 Ultimate, 64-bit.

Same issue , the only workaround is the one describe by Tegner above .

rgds

Da

0 Kudos
CossakTarasBulb
Enthusiast
Enthusiast

Yes.... i just recreated the damn issue, if i remove and read nics on the initial configuration of the OS, it still does this.  Ill reopen my ticket.

0 Kudos
corvettefisher
Enthusiast
Enthusiast

Go into Edit>Preferences>Default Hardware compatibility>Worksation 10.0

Change 10.0, to version(worksation) 9.0 or 8.0, It should work from there.

0 Kudos
ErikFR
Contributor
Contributor

Hey,

concerning the recent version of VMWare Workstation I had the same problem: I added 4 virtual network adapters configured as NAT adapters to my ESXi 5.5 Update1 Servers. Only one adapter had been detected. This is what i did to resolve the problem:

-  Gone into Edit>Preferences>Default Hardware compatibility>Set Workstation 9

-  Installed ESXi host using only one NAT network adapter

-  Shut down ESXi host

-  Added 3 or more network adapters NOT configured as NAT adapters: bridged, host only or VMWare network X.

-  Started ESXi Host. Now all network adapters were successfully detected.

-  Shut down ESXi host again and changed the adapters configuration to NAT.

-  Started ESXi host: All adapters detected and configured as NAT adapters.

Its annoying but it seems to work.

Best regards from Black Forest

0 Kudos
FredWoolard
Contributor
Contributor

Using VMware Workstation 10 (10.0.2 build-1744117), had similar issue--created Windows Server 2012 VM with two network adapters, changing the default NIC to a custom (VMNet 1 host only), and adding a second NIC set to NAT.

Guest machine only recognized the first NIC. Inspecting the .vmx file for that machine, I noticed the second NIC lacked a driver assignment, so added an entry (ethernet1.virtualDev = "e1000e"). This seemed to take care of things.

dariusd
Leadership
Leadership

I've reproduced this problem here: Adding a virtual NIC by using the "Customize Hardware" button from inside the New Virtual Machine Wizard will cause the device to be created with no assigned device type.  Windows Server 2012 does not support the default vlance virtual network device.

You can work around this problem by configuring the additional ethernet<n>.virtualDev = "e1000e" lines manually, or by postponing the hardware customization until after the VM is first created – just go into the VM's settings later and add any required extra vNICs.

I've filed an internal bug report to have the New Virtual Machine Wizard corrected.

Thanks!

--

Darius

0 Kudos
Mesi84
Contributor
Contributor

i'm using workstation 10.0.3 for Windows and i have windows 8.1 VM with bridged connection, by default VM Workstation set the bridge mode to auto, just change it and choose which physical NIC you want to binf it to your VM, go to Edit>Virtual Network Editor and then change the VMnet information of your bridge connection

Thanks

Mina

0 Kudos
ajw
Contributor
Contributor

Thanks!  That fixed my problem!

I'm using Workstation 10.0.3; not sure exactly when/how I created my VM, but I added 4 NICs and only the first was recognized.    Adding the ethernet1.virtualDev = "e1000e" line did it.  (same line for ethernet2, and 3 of course).


You do have to shut down Workstation before editing the vmx file.   Just shutting the VM down wasn't enough.

0 Kudos
virtualworld199
Contributor
Contributor

Hello,

I Was having the same issue while testing 5.5, This how I resolved this issue,

1. I created the virtual machine with custom installation

2.In step 3, I selected I will install the operating system later.

3.In step 4, I selected vmware esx and Vmware esxi version 5.

4. After going through all the other step till where it asked for customized hardware i used  Custom bridged network.

5. In the  device status for network adapter , I checked connected and connect on power on.

6. finish the installation and power on the virtual machine.

7. Then right click on the virtual machine and click setting, In the setting go to cd/dvd drive and click on it, In the connection setting use the iso image to install the ESXi 5.5 .

It is always better to have the virtual machine ready with the hardware needed before you install the operating system.I would recommend install the operating system after the virtual machine is ready.

If this work for you please marked the answer as correct.

Thankyou

0 Kudos
CossakTarasBulb
Enthusiast
Enthusiast

Hi!

VMWARE Workstation 11 failed to connect to server. Server is an unknown server. VMware Workstation c...

Can you take a look at this and see if you can report this to anyone?

0 Kudos