46terherh
Enthusiast
Enthusiast

Using VMware on Windows 1903 host machine cannot turn on guest machine

Jump to solution

Hello, I got a problem after upgrade to Windows Insider Preview 1903 18362.30 x64 on host machine.

CPU : I5-8400

RAM : 16G

Host OS : Windows 10 1903 x64 18362.30 (Latest WIP)

VMWare Version : 15.0.4 build-12990004

Other Status :

"bcdedit /set hypervisorlaunchtype OFF"  (Means that Windows Native hypervisor already turned off)

"Memory integrity guard OFF"

"Credential Guard OFF"

Before I upgraded to Windows Insider Preview 18362.30, I was using Windows 10 RS5 x64 as a host operating system.

I could run any VM guest machine without any problem.

But, after I upgrade to Windows 10 1903, I cannot run any VM guest.

Guest screen only shows a black screen, and nothing happens.

What I can do is just rebooting machine. Cannot terminate vmware-vmx.exe process.

Anybody has same issue like this? And if anybody has solution it will be very thankful.

Thanks.

1 Solution

Accepted Solutions
bonnie201110141
VMware Employee
VMware Employee

This issue is fixed internally in VMware. Please be patient for the update.

View solution in original post

74 Replies
LikeVMW
Enthusiast
Enthusiast

Try turning off "Accelerate 3D graphics"

0 Kudos
46terherh
Enthusiast
Enthusiast

It doesn't work.

Just shows up black screen and nothing works, like deadlock...

0 Kudos
wgbell
Contributor
Contributor

I've got the same issue on 1903.   What worked for me (at least temporarily) is to switch the network adapter to NAT from Bridged.  I can then start up.  Usually, if I then shut down the guest, switch back to bridged it will start up.  However, if I then shut down the guest and restart it, it will usually lock up and I have to start the process over.

0 Kudos
46terherh
Enthusiast
Enthusiast

I've been already using NAT for a long time. (Unfortunately, It doesn't help for me)

A few days ago, Microsoft mentioned that they almost decided to launch 18362 WIP Build as a 1903 RTM Build. (Currently being rolled out from Release Preview Ring)

So I think VMware team should resolve this problem, may be this is a bug from VMware Workstation.

0 Kudos
fatguy1121
Contributor
Contributor

I'm experiencing a similar issue that may be related. In 1903 as soon as I connect a usb device, specifically a flash drive the guest locks up and is completely unresponsive. I have to reboot the host to recover it. Try removing your usb controller from your vm and see if it boots. I'm in the middle of trying to get support with this.

Simple07
Contributor
Contributor
0 Kudos
46terherh
Enthusiast
Enthusiast

I'm 100% sure that THIS ISSUE IS NOT RELATED TO CREDENTIAL GUARD.

0 Kudos
fatguy1121
Contributor
Contributor

I agree, Credential guard has been implemented into Windows since 2017, Even on custom images that completely remove all windows security components it still persists. Did you have any luck with removing the usb controller?

0 Kudos
wvmstr
Contributor
Contributor

I am on the Windows Insider slow ring, and each time I had to turn off credential guard.

Big waste of time.

0 Kudos
david_pjimenez
Contributor
Contributor

I can confirm that I face the same issue when I insert a USB device to the guest OS, the virtual machine freezes!

I can use the VM's until I try to connect some USB device (Pendrive, Wifi cards...).

For those ones that complain about credential guard, I use this tool to turn off and on Hyper-V, as I need and it works pretty fine for me on Windows 10 1903:

GitHub - ygoe/HyperVSwitch: Hyper-V Switch – A simple GUI to enable or disable Hyper-V without unins...

You still have to turn off "Memory Integrity" inside Windows Defender is you have it on (If you turn it off, you are not going to be able to turn it on again until you remove VMware from your system).

0 Kudos
46terherh
Enthusiast
Enthusiast

I haven't experienced any issue related to USB controller yet, because I currently cannot turn on VM due to W10 1903 and VMware issue!

0 Kudos
Susie201110141
VMware Employee
VMware Employee

Could you upload your VMware.log of VM ?

0 Kudos
akukalle
Contributor
Contributor

Here is mine

0 Kudos
Mouri_Naruto
Contributor
Contributor

I have the same problem.

My hardware is: Intel Core i7-8750H, Nvidia Geforce GTX1060, 32GB DDR4 2666 RAM, 512GB NVME SSD

My software is: Windows 10.0.18362.53, Intel Graphic Driver 25.20.100.6444 (DCH), Nvidia Graphic Driver 425.31 (DCH)

When I upgrade my Intel Graphic Driver to the newest version via download it manually at Intel Download Center, the problem seems to be solved.

But Windows 10 always install the old version Intel Graphic Driver to me, I suffer from this problem. (So sad.)

I have read the log file and found nothing errors or warnings. So I think it hangs because of the compatibility issue between the vmware workstation and the graphic driver.

I hope the problem will be solved as soon as possible.

Naruto Mouri

NecessaryEvil
Contributor
Contributor

Same issue happened to me. I had upgraded to 18362.57 (I think. whatever April's update updated it to), and no change. Reformatted the PC, and it failed again. After that I gave up and reformatted and went to 1809.

0 Kudos
46terherh
Enthusiast
Enthusiast

Unfortunately, I already reverted to Windows 1809 RS5 release. (Because I have to and need to use VMware everyday)

Originally I didn't expect to have issue related to VMware and Windows 1903, that's why I updated to Windows 10 1903.

0 Kudos
bonnie201110141
VMware Employee
VMware Employee

So far from this thread, I see below issues on Windows 1903 host:

1) VMs run into black screen

2) If VM is in bridged mode, VM locks up. If changed to NAT, issue is resolved.

3) With USB devices connected, guest locks up.

4) With old Intel graphic driver, VM ran into black screen. With updated Intel graphic driver, the issue is gone.

We will try to reproduce the issue internally. For now, will you please do the following to collect support bundle?

1) Enable debug by VM > settings > Options > Advanced > Gather debugging information, set it to Full

2) reproduce the issue (please describe your issue as people have different issues)

3) Help > Support > Collect support data, please select the VM in problem.

Please upload the zip file. Thanks very much!

0 Kudos
46terherh
Enthusiast
Enthusiast

I'm gonna do what you mentioned.

When I get issue, I'll upload log file.

Really Thanks for supporting.

0 Kudos
bonnie201110141
VMware Employee
VMware Employee

This issue is fixed internally in VMware. Please be patient for the update.

View solution in original post