d98rolb
Contributor
Contributor

Ungrab mouse automatically is not working!

Previously I was using VmWare Workstation 6.05 and the mouse was ungrabbed automatic when it leaves the Vmware window to the physical machine. After an upgrade to 6.5.2 I have an annoying problem that the mouse is trapped inside the guest OS.

Of course I can use Ctrl-Alt to manually ungrab it but this is really annoying! What option do I have to fix it ?

Physical machine is running Windows Vista Ultimate SP1 with 8 GB memory.

Guest OS is Windows XP Pro SP3 with 1.5 GB memory

Ungrab is checked in Edit/Preferences/Input/Ungrab when cursor leaves window

I have installed VmWare Tools 7.8.5. build 156735.

I also completely uninstalled version 6.05 before I installed 6.5.2.

But I found one clue. I have another image with Windows XP and it seems to work fine there.

Maybe it is best to make a new VmWare image ?

I want to avoid that if possible Smiley Sad

Regards

0 Kudos
4 Replies
joe1600
Enthusiast
Enthusiast

hii

do install vmware tools ie upgrade vmware tools ...

if found this helpful do award points as correct oe helpfull..thanks...

regards

Joe

Joe Joseph,Thanks in Advance If you find my reply useful, feel free to mark it as Helpful or Correct.
0 Kudos
d98rolb
Contributor
Contributor

As I said I did a clean install of latest vmware and then install vmware tools in the image. I even try to reinstall vmware tools with the same version and result...

I suspect there is a bug that sometimes appear when upgrade an vmware image from 6.0 to 6.5 as the other image works fine.

Regards

Roland

0 Kudos
gepfert38
Contributor
Contributor

I am having the same issue. I have 3 vm's on my desktop. 2, I am currently using and one I just created. The first two the cursor moves fine between the host and the guess, but the 3rd, which I just built traps the cursor. I have never had this problem before. I am using the VMPlayer to run the VM and when I open the vm in workstation the Install VM Tools is grayed out. When I look at the preferences they are like what the previous post states.

0 Kudos
alexlang
Contributor
Contributor

As I mentioned in a thread I started last night, if you disable USB, which force the mouse to the VMware driver instead of the Windows HID drivers, the ungrab works. Now, for me, the trick is how to leave USB support enabled and not have the mouse use the USB HID drivers.

0 Kudos