twrangham
Contributor
Contributor

Ubuntu 10.04 Beta2 VMware Workstaion 7

Has anyone had issues with the Keyboard not working in the new Ubuntu 10.04 Beta? I had it working upon first install, then after a reboot, it quit. Reinstalled and keyboard doesnt work either. Tried different KEyboard layouts, doesnt seem to matter.

Mouse works fine.

Thanks

0 Kudos
14 Replies
BringIt
Contributor
Contributor

I have exactly the same problem. Must have something to do with the radical changes they made....like ripping out the HAL daemon....

Anyone have a fix?

0 Kudos
SGiff
Contributor
Contributor

I had similar problem in that the mouse worked on the gdm login screen but the keyboard did not. I was able to login using the on-screen keyboard.

I enabled the on-screen keyboard via the universal access preferences, (little man-in-circle button on gdm screen). Also had to reboot to get the keyboard to display properly. Once logged in the regular keyboard worked fine.

I found the :0-greeter.log file in /var/log/gdm had errors complaining about not find symbols for "U.S. English" keyboard layout in us keyboard file. A little grepping later finds "U.S. English" is set in /etc/default/console-setup.

XKBMODEL="pc105"

XKBLAYOUT="us"

XKBVARIANT=""

XKBOPTIONS=""

Reboot and keyboard now works at login. Don't know if this is VMware's or Ubuntu's fault during install, since I used the auto install process in Workstation 7. Sounds like it could be VMware related as a manual install seems to avoid this.

Hope this helps.

0 Kudos
rizlaw
Contributor
Contributor

Thanks SGiff for the tip. I was having the same issue and I'm happy to report that your workaround works perfectly. Smiley Happy

0 Kudos
admin
Immortal
Immortal

I can confirm this workaround also works for the new 10.04 RTM released recently.

Regards,

Toby

Senior Consultant PSO

Advanced Services

VMware

VCP4, ITIL

0 Kudos
MikeCIO
Contributor
Contributor

I can't say I've had the same luck. Not only does the keyboard not work, but selecting the on-screen keyboard via the universal access preferences just flashes a window up in the background for a fraction of a second, then does nothing.

I recall about 15 years ago, you could boot Linux in single user mode (yeah... its been about that long since I've had to resort to it). I'm pretty sure you could pass in a switch in Grub's edit mode to get linux to boot this way. Ubuntu 10.04 removed grub with their new HAL. Anyone know of a key-combo or similar to break out of the boot process and go into single user mode/non-graphical mode?

0 Kudos
MikeCIO
Contributor
Contributor

!

Ok... Changed some virtual machine settings and the on-screen keyboard finally popped up. Tried to revert the changes to reproduce but failed.

The settings I had deselected included Processors=2 (meant to select 2 cores), 3D Graphics acceleration, automatic USB connection, ...? I think that was it. Reverted everything back to default and onscreen keyboard came up.

After applying fixes suggested and rebooting, I'm able to log in. Thanks

0 Kudos
Raoulvb
Contributor
Contributor

I have the same issue with the just released new version of Ubuntu.

But also changing VMware options as suggested does not solve the same issue: the onscreen keyboard flashes and is gone. I have no way login on, so I also cannot apply the patch as suggested.

Anyone another idea how to fix this problem?

thanks,

Raoul

0 Kudos
Raoulvb
Contributor
Contributor

ok,

this is how I fixed it:

I still had my VMware machine with Ubuntu 9 so I added the virtual disk of my ubuntu 10 to it, booted, mounted the disk of my new ubuntu and made the changes as suggested above in indicated file (as root).

After that all worked fine..

thanks for the hints !!!

Raoul

0 Kudos
SGiff
Contributor
Contributor

I also had the problem with the onscreen keyboard when you first enable it. If you leave it enabled and reboot, the onscreen keyboard will appear on the next boot.

I spent some time tracking down the root of this problem. I've found that using the "Easy Install" method in VMware workstation (7.01) does indeed cause the problem. When you attach the Ubuntu iso file during the VM creation, vmware recognizes it and creates autoinst.iso and autoinst.flp and attaches them to the newly created VM. These boot devices contain a vmware generated preseed configuration that contain the bogus keyboard entries for the debian-installer. So, if you disconnect the autoinst.iso and autoinst.flp devices before booting the VM to do the install, you can avoid this.

0 Kudos
guylj
Contributor
Contributor

I installed 10.04 LTS on VMWare Player 3.0.1 227600. Took all the defaults and the Easy Install route I specified 4 cpus. Hit the no keyboard at login so enabled on screen keyboard which didn't appear so rebooted VM but on screen keyboard still didn't appear. Shut down VM and changed cpus to 1. Restarted VM and on screen keyboard now appeared and I could login. Shut down VM again, changed cpus back to 4, started VM again. This time I stil had the on-screen keyboard and the System Monitor shows 4 cpus.

0 Kudos
rstrang
Contributor
Contributor

Thanks SGiff.

Had the same problem with Ubuntu 10.04 as guest under VMWare Player 3. The console-setup change fixed the problem.

I also verified that the change matched the console-setup on my Unbuntu 9.10 host system.

0 Kudos
m0te
Contributor
Contributor

Had a similar problem with Ubuntu 10.04 Desktop and UNE, both the final versions. Standard VM setup resulted in a VM that would not accept keyboard input, and the onscreen keyboard simply did not appear when I enabled it.

The way I got around it was was to simply remove the floppy drive when setting up the VM initially. After installation finished, the VM booted into command-line. Logon, issue a "shutdown -r", and the next time it will boot into the GUI and the keyboard works just fine. FWIW, this happened on the latest VMware Workstation (7.1.0.261024, which I downloaded yesterday evening). So it seems to be an ongoing quirk. Again FWIW, this was on a Dell Latitude D830.

Performing the trick fixed both Desktop and UNE setups

0 Kudos
paologai
Contributor
Contributor

I had the same problem.

setting the etc/default/console did not solve the problem.

We solved it by commenting out the lines

-


Section "ServerFlags"

Option "NoAutoAddDevices"

EndSection

-


in this way xorg is able to detect the keyword and everything worked fine after this!

PJ

0 Kudos
azum5555
Contributor
Contributor

Thank you paologai!

None of the fixes did it until I tried commenting out the xorg.lines! Thank you again!

0 Kudos