clawhead
Contributor
Contributor

No Internet on VMWare WS w/ Linux 2.6.22 kernel

Jump to solution

I'm able to use VMWare WS v. 6.x with no problems on kernel 2.6.20, but not with the current 2.6.22 kernel. I've applied the any-any patch build 112, which permitted me to compile all modules. VMWare loads and will boot my guest OS (Win2K Pro). All is fine with the guest -- but no Internet connection. If I revert to an older kernel and recompile modules, everything is hunky-dorey again.

Here's the pertinent info:

(1) Output from ifconfg -a on host:

eth0 Link encap:Ethernet HWaddr 00:15:58:2F:B2:AA

BROADCAST MULTICAST MTU:1500 Metric:1

RX packets:0 errors:0 dropped:0 overruns:0 frame:0

TX packets:0 errors:0 dropped:0 overruns:0 carrier:0

collisions:0 txqueuelen:1000

RX bytes:0 (0.0 b) TX bytes:0 (0.0 b)

Interrupt:16

eth1 Link encap:Ethernet HWaddr 00:16:6F:BA:6E:5A

inet addr:192.168.1.101 Bcast:192.168.1.255 Mask:255.255.255.0

inet6 addr: fe80::216:6fff:feba:6e5a/64 Scope:Link

UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1

RX packets:39303 errors:0 dropped:2 overruns:0 frame:0

TX packets:38288 errors:0 dropped:0 overruns:0 carrier:0

collisions:0 txqueuelen:1000

RX bytes:33077558 (31.5 Mb) TX bytes:8409858 (8.0 Mb)

Interrupt:22 Base address:0xe000 Memory:b4001000-b4001fff

irda0 Link encap:IrLAP HWaddr 00:00:00:00

NOARP MTU:2048 Metric:1

RX packets:0 errors:0 dropped:0 overruns:0 frame:0

TX packets:0 errors:0 dropped:0 overruns:0 carrier:0

collisions:0 txqueuelen:8

RX bytes:0 (0.0 b) TX bytes:0 (0.0 b)

lo Link encap:Local Loopback

inet addr:127.0.0.1 Mask:255.0.0.0

inet6 addr: ::1/128 Scope:Host

UP LOOPBACK RUNNING MTU:16436 Metric:1

RX packets:1711 errors:0 dropped:0 overruns:0 frame:0

TX packets:1711 errors:0 dropped:0 overruns:0 carrier:0

collisions:0 txqueuelen:0

RX bytes:2344355 (2.2 Mb) TX bytes:2344355 (2.2 Mb)

(2) Using bridged networking.

(3) Output from psauwww | grep -i bridge:

username 16693 0.0 0.0 3176 768 pts/4 R+ 01:41 0:00 grep -i bridge

(4) .vmx file for virtual machine:

#!/usr/bin/vmware

config.version = "8"

virtualHW.version = "6"

scsi0.present = "TRUE"

memsize = "1024"

MemAllowAutoScaleDown = "FALSE"

scsi0:0.present = "TRUE"

scsi0:0.fileName = "Windows 2000 Professional.vmdk"

ide1:0.present = "TRUE"

ide1:0.autodetect = "TRUE"

ide1:0.deviceType = "cdrom-raw"

floppy0.startConnected = "FALSE"

floppy0.autodetect = "TRUE"

ethernet0.present = "TRUE"

ethernet0.wakeOnPcktRcv = "FALSE"

usb.present = "TRUE"

ehci.present = "TRUE"

sound.present = "TRUE"

sound.fileName = "-1"

sound.autodetect = "TRUE"

svga.autodetect = "TRUE"

pciBridge0.present = "TRUE"

isolation.tools.hgfs.disable = "FALSE"

displayName = "Windows 2000 Professional"

guestOS = "win2000pro"

nvram = "Windows 2000 Professional.nvram"

deploymentPlatform = "windows"

virtualHW.productCompatibility = "hosted"

RemoteDisplay.vnc.port = "0"

tools.upgrade.policy = "useGlobal"

floppy0.fileName = "/dev/fd0"

ide1:0.startConnected = "TRUE"

ethernet0.addressType = "generated"

uuid.location = "56 4d 8a 9a c8 f4 fd e6-37 23 07 ea 06 d6 b5 ee"

uuid.bios = "56 4d 8a 9a c8 f4 fd e6-37 23 07 ea 06 d6 b5 ee"

scsi0:0.redo = ""

pciBridge0.pciSlotNumber = "17"

scsi0.pciSlotNumber = "16"

ethernet0.pciSlotNumber = "32"

sound.pciSlotNumber = "33"

ehci.pciSlotNumber = "34"

ethernet0.generatedAddress = "00:0c:29:d6:b5:ee"

ethernet0.generatedAddressOffset = "0"

ide1:0.fileName = "auto detect"

tools.syncTime = "FALSE"

extendedConfigFile = "Windows 2000 Professional.vmxf"

sharedFolder.option = "alwaysEnabled"

sharedFolder.maxNum = "2"

sharedFolder0.present = "TRUE"

sharedFolder0.enabled = "TRUE"

sharedFolder0.readAccess = "TRUE"

sharedFolder0.writeAccess = "TRUE"

sharedFolder0.hostPath = "/home/claw/Docs"

sharedFolder0.guestName = "Home-Claw-Docs on Arch Linux"

sharedFolder0.expiration = "never"

ethernet0.connectionType = "bridged"

#ethernet0.vnet = "/dev/vmnet0"

ethernet0.startConnected = "TRUE"

sharedFolder1.present = "TRUE"

sharedFolder1.enabled = "TRUE"

sharedFolder1.readAccess = "TRUE"

sharedFolder1.writeAccess = "TRUE"

sharedFolder1.hostPath = "/home/ftp"

sharedFolder1.guestName = "Home-Ftp on Arch Linux"

sharedFolder1.expiration = "never"

(5) ipconfig /all on guest OS (Win2K Pro):

Windows 2000 IP Configuration

Host Name . . . . . . . . . . . . : vmware-arch

Primary DNS Suffix . . . . . . . :

Node Type . . . . . . . . . . . . : Broadcast

IP Routing Enabled. . . . . . . . : No

WINS Proxy Enabled. . . . . . . . : No

Ethernet adapter Local Area Connection:

Connection-specific DNS Suffix . :

Description . . . . . . . . . . . : VMware Accelerated AMD PCNet Adapter

Physical Address. . . . . . . . . : 00-0C-29-D6-B5-EE

DHCP Enabled. . . . . . . . . . . : Yes

Autoconfiguration Enabled . . . . : Yes

Autoconfiguration IP Address. . . : 169.254.47.239

Subnet Mask . . . . . . . . . . . : 255.255.0.0

Default Gateway . . . . . . . . . :

DNS Servers . . . . . . . . . . . :

Thanks for any advice. Meanwhile, it's not that big a deal to revert to an older kernel, but this is the sort of thing that I like to get to the bottom of if possible.

(1) Reboot - McCain (2) Reformat - Clinton (3) Install new OS - Obama
0 Kudos
63 Replies
2hansen
Contributor
Contributor

Same goes for my Compaq nw8440. No bridging when host is using wireless, no problems when host uses wired... (Host: Ubuntu 7.10; Guest: XP Prof.)

0 Kudos
clawhead
Contributor
Contributor

Same goes for my Compaq nw8440. No bridging when host is using wireless, no problems when host uses wired... (Host: Ubuntu 7.10; Guest: XP Prof.)

You may be helped by this info from KevinG:

>If you used the vmware-any-any-update, it replaced the original /usr/lib/modules/source/vmnet.tar file with a one that does not include vmnet-only/smac_linux.x386.o_shipped vmnet-only/smac_linux.x86_64.o_shipped. You will need to exact the vmnet.tar and insert the vmnet-only/smac_linux.x386.o_shipped

vmnet-only/smac_linux.x86_64.o_shipped that is included with the orginal

/usr/lib/modules/source/vmnet.tar in WS 6

These comments are from this thread:

http://communities.vmware.com/thread/104681?tstart=15

(1) Reboot - McCain (2) Reformat - Clinton (3) Install new OS - Obama
0 Kudos
2hansen
Contributor
Contributor

Thanks for the quick response. However, I did a clean install of 6.0.1 and my vmnet.tar does include the smac_linux.x{386|86_64}.o_shipped files - so I guess that is not the issue. (And sorry if "my" issue is different from the one discussed in this thread - but the symptoms seem identical.)

0 Kudos
Daguerre
Contributor
Contributor

Fixed!

http://www.linuxquestions.org/questions/showthread.php?p=2905568

VMWare 6.0.1 WinXP guest can now bridge my madwifi 0.9.3.2 interface, on Fedora using kernel 2.6.22.7.

Well, that was annoying!

Hauke-m
Enthusiast
Enthusiast

Thank you for this patch. Now bridged network is working with my kernel 2.6.23-rc8 with Wireless LAN.

I have updated the patch to also work when no wireless network is used. You can download it here:

http://www.hauke-m.de/fileadmin/vmware/vmware-wireless.patch

The patched vmnet.tar can be founfd here:

http://www.hauke-m.de/fileadmin/vmware/vmnet.tar (it is based on the vmnet out of the VMware Workstation 6.0.1)

0 Kudos
clawhead
Contributor
Contributor

Thanks for the pre-patched vmnet.tar, Hauke-m. That makes life easier.

I went ahead and re-upgraded to 6.0.1 and replaced the stock vmnet.tar with your patched one. I can verify that, on my system at least, both wireless and wired bridged networking appear to function properly with Linux kernel 2.6.22.9 on the host and WinXP Pro SP2 as the guest.

I really appreciate this fix, funderburg (from linuxquestions.org), daguerre and Hauke-m. I was really frustrated before.

(1) Reboot - McCain (2) Reformat - Clinton (3) Install new OS - Obama
0 Kudos
clawhead
Contributor
Contributor

Hey, Hauke-m, have you by any chance had time to produce a pre-patched vmnet.tar for WS 6.0.2-build 59824? If not, can we assume that the vmnet.tar you patched for 6.0.1 will work also for 6.0.2?

Thanks again for your help with this worse-than-annoying problem.

(1) Reboot - McCain (2) Reformat - Clinton (3) Install new OS - Obama
0 Kudos
clawhead
Contributor
Contributor

I can confirm that, on my system at least, Hauke-m's pre-patched vmnet.tar for WS 6.0.1 works equally well for WS 6.0.2. I've gotten both wifi and wired Internet working with no probs (Host = Arch Linux, Guest = WinXP SP2, bridged networking). I haven't done any additional testing.

(1) Reboot - McCain (2) Reformat - Clinton (3) Install new OS - Obama
0 Kudos
Hauke-m
Enthusiast
Enthusiast

From version 6.0.1 to version 6.0.2 VMWare made no changes in the vmnet.tar !

The patched version for wireless will work in version 6.0.2 as in version 6.0.1

clawhead
Contributor
Contributor

From version 6.0.1 to version 6.0.2 VMWare made no changes in the vmnet.tar !

The patched version for wireless will work in version 6.0.2 as in version 6.0.1

That's good news, Hauke-m. Thanks.

(1) Reboot - McCain (2) Reformat - Clinton (3) Install new OS - Obama
0 Kudos
coenkd
Contributor
Contributor

Works too on workstation 6.0.0 build-45731. Thanx! (wireless Broadcom BCM4318 802.11g)

0 Kudos
clive_long
Contributor
Contributor

Thank you for this patch. Now bridged network is working with my kernel 2.6.23-rc8 with Wireless LAN.

I have updated the patch to also work when no wireless network is used. You can download it here:

The patched vmnet.tar can be found here:

(it is based on the vmnet out of the VMware Workstation 6.0.1)

Hi,

Can you please explain how to apply this? Looks like exactly the problem I am experiencing with wifi.

Ta, Clive

0 Kudos
clawhead
Contributor
Contributor

Thank you for this patch. Now bridged network is working with my kernel 2.6.23-rc8 with Wireless LAN.

I have updated the patch to also work when no wireless network is used. You can download it here:

The patched vmnet.tar can be found here:

(it is based on the vmnet out of the VMware Workstation 6.0.1)

Hi,

Can you please explain how to apply this? Looks like exactly the problem I am experiencing with wifi.

Ta, Clive

If I remember correctly:

(1) Download Hauke-m's patched vmnet.tar file from here:

(2) Go to /usr/lib/vmware/modules/source and rename the original vmnet.tar to vmnetOLD.tar or something like that.

(3) Copy Hauke-m's patched vmnet.tar to /usr/lib/vmware/modules/source/.

(4) Run vmware-config.pl.

That should do it.

(1) Reboot - McCain (2) Reformat - Clinton (3) Install new OS - Obama
0 Kudos
clive_long
Contributor
Contributor

It works!

I can now take my laptop back into my office and run off wifi.

Thanks to those people who worked out this and fixed it.

Thanks for open source.

Clive

0 Kudos
smear3
Contributor
Contributor

I'm doing something wrong here. I renamed the original vmnet.tar to vmnet.tar.old Then as root I copied the patch file to: /usr/lib/vmware/modules/source/. Next I went to /usr/bin/vmware-config.pl and ran that script as root. After clicking enter on everything I restarted my virtual machine but the nic on the xp sp2 still thinks it's connecting to the LAN. I am running Ubuntu Gutsy Kernel 2.6.22 and Workstation 6.0.2. The only thing that I can think I'm doing wrong is not enabling NAT in the config.pl. The reason I don't want NAT is I want my virtual machine to get it's ip from DHCP on the Windows network so I can test etc. with it. Why do you think that my wireless isn't working? Basically my problem is like the others here. It works wired but not on the wifi. Thanks in advance for any help.

0 Kudos
clive_long
Contributor
Contributor

I'm doing something wrong here. I renamed the original vmnet.tar to vmnet.tar.old Then as root I copied the patch file to: /usr/lib/vmware/modules/source/. Next I went to /usr/bin/vmware-config.pl and ran that script as root. After clicking enter on everything I restarted my virtual machine but the nic on the xp sp2 still thinks it's connecting to the LAN [2}. I am running Ubuntu Gutsy Kernel 2.6.22 and Workstation 6.0.2. The only thing that I can think I'm doing wrong is not enabling NAT in the config.pl . The reason I don't want NAT is I want my virtual machine to get it's ip from DHCP on the Windows network so I can test etc. with it. Why do you think that my wireless isn't working? Basically my problem is like the others here. It works wired but not on the wifi. Thanks in advance for any help.

May well be your problem. Have you run two NICs before? If not, then you need two bridged NICs. By hitting enter and accepting all defaults you will end up with vmnet0 as bridged, vmnet1 as NAT and vmnet8 as host. You do not want this default config if you want both NICs to connect to a physical network. See also .

this is fine. Guest OS always see the NICs as wired connections - no matter whether they are physically wired or wifi.

I'm not quite understanding what you have written. I am assuming you don't want NAT but want both NICs to take there IP Address from a DHCP server. This is a fine simple setup. I just wanted both virtual NICs to be on the same subnet as the DHCP server in the router. So when I ran vmware-config.pl I set both vmnet0 and vmnet1 to be bridged and deleted all other vmnet2. In the virtual machine parameters I mapped eth0 to vmnet0 and eth1 to vmnet1. The detailed instructions and lots of variants to create subtle and easy-to-get wrong subnets are documented in the WS User Guide Chapter 13, configuring a virtual network > Setting Up a Second Bridged Network Interface on a Linux Host, works under Linux

Clive

0 Kudos
franske
Contributor
Contributor

Thank you -very- much for this patch!

Now bridging works on my Asus A6M with a Atheros 5006XS Wifi-miniPCI card (I ditched the broadcom 4318), Mandriva 2008.0 AMD64, kernel-laptop-2.6.22.9 with VmwareServer 1.04.

All FYI.

0 Kudos
franske
Contributor
Contributor

Sorry,

Looks like I was too quick: it seemed to be working, but after a restart it doesn't anymore.

I'll look into it.

BTW: Virtualbox-1.5.0-OSE has no problems whatsoever, could look at that source-code..

0 Kudos
clawhead
Contributor
Contributor

Is the vmnet device you're using bridged to the correct network adapter? I.e., if you're using vmnet0 and your wifi adapter is at eth1, have you instructed VMWare to bridge those two devices? This is usually done when you run vmware-config.pl, although it can be partially adjusted in Settings.

(1) Reboot - McCain (2) Reformat - Clinton (3) Install new OS - Obama
0 Kudos
franske
Contributor
Contributor

My Atheros Madwifi is set at ath0. And I have tried a lot of config incl. the one you mention.

I think I :

- better use the org vmnet.tar,

- set my eth0 to a static address,

- set vmnet0-bridge to eth0 (vmware -wants- one bridge) and

- try to use NAT or Host-only to/on ath0

Bridge on ath0 is a no-go it seems with VMwareServer 1.04

Annoying, all of this.

I would use Virtualbox (no problems there) but it uses much more cpu-power.

It's now 21.22 hr over here. Finished the setup:

- eth0 static setup & start at boot !

- vmnet0-bridge set to eth0

- vmnet8 NAT+DHCP on ath0

It works & good enough for me.

Pity I cannot do with just the bridge to ath0, but I can live with it.

Franske

0 Kudos