reagles
Contributor
Contributor

Kali Extremly slow to load and run

Hi all,

I'm hoping you can help with this as I've run out of Google answers and I have no idea how to fix this, I'm super confused.  I've used VMware Workstation for a long time, and it's definitely my preferred choice.  I recently got a new laptop (i7-1260p, 32GB RAM, Win 11 Pro) and wanted to run Kali on it, however it was really slow.  Got a note saying "You are running this virtual machine with side channel mitigation enabled" and basically I had to disable it to speed it up.  Never seen it before, but I guessed it was because I'm on latest spec stuff, but I couldn't see how to do this in standard Workstation, so I thought I'd try out Pro to try out this fix.  Was able to disable it but still really slow to load/run.

Started Googling it and saw other people have had similar issues, so I've tried all the solutions I could find; tried turning Hyper-V off with the bcdedit /set hypervisorlaunchtype off command, and turned off memory isolation in Core Isolation, I've changed the memory preferences for VMware Pro to 'Fit all virtual machine memory into reserved host RAM'.  I've tried various combinations of device setup from 2GB Memory to 16GB's, 2 cores to 8.  Different Linux versions within the setup, (usually Debian).  I've tried iso installs and re-downloading, extracting and installing images.  Same everytime, if anything it's getting worse. 

It'll often (slowly) get to the point where it says 'Loading inital ramdisk' and then take about a minute or more to continue.  And then when you're in, everything is slow.  For example Firefox takes 5-10 seconds to load.

I've downloaded Virtual Box, and it's working perfectly on there, but I'd much rather use VMware as I prefer it.  Does anyone else have any other ideas on what this could be and how to fix it?  I'm ashamed to say I'm not sure where or how to find the log files to provide more data so apologises for not putting them up.

Many many thanks in advance for any help you can offer.  Like I said trying to fix this is driving me nuts...

Labels (3)
8 Replies
reagles
Contributor
Contributor

Update: In case anyone is following this, unfortunately I haven't made any progress on this.  Still can't find anything that'll resolve this issue.  Have tried different compatability settings as well.  Found some "fixes" for Ubuntu, but couldn't apply them to Kali.  Currently trying to install Parrot as a diffierent option, but everything still appears slow, it's taking a long time to unpack the image, but I'll wait to see if it's still slow once it's installed, but as it's also Debian I'm not expecting it to be any different.

Again, if anyone can provide any guidance or help on this it'll be greatly appreciated.  I'm not able to get any support from VMWare so I'm kind of relying on the community for this one.  Again I'd prefer to stick with VMWare, but I'm going to have to swap to Virtual Box by the look of things.

0 Kudos
Technogeezer
Champion
Champion

You're running an Alder Lake (12th gen) Core processor. Its performance/efficiency core architecture and Windows handling of scheduling threads across the two types of threads are giving Workstation users fits.

If you're running Windows 11 as a host, try changing its power profile from "Balanced" to "Performance" and see if that makes a difference.

 

reagles
Contributor
Contributor

Many thanks for your reply @Technogeezer.  I did see a little bit about this before but because they were month's old I didn't put much stock in them as I though VMWare would have resolved the issue by now.  Turns out they haven't...

I tried changing the power profile as you suggested and although it definetly helped a little, unfortunatly it hasn't resolved the issue.  It's still miles slower than VirtualBox.  Did a bit more research into the Alder Lake issue and found some more possible solutions like disabling the E-cores in the setup file/s, but there's no guarantee that'll work either and it's really isn't something we should have to do.  I'm shocked VMWare haven't managed to get on top of this issue by now considering Alder Lake's been around for over a year.  Should have done a bit more research before purchasing this laptop, but it never crossed my mind that mainstream software wouldn't work with mainstream hardware...  Live and learn I guess.  Definitely won't be purchasing Workstation Pro now though.

Apologises for ranting...  But many many thanks again for pointing me in the right direction.  The path forward is much clearer now.

0 Kudos
Technogeezer
Champion
Champion

Yes, it is a shame that VMware has not either addressed this in their products or told us exactly why they haven't. 

This performance/efficiency core architecture concept is not going away.

It's almost like "well, we don't support Alder Lake in ESXi, so we're not going to do that in the desktop products since we reuse a lot of ESXi code". I'd welcome a response by a VMware employee to tell me if I'm right or wrong - but I'm not hopeful that I'll get one.

reagles
Contributor
Contributor

I completly agree, it just doesn't make any scense.  And it's even more surprising that they appear to be ignoring it.  It's a worrying sign. It would at the very least be reassuring to have a VMWare employee address this, but like you say, I feel this is sadly unlikely. 😞

0 Kudos
Technogeezer
Champion
Champion

One other thought from what I've seen recently:

See https://communities.vmware.com/t5/VMware-Workstation-Pro/SOLVED-VMware-workstation-17-low-performanc... especially the later comment on 1/23/2023 by @wila .

If you disable Hyper-V, and the VM runs on the VMware hypervisor instead of Hyper-V does the situation improve?

0 Kudos
wila
Immortal
Immortal

Hi,

Normally yes.

But getting the Hyper-V hypervisor to be actually disabled and switching over to the VMware hypervisor is becoming more and more difficult.

Basically as long as you see "Monitor Mode: ULM" in the vmware.log file you're running under Hyper-V.

Like I said down there in my reply, don't forget to reboot the host after changing any of those settings.

-

Wil

| Author of Vimalin. The virtual machine Backup app for VMware Fusion, VMware Workstation and Player |
| More info at vimalin.com | Twitter @wilva
0 Kudos
reagles
Contributor
Contributor

I believe I've already tried that @Technogeezer but I gave it another go and unfortunately it's still didn't make any difference.  Still incredibly slow.  This is getting beyond frustrating.  If the issue is with Hyper-V then I think @wila could be right and it's hard to fully disable it now, but it seems like just another issue that VMWare needs to resolve. 

It's absolutely crazy that at the moment, I can't run a basic Linux VM on a well spec'd new laptop.

reagles_0-1674773226236.jpeg

 

0 Kudos