ColinPM
Contributor
Contributor

Guest shutdown hangs at black screen for 5+ minutes with Vista host on Dell D630 laptop

Jump to solution

Has anyone else seen this problem, and can anyone suggest a solution?

We have VMware Workstation 6.0.4 running on a Dell D630 laptop and every guest takes forever to shut down - Windows seems to shut down then the program hangs for a long time with a black screen. Guests in VMware Workstation running on a desktop and a server all shut down normally so it seems to be something specific to either the laptop or Windows Vista.

0 Kudos
1 Solution

Accepted Solutions
continuum
Immortal
Immortal

hey - you use SMP-BartPE ? - me too

But serious - having 2 CPUs in a VM does mostly affect performance badly. But I doubt it matters here.

May i suggest you read my site http://sanbarrow.com/vmx/vmx-config-ini.html

and start with adding this line to config.ini

prefvmx.minVmMemPct = "100"

at the end of the page there is a longer list of tweaks for performance - try one by one to see what makes a difference

___________________________________

description of vmx-parameters:

VMware-liveCD:

Do you need support with a recovery problem ? - send a message via skype "sanbarrow"

View solution in original post

0 Kudos
16 Replies
continuum
Immortal
Immortal

A notebook with Vista should have at least 4 Gb of RAM - otherwise I would recommend to update to XP.

___________________________________

description of vmx-parameters:

VMware-liveCD:

Do you need support with a recovery problem ? - send a message via skype "sanbarrow"
ColinPM
Contributor
Contributor

The laptop has 4GB RAM, dual-core processor, the VMs are on a decently quick external USB drive (Seagate FreeAgent 500GB). Best laptop I ever had, but previous laptops behaved better with VMware Workstation (but were running the XP 'upgrade' Smiley Happy )

Any more ideas?

0 Kudos
continuum
Immortal
Immortal

Do you have a good defragmentation tool and use it regularly ?

Do you use VM with millions of snapshots ?

Do you run antivrus and let them scan vmdks ?

___________________________________

description of vmx-parameters:

VMware-liveCD:

Do you need support with a recovery problem ? - send a message via skype "sanbarrow"
ColinPM
Contributor
Contributor

All good questions.

All (both) disks defragmented regularly.

Happens with all my VMs, with and without snapshots, and even with a dummy 'empty' VM used to boot BartPE from an ISO image.

My antivirus excludes all VMware disk files (and in fact the whole folder structure where I store my VMware images).

Happened with Vista original release, and now also with SP1.

I'm usually the guy to diagnose issues like this, but this one has me stumped for now. I suspect there may be a problem with releasing or flushing the guest memory at shutdown.

Thanks for continuing to help.

Any more ideas?

0 Kudos
continuum
Immortal
Immortal

Lets see your config.ini and a sample vmx-file

___________________________________

description of vmx-parameters:

VMware-liveCD:

Do you need support with a recovery problem ? - send a message via skype "sanbarrow"
0 Kudos
ColinPM
Contributor
Contributor

Here you go:

Config.ini

host.cpukHz = "2500000"

host.noTSC = "TRUE"

ptsc.noTSC = "TRUE"

prefvmx.useRecommendedLockedMemSize = "TRUE"

The cpukHz setting was recommended by a VMware Knowledge Base entry because the laptop processor reported a different speed to VMware than what VMware expected. I suspect but cannot remember for sure that the others came from there too.

Sample .vmx file (a BARTPE VM that exhibits the problem - I specified a Windows Server 2003 VM but it happens with all the Windows versions I have tried).

config.version = "8"

virtualHW.version = "6"

numvcpus = "2"

scsi0.present = "TRUE"

scsi0.virtualDev = "lsilogic"

memsize = "2048"

scsi0:0.present = "TRUE"

scsi0:0.fileName = "Windows Server 2003 Standard Edition.vmdk"

ide1:0.present = "TRUE"

ide1:0.fileName = "C:\My ISO Images\PEBuilder.iso"

ide1:0.deviceType = "cdrom-image"

floppy0.autodetect = "TRUE"

ethernet0.present = "TRUE"

ethernet0.connectionType = "hostonly"

ethernet0.wakeOnPcktRcv = "FALSE"

usb.present = "FALSE"

ehci.present = "TRUE"

sound.present = "FALSE"

sound.fileName = "-1"

sound.autodetect = "TRUE"

svga.autodetect = "TRUE"

pciBridge0.present = "TRUE"

mks.keyboardFilter = "allow"

displayName = "Windows Server 2003 Standard Edition"

guestOS = "winnetstandard"

nvram = "Windows Server 2003 Standard Edition.nvram"

deploymentPlatform = "windows"

virtualHW.productCompatibility = "hosted"

tools.upgrade.policy = "useGlobal"

ide1:0.autodetect = "TRUE"

floppy0.fileName = "A:"

extendedConfigFile = "Windows Server 2003 Standard Edition.vmxf"

floppy0.present = "FALSE"

ethernet0.addressType = "generated"

uuid.location = "56 4d 26 b8 68 35 80 aa-17 34 b9 de c7 86 29 5d"

uuid.bios = "56 4d 26 b8 68 35 80 aa-17 34 b9 de c7 86 29 5d"

scsi0:0.redo = ""

pciBridge0.pciSlotNumber = "17"

scsi0.pciSlotNumber = "16"

ethernet0.pciSlotNumber = "32"

ehci.pciSlotNumber = "33"

ethernet0.generatedAddress = "00:0c:29:86:29:5d"

ethernet0.generatedAddressOffset = "0"

Thanks for your interest

0 Kudos
continuum
Immortal
Immortal

hey - you use SMP-BartPE ? - me too

But serious - having 2 CPUs in a VM does mostly affect performance badly. But I doubt it matters here.

May i suggest you read my site http://sanbarrow.com/vmx/vmx-config-ini.html

and start with adding this line to config.ini

prefvmx.minVmMemPct = "100"

at the end of the page there is a longer list of tweaks for performance - try one by one to see what makes a difference

___________________________________

description of vmx-parameters:

VMware-liveCD:

Do you need support with a recovery problem ? - send a message via skype "sanbarrow"

View solution in original post

0 Kudos
ColinPM
Contributor
Contributor

Yes I use BARTPE and one day will get time to learn how to use the Windows Vista Automated Installation Kit to see if it is any better.

Thank you for all your help with this issue.

That page of yours is a great resource. The first setting I tried greatly reduced my VMware guest startup time, but did not resolve the issue with the shutdown time. I added the setting below:

useNamedFile= "FALSE"

and it really sped up the startup time. Based on that I tried moving a VMware guest image from my external drive to the local drive and what a difference! The guest shut down almost instantly. The issue is clearly to do with the USB bus and/or the USB drive.

I shall continue to experiment with the other settings you recommend(ed) to see if I can get adequate shutdown performance for VMware guests on the external drive.

Thank you very much!

0 Kudos
ColinPM
Contributor
Contributor

Here is an update.

I tried the following settings and my shutdown time was reduced dramatically, even on the USB drive:

prefvmx.minVmMemPct = "100"

mainMem.useNamedFile = "FALSE"

mainMem.partialLazySave = "FALSE"

mainMem.partialLazyRestore = "FALSE"

Ulli, thanks again for all your help! Problem resolved.

Colin

0 Kudos
labqa
Contributor
Contributor

Hi, I have the exact same problem with three different VM Hosts, the Guest OS takes 5 minutes or longer to get past the black screen and shut down. I did not have this problem with v5.5 and am using v6 now. I tried adding the settings that worked for Colin to the config.ini file but that did not do anything. Is this a known issue by now, does anyone know of a solution? Here's what I have not in my config.in (the first three lines were already in there):

prefvmx.useRecommendedLockedMemSize = "FALSE"

prefvmx.allVMMemoryLimit = "900"

tools.upgrade.policy = "upgradeAtPowerCycle"

prefvmx.minVmMemPct = "100"

mainMem.useNamedFile = "FALSE"

mainMem.partialLazySave = "FALSE"

mainMem.partialLazyRestore = "FALSE"

0 Kudos
sugarmonster
Contributor
Contributor

I had exactly the same problem using server 2k8 (x64) as a host and VMWare 6.5. I could create a new, blank VM, power it on and it wouldn't power off.

Much hair pulling and not a little desperation later I narrowed it down to USB support. I had a bluetooth USB device not recognised in the host (device manager showing yellow exclamation marks). Removing USB support from the guest allowed it to shut down properly, which was at least a starting point.

I then fixed the host drivers so that the bluetooth dongle was recognised properly and VMWare magically recognised everything and started working again!

The config files made no difference in my case, although I'm sure they're great for tweaking performance once it fundamentally works...

Marc.

0 Kudos
kwigibo
Contributor
Contributor

ColinPM wrote:

prefvmx.minVmMemPct = "100"

mainMem.useNamedFile = "FALSE"

mainMem.partialLazySave = "FALSE"

mainMem.partialLazyRestore = "FALSE"

Worked for me too.

I have

Vista SP1 (fully patched)

Dell Latitude D630

Thanks to all who helped. Smiley Happy

0 Kudos
posaunenbaer
Contributor
Contributor

had the same problem an opened a thread, too.

http://communities.vmware.com/message/1157846

Here I found the solution.

Thank you.

0 Kudos
mattmilner
Contributor
Contributor

I had the same problem, and changing those four settings worked for me. Thinkpad T500 with Dual Core Intel processor. Running VMWare Workstation 6.5 on Windows 7 x64. Guest OS is a 32 bit version of Windows Server 2008.

thanks for the help!

Matt

0 Kudos
valdetero
Contributor
Contributor

I know this thread is long dead, but if anyone comes to it after me, I wanted to say it still works.

I have a Latitude E6510 running Win7 x64 and VMWare Workstation 8.0 and a few VMs on an external USB drive and they would take forever (if at all) to shut down after the screen went black. I only seemed to notice this when the VMs were on the external drive.

I added those four lines and my VMs' shutdown is almost immediate.

0 Kudos
sysfried
Enthusiast
Enthusiast

Aparently this fix is also still valid for Workstation 9.x on Windows 7 (64Bit)

0 Kudos