chumaito
Contributor
Contributor

Guest display scaling on Workstation 11?

Jump to solution

The feature list for Workstation 11 says, "Workstation 11 has been optimized to support higher resolution displays like the new QHD+ (3200x1800) displays used in laptops and x86 tablets."  This was a big selling point for me, as I have a Yoga 2 Pro (3200x1800).  When I boot up my Ubuntu VM, though, the display still appears tiny, and most things are too small to read.  I expected to be able to scale this up so I can work with it properly on my ultrafine pixel screen, but I don't see any way to do that.  This all sees the same as Workstation 10.  There is the ability to go fullscreen and scale, but I am accustomed to working with multiple VMs at a time in separate windows.  What am I missing?

1 Solution

Accepted Solutions
elsnook
Contributor
Contributor

I just ran into this problem on a Surface Pro 3.  For me the solution was:

  1. Close VMware Workstation
  2. Right click on the VMWare workstation Shortcut
  3. Select Properties
  4. Choose Compatibility
  5. Under Settings Check "Disable display scaling on High DPI settings".
  6. Open Workstation

On a side note, Workstation 11 seems to be running perfectly well on Windows 10 Insider Build 10162

View solution in original post

30 Replies
chumaito
Contributor
Contributor

I found this similar, unanswered question:

Pixel doubled guest in high dpi host / zoom in VMWare 11

0 Kudos
TracyHuang
Enthusiast
Enthusiast

Thanks for the posting. Would you please provide more details for the issue? What's the host OS? Have you choose the "Use host setting for monitors" in Display menu of Virtual Machine Setting, also choose the graphics memory as recommended? Besides, if the VM is not a new installed OS, would you please upgrade the vmware tool as well? Finally, it would be appreciated if you can upload the vmware.log for our investigation.

0 Kudos
chumaito
Contributor
Contributor

The host OS is Windows 8.1.  I am running at 3200x1800.  Windows 8.1 has a feature in the "Display" control panel app, "Change the size of alll items" which has 5 steps (gradations?)  and is intended to enlarge all windows, fonts, icons, etc. equally to give the effect of a lower resolution display.  I have it set to the second highest magnification value.  I would like to set it lower, but pixel-based windows become unreadable.  Workstation 11 ignores this setting and displays guest windows pixel-per-pixel.

I need a solution that works without VMWare tools, as I may run legacy and/or unsupported systems.

The described behavior occurs with "use Host Settings for Monitors" on.  Turning it off does not change anything.

I feel that I should point out that my issue is really only about how the guest display is rendered on the host.  For instance, when the guest is booting and is still in text mode, I cannot read anything on the console, because the text is too small.

I am trying to get Workstation Server running in the hopes that I can connect to the VM with a tool that scales, if such exists.  If that fails, I will just start dropping my screen resolution as mitigation.

0 Kudos
memorx
Contributor
Contributor

Same issue here!

Im working with a Fujitsu U904 with a QHD 3200x1800 Display.

My VM's are not scaled in the Workstation but a feature from Workstation 11 should be scaling for this Displays, but where to enable ?

Win 8.1 Update as well

0 Kudos
UnitUniverse2
Enthusiast
Enthusiast

Temporary you may get a workaround by openning MainMenu->Edit->Preferences, Then click 'Display' on the left of the dialog-box, uncheck the 'Auto-fit guest' and select the 'Stretch guest', You have to put the guest on the full-screen mode as needed.

The high-resolution support of the VM, as my understanding, is to let the guest os being capable of applying high-resolution larger than legacy HD rather than stretching/compressing the guests' view.

In window mode there seems no simple way for now and you have to live with that until they do something to figure any solution out.

0 Kudos
chumaito
Contributor
Contributor

Summary of findings:, Workstation 11.0.0 on Windows 8.1

     - Display scaling occurs only in fullscreen mode.

     - The display in fullscreen mode is limited to the resolution used by Windows, not the device resolution.  If you are using reduced resolution on your high-res device to accomodate legacy programs which do not scale, you are limited to that resolution in Workstation's fullscreen mode.

     - Displays do not downscale.  If you have a guest with a resolution greater than the host is using, there will be scrollbars in fullscreen mode.

     - Full screen displays are not integrated with Metro, and thus cannot be cycled through via alt-logo.

I was unable to get Workstation Server running, so I don't know about connecting to guests via viewers.

0 Kudos
RuralRob
Enthusiast
Enthusiast

What I would really like to see is support for the scaling of text displays to fill the host window on a high-resolution screen.

For example, installing Ubuntu Server 15.04 under Workstation 11 (Windows 8.1 host, 3200x1800 screen):

Screenshot (1).png

If you squint real hard, you can ALMOST read that Ubuntu setup screen.

Any way to zoom this to fill the window?

0 Kudos
altjx
Enthusiast
Enthusiast

Has anyone found a solution to this? It seems that there's several threads out there that talks about the same issue, and I have yet to see one solution. Not even any suggestions.

0 Kudos
amsharifian
Contributor
Contributor

There is no new answer? So why they have announced they are supporting high dpi display??

0 Kudos
elsnook
Contributor
Contributor

I just ran into this problem on a Surface Pro 3.  For me the solution was:

  1. Close VMware Workstation
  2. Right click on the VMWare workstation Shortcut
  3. Select Properties
  4. Choose Compatibility
  5. Under Settings Check "Disable display scaling on High DPI settings".
  6. Open Workstation

On a side note, Workstation 11 seems to be running perfectly well on Windows 10 Insider Build 10162

View solution in original post

thejesperbernle
Contributor
Contributor

It might not be a permanent solution but it works for me so I thought I post it here as an alternative, at least. Smiley Wink

My global settings in VmWare Workstation 11:

displaysettings2.jpg

And individual VM setting:

displaysettings.jpg

As soon as I go Full Screen Everything is to my liking. Smiley Happy

ElissaJ
Contributor
Contributor

#10 - This is the answer. Thanks Elsnook! Someone should mark this as the answer I think.

0 Kudos
ys_ding
Contributor
Contributor

Hi,

I am having the same problem as well, my laptop's resolution display is QHD+ (3200X1800), but i am using Workstation 12, instead of 11.

I have tried to check the "Disable display scalling on High DPI settings" under Properties > Compatibility, however, it does not help me. The guest's display is so tiny and so challenging to read. Guest is running on Windows 7.

Can someone please help. Thanks.

0 Kudos
dahan
Contributor
Contributor

One of the big new features in Workstation 12 is supposed to be "Ready for High Resolution Displays", but it's still pretty broken, which is very disappointing Smiley Sad

I mentioned the problems during the preview: High DPI support but the preview period was extremely short and 12 was released soon after my post, with none of the issues fixed as far as I can tell.

0 Kudos
jileto
Contributor
Contributor

Also on WS12 running in a Win10 host with a Win7 guest.  My workaround was to RDP into the guest using RDTabs by Avian Waves.

Maximize the program when it starts up.  Set up your RDP connection to the guest.  Use the default Display/Screen size settings first - you can customize later.  It will stretch the guest session to fill up the screen.  It even has the option to scale down the screen if you set up a session screen size that is larger than the host screen size.

0 Kudos
altjx
Enthusiast
Enthusiast

Bump. Anyone? Anything? Am I the only person that runs VMware Workstation with 4k monitors around here?

0 Kudos
dahan
Contributor
Contributor

From all the threads about it, I think it's safe to say that there are many people who run Workstation on 4k monitors here. The problem seems to be that nobody at VMware does Smiley Sad Seeing that the usability issues are readily apparent as soon as you try.

altjx
Enthusiast
Enthusiast

Bump. Pretty disappointing how it's the only app that still has issues with this. I would have considered selling my 4k monitors had it been other applications as well, but it's just VMware. Is there not a support group that come to these threads and assist with these issues or anything? Anyone know if VirtualBox has this fixed? I'd gladly pay for another product to get this working as opposed to waiting another four years for this to be fixed.

0 Kudos
mcsleuthburger
Contributor
Contributor

This is a super old thread but since it is unanswered and I was having the same issue, here is the solution.

Once connected to guest, in the Workstation Console click the "VM" tab and click to "Install VMware Tools" - continue on the Guest Machine to complete the installation. After the installation, it will prompt you to reboot the Guest. This should fix the issue. Also make sure that your Autosize is set to Autofit Guest / Autofit Window under the "View" tab.

0 Kudos