Grimmda
Contributor
Contributor

Cannot press ESC to get into BIOS fast enough

I run Vista Business x32 on my host and had VMWare Workstation Version 6.0.0 Build 45731 and installed Build 55017 Yesterday.

I went from being able to turn my Guest OS's on and press the ESC key and change my boot orders to NOT being able to do so because the bios flashed by so quickly.

I looked around and found a thread that said others had problems with this with some versions and the fix is to unmount some hard drives out of the Guest and it was easier to hit ESC.

That "workaround" is unacceptable considering the amount of boot orders I change (probably 5-10 a day depending on the work I'm doing) so I uninstalled 55017 and reinstalled 45731 and am again able to change the boot order.

Allow me to echo the request of others and make the "BIOS boot time" a configurable item, thank you.

0 Kudos
15 Replies
oreeh
Immortal
Immortal

While the console has the focus press Ctrl-R (Reset). This should give you enough time to get into the VM BIOS

0 Kudos
Grimmda
Contributor
Contributor

That might be the case, but the issue is I can't have things be "hit or miss". I build images using sysprep, and if I'm not sharp enough to change the boot order I have to restore a snapshot and try again. I could get into the bios with focus 1 out of 4 times. I shouldn't have to "play" a game of getting into the BIOS.

0 Kudos
oreeh
Immortal
Immortal

In this case you can simply adjust this once and copy the nvram file from the VM folder to the new VMs.

0 Kudos
Grimmda
Contributor
Contributor

That sounds like a better workaround, thanks!. Still a workaround though. Something configurable would be nice.

0 Kudos
oreeh
Immortal
Immortal

Since this is configurable in VMware Fusion I suspect it (in the future) to be available in Workstation as well.

0 Kudos
admin
Immortal
Immortal

Edit your .vmx file and add the line:

bios.bootDelay = "5000"

which adds a 5000 millisecond (5 second) delay to the boot, or add:

bios.forceSetupOnce = "TRUE"

to make the VM enter the BIOS setup at the next boot.

Edit:

(Argh, what's the new equivalent of the old "code" tags?)

Edit #2:

Got the config options right this time.

0 Kudos
oreeh
Immortal
Immortal

So this feature is already present in WS6... good to know

0 Kudos
oreeh
Immortal
Immortal

The new equivalent is

text

without the spaces, and without a slash in the closing block

All documented here: http://communities.vmware.com/markuphelpfull.jspa

0 Kudos
admin
Immortal
Immortal

I believe the bios.bootDelay/bios.forceSetupOnce options are present in Workstation 6.0.1 (but probably not 6.0).

And thanks for explaining the new (and strange..) markup to me. Smiley Happy

0 Kudos
oreeh
Immortal
Immortal

I believe the bios.bootDelay/bios.forceSetup options are present in Workstation 6.0.1 (but probably not 6.0).

I'm using 6.0.1 since the beta.

Now this only has to be ported to ESX and Server as well Smiley Wink

And thanks for explaining the new (and strange..) markup to me. Smiley Happy

You're welcome

0 Kudos
SteveHathaway
Contributor
Contributor

The phoenix bios setup in VMWare Workstation 6.0.2 build 59824 still has an extremely short window to capture the bios setup.

I have had to reset multiple times on a fast workstation (reset) (get-screen) (press escape) that must all be accomplished within

about 1/2 second. Once the bios setup is captured, the boot order and other bios parameters can be set and saved.

The VMWare Workstation documentation -- I cannot find how to lengthen the delay to capture the bios setup.

None of the user screens have the ability to set this problematic short bios capture delay.

If editing a script is required - where is the documentation?

I was trying to use the "Other Linux2.6x Kernel" setting that determines the type of guest operating system.

I am trying to port some of my LinuxFromScratch development to virtual workstation isolation.

I have been evaluating VMware Workstation for only a few days and think the performance is world class.

- Steve Hathaway

0 Kudos
tgrigsby
Contributor
Contributor

This procedure worked for me ESX 3.1

The default boot order appears to be Floppy/Harddisk/CdROM

So I created a bootable floopy image.

Restarted the Vm with the floppy connected at power on.

At the A: prompt I then did a CtlrAltIns to reboot the vm.

I then had a few seconds to hit the esc key before it blew by.

Some Bios 's back in the day actually had a way to access the bios from DOS... I don't know if this is the case for the VMWARE bios.

0 Kudos
Peter_vm
Immortal
Immortal

If you read this post:

http://communities.vmware.com/message/760222#760222

You would not have a problem

0 Kudos
tgrigsby
Contributor
Contributor

Read it.

Tried it.... Tried it again...

Didn't Work.

Most likely reason because ESX server was not patched to the latest version.

However once we get our server patched you can bet I will be using the info in the post above Smiley Happy

0 Kudos
admin
Immortal
Immortal

In Workstation 6.5, you can now go to VM > Power > Power On to BIOS.

0 Kudos