introiboad
Contributor
Contributor

Bluetooth device showing in VM guest even after disabling Bluetooth Sharing

Jump to solution

Hi all,

I am running the following setup:

Host: Windows 10

VMWare Workstation Pro 14.1

Guest: Ubuntu 17.10

I have a USB Bluetooth controller (device) on my laptop, controlled by my Windows Host, that I do not want to share with the VM. I have disabled "Share Bluetooth devices with the virtual machine" and I of course do not connect the actual USB device to the VM, which goes by the name of "Intel(R) Wireless Bluetooth(R)".

The issue is that the Bluetooth device is still being found by both my Windows host and Ubuntu guest, which should not be the case since I have disabled the option to do so.

Any ideas on why this could be the case?

Thanks in advance.

Message was edited by: introiboad

0 Kudos
1 Solution

Accepted Solutions
introiboad
Contributor
Contributor

It looks like while I was playing with the .vmx file and stopping and starting the VM at some point the lines:

usb.autoConnect.device0 = ""

usb.autoConnect.device1 = "name:Virtual\ Bluetooth\ Adapter vid:0e0f pid:0008

finally disappeared from the .vmx file and that solved my issue.

Thank you everybody for your help!

View solution in original post

0 Kudos
12 Replies
bonnie201110141
VMware Employee
VMware Employee

I cannot reproduce it locally with host Windows 7 + Guest Ubuntu 16.04.4.

Did you disable the option when the VM is powered off?

0 Kudos
introiboad
Contributor
Contributor

Hi there,

Thanks for looking into this.

Yes, I did turn off the VM in order to change the setting. I tried again right now:

1. Shut down Ubuntu in the VM

2. Make sure the checkbox is *not* set (Share Bluetooth devices with the Virtual Machine)

3. Boot up Ubuntu in the VM

The result is that when I type "hciconfig" on a shell I get:

$ hciconfig

hci0:   Type: Primary  Bus: USB

        BD Address: 00:28:F8:B3:4D:08  ACL MTU: 8192:128  SCO MTU: 64:128

        UP RUNNING

        RX bytes:539 acl:0 sco:0 events:28 errors:0

        TX bytes:1107 acl:0 sco:0 commands:28 errors:0

I also tried connecting to a Bluetooth device from Ubuntu and it works, so it's clearly seeing the controller and managing it.

And of course if I got to the Bluetooth options on Windows I can still use the Bluetooth device there by looking for devices, connecting to mice, etc.

It might be a Windows 10 issue?

Thanks again.

0 Kudos
bonnie201110141
VMware Employee
VMware Employee

VMware virtual bluetooth adapter would be enumerated as a "Generic Bluetooth Adapter" in VM, not "Intel bluetooth". "hciconfig -a hci0" would show manufacturer as 6502. Would you please check the output of "hciconfig -a hic0" in you VM?

0 Kudos
introiboad
Contributor
Contributor

Hi there,

Indeed the adapter's manufacturer is shown as 6502 inside the VM, so there's something wrong with the sharing, VMWare seems to be ignoring the fact I unchecked the checkbox. Here's a screenshot:

vmware_bluetooth.png

That said, the device still appears on VMWare's Removable Devices menu as Intel Wireless Bluetooth:

vmware_removable_devices.png

Thanks again.

0 Kudos
RDPetruska
Leadership
Leadership

The pull-down menu within Workstation *will* show the device as how your host sees/enumerates it (Intel Wireless Bluetooth in your case).  If you select that in the pull-down menu, what does the sub-menu show?  Is anything under there checked?

0 Kudos
introiboad
Contributor
Contributor

Hi there,

The sub-menu just shows the usual options as you can see from this screenshot:

EDIT: I tried unchecking "Show in Status Bar" but it seemed to make no difference at all, the Linux kernel still sees the device.

vmware_removable_devices_2.png

Thanks!

0 Kudos
introiboad
Contributor
Contributor

Interestingly enough, if I press "Connect (Disconnect from Host)" then the Linux kernel sees 2 Bluetooth adapters!

See screenshot below:

vmware_bluetooth_both.png

0 Kudos
bonnie201110141
VMware Employee
VMware Employee

I still cannot reproduce your issue. Will you please try to remove USB controller and add it again? Also you can try USB3.0 and USB2.0 and see if anything different. Also, please attach vmware.log.

0 Kudos
introiboad
Contributor
Contributor

I tried removing the USB controller from the VMWare VM Settings window and adding it again, this didn't help and I still see the controller inside my VM.

I tried switching to 2.0 and 3.0 and it again made no difference.

You can find the link to my log files here: vmware

0 Kudos
continuum
Immortal
Immortal

I looked into your logs and have a different theory:

I assume the problem is caused by poorly coded interaction GUI - vmx-file.
Try to add this line to your vmx - in case it does not exist.
usb.vbluetooth.present = "FALSE"

Do you need support with a recovery problem ? - send a message via skype "sanbarrow"
0 Kudos
introiboad
Contributor
Contributor

Try to add this line to your vmx - in case it does not exist.

usb.vbluetooth.present = "FALSE"

I tried this (the line was not present) but it still doesn't fix the issue.

There's some more to this though because:

1) The "Share Bluetooth devices with the virtual machine" checkbox resets itself even if I check it, something I had never tried

2) The following lines are auto-added every time I load the VM even though I remove them manually from the .vmx file:

usb.autoConnect.device0 = ""

usb.autoConnect.device1 = "name:Virtual\ Bluetooth\ Adapter vid:0e0f pid:0008

0 Kudos
introiboad
Contributor
Contributor

It looks like while I was playing with the .vmx file and stopping and starting the VM at some point the lines:

usb.autoConnect.device0 = ""

usb.autoConnect.device1 = "name:Virtual\ Bluetooth\ Adapter vid:0e0f pid:0008

finally disappeared from the .vmx file and that solved my issue.

Thank you everybody for your help!

View solution in original post

0 Kudos