Termux
Contributor
Contributor

[BUG] Service uses port 443

Good morning, I have updated Workstation to version 16. Being a web programmer, I also run a local Web Server on my PC to test PHP pages.

Reading the Release Notes of this new version I noticed that the Shared VMs feature has been removed.

The problem lies in the vmware-hostd.exe process, which uses port 443, not allowing me to run XAMPP. I tried to look in VMware settings, but the ability to change port has been removed.

Try to fix it as fast as possible.

Thanks

pastedImage_2.png

Tags (2)
2 Replies
a_p_
Leadership
Leadership

I didn't update to v16 yet, so this is taken from v15.

Since I don't use Shared VM's, the "VMware Workstation Server" (VMwareHostd) service is disabled on my PC. The port that it uses - in case it's enabled - can be found in C:\ProgramData\VMware\hostd\proxy.xml.


André

Hockeychap
Contributor
Contributor

Just to extend AP's answer.

I had exactly the same problem. To disable the https server change the third line in C:\ProgramData\VMware\hostd\proxy.xml

from

<httpsPort>443</httpsPort>

to

<httpsPort>-1</httpsPort>

This has disabled the https server on my machine. If you set it to a non -1 value, that seems to be the port that the server will use.  YOu will need to restart the "VMWare Workstation Server" services on you pc to make the change effective.

HTH,

Justin