jjex22
Contributor
Contributor

Vmware tools installer crashes (win 2k pro)

Jump to solution

Hi all, I've been using virtual box on my linux netbook for a while (win xp, win 2kpro and win 98 - the disks i have basically!) anway, finnally got a new desktop with windows 7, and thought I'd give vmware a go and purchased workstation 8.  on paper it should be basically the  same - they both don't support windows 98, but do support the NT based systems.  (to be fair windows 98's VMware tools does install and do everything but sound and networking,)

However, when i try and install VMware Tools in windows 2000 pro, the installer crashes almost instantly  with
" Microsoft Runtime DLLs cannot be installed on this operating system. Please see Microsoft KB835732 for details."


I figure I must be doing something wrong, as I've deleted and re-created the windows 2000 installation and the same thing happens, but on the VMware site this system is listed as supported, Any ideas anyone?

Many thanks,
JJ

0 Kudos
1 Solution

Accepted Solutions
continuum
Immortal
Immortal

sounds like you have a Win2000 with sp1,2 or 3
the installer for the tools needs servicepack4

Do you need support with a recovery problem ? - send a message via skype "sanbarrow"

View solution in original post

0 Kudos
7 Replies
continuum
Immortal
Immortal

sounds like you have a Win2000 with sp1,2 or 3
the installer for the tools needs servicepack4

Do you need support with a recovery problem ? - send a message via skype "sanbarrow"

View solution in original post

0 Kudos
jjex22
Contributor
Contributor

Thanks for repling continuum, Unfortunatly, just checked my computer and it confirms that it is SP4.

0 Kudos
continuum
Immortal
Immortal

do you have versions of MS VisualC runtimes already installed on that system ?

Do you need support with a recovery problem ? - send a message via skype "sanbarrow"
jjex22
Contributor
Contributor

Sorry, that's a little beyond me - how would I check? If it helps, it's a clean install of a Windows 200 professionl sp4 cd?

0 Kudos
continuum
Immortal
Immortal

nothing ;listed in controlpanel > software ?

Do you need support with a recovery problem ? - send a message via skype "sanbarrow"
jjex22
Contributor
Contributor

no, add/remove programs was empty... but your earlier post did make me wonder how old my win2k disk was, as I remember getting the xp computer when xp was new, so I've just downloaded IE6 so I can use MS update, and am running update now to see if it helps, will notify when update complete - ,atleast it can connect to the internet without VMtools, that's one up on virtualbox at least!

0 Kudos
jjex22
Contributor
Contributor

All is working again now! many thanks to continuum, i don't know if it's because my service pack update update was on a seperate cd which i had to install after the main os, or what, but running Windows update has solved the problem.

0 Kudos