waby38
Contributor
Contributor

Player v3.0 under Fedora 12 as HOST

Hi,

I've just tried to use the latest Player v3.0 under my fresh installation of Fedora 12

Installation is ok, and compilation of kernel module is also fine.

=> I've cross check this operation using : "vmware-modconfig --console --install-all" , and my kernel is "2.6.31.5-127.fc12.i686.PAE"

Now, if I start vmplayer, then I got the main screen for less than 1 second, and after disappear / crash without any message

Using strace, I able to see that SIGSEGV (Segmentation fault) append just after reading some stuff from "/usr/lib/vmware/resources/mozilla-root-certs.crt"

Is there any bad experience for Fedora 12 users ?

Using the previous Fedora 11, everything was fine with this Player v3.0!!

Any tips ??

0 Kudos
30 Replies
MihaiSapteCai
Contributor
Contributor

Actually, it's much worse than that. It's not that it just doesn't work - if you start it from the menu it blinks a screen then quits without any error messages. If you start it from the command line (vmplayer) it gives you a long list of errors, the last one about not finding one stupid icon (and most or the others about some accessibility file). The vmware-config command referred in all online helps is gone.

If you try to say... fine, I'll go back to 2.5.3 and download the rpm and install it, nothing happens - there is no vmware-* and vmplayer anywhere in the path.

Fine... download the bundle, and execute it, it starts, goes for a while and crashes (I left it about 30 minutes on a 3GHz machine) at the end when configuring the files (likely a gcc compilation). If you cancel it, it promptly uninstalls happily.

Fine... let's report it - go to vmware.com and try to register - to no avail - Firefox is not playing well with their cookies or something else in their system - you can't even register, let alone post a bug.

I don't know - I heard good things about vmware, but this being the first experience with them got me stumped: nothing seems to work! And this is using Fedora and Firefox - it's not like using an unheard OS and an unheard browser. I'm really disappointed.

M.

0 Kudos
waby38
Contributor
Contributor

Ho, It seem that you experience with "vmplayer" looks bad.

First, Let me give you some tips for your setup: (from "root" account, work for F11 & F12 on x86-32, not tested on 64bits)

  • First, "disable" or set to "permissive" selinux using "system-config-selinux" then Reboot

  • as some kernel modules need to be compiled, you need a compiler & current kernel header.
    "yum install gcc kernel-devel" or "yum install gcc kernel-PAE-devel" (depend of your kernel, check with "uname -r")

Now you are able to install Player v3 and at the end of the setup, the script will compile modules.

to check again if it's ok, you can re-compile module using "vmware-modconfig --console --install-all" from console

If you are running Fedora 11, now you can use a simple "vmplayer" to start. (tested ! work great with 3d enable in WinXP/Win7 Guest !)

For Fedora 12, it still does not yet work...

0 Kudos
Phalken
Contributor
Contributor

First thing : sorry for my bad English, I'm a french guy, and don't speak very well English

For Fedora core 12, I've the same problem as you. If you disconect your nework (in the network manager icon) before you star VMware Player, it's working ! then you just re-connect your network. If your don't work with your VM computer, perhap 5 or 10 min later, VMplayer crash like before... .I'v tried to disable the Firewall.. same result... It's probably a network problem with the new version of the network manager. Perhaps on the next release of this application it will be fixed.

Phalken

0 Kudos
magshs
Contributor
Contributor

I also found this issue

Fedora 12 host

Vmware 3.0 build 203739

The vmplayer looks like it would start but crashed.

A strace showed an issue with certificates. I moved these certs aside and vmplayer now starts

mv /usr/lib/vmware/resources/mozilla-root-certs.crt /usr/lib/vmware/resources/mozilla-root-certs.crt.old

0 Kudos
MihaiSapteCai
Contributor
Contributor

It does appear to be a SELinux problem (I seem to get a violation warning each time I try to install), but disabling the SELinux alone does not fix the problem, i.e., VMPlayer still does not start. However, removing the certificate (how did you ever figure that out??!!!) does the trick. It also keeps working even after re-enabling SELinux. Even Firefox started to work with this forum - things look much better in the morning :-).

M.

0 Kudos
waby38
Contributor
Contributor

Removing access to "mozilla-root-certs.crt" work for me.

2 ways to do that:

  • removing / rename "mozilla-root-certs.crt"

  • disabling Network access (using or not NetworkManager)

After that, Vmplayer work, BUT, if I restore Network access or "mozilla-root-certs.crt",

and I click to "VM->Install VMWare Tools" then VMPlayer crash again as he want to acces

to this certificat.... Probably something wrong here...

And If we remove this certificat, then, "VM->Install VMWare Tools" just say that he can't get

the certificat (probably to check / download updated version of VMWare Tools)

So I thing we hit the real problem! ...but how to fix it ?

Now we have a workarround, but we can't upgrade / install VMWare tools using F12 as HOST...

0 Kudos
MihaiSapteCai
Contributor
Contributor

Did you figure a way around it? I tried to re-enable the certificate while vmplayer is running and it crashes as soon as I try to install the vmware-tools.

The problem is that without the tools I can't seem to get the network to work in Windows 7. This sucks.

M.

0 Kudos
waby38
Contributor
Contributor

no real workarround yet...

Currently, I put my VM on another supported HOST (CentOS, F11, ...) to install/upgrade VMTools,

then I come back to Fedora 12 (and removing *.crt)

We need to wait from VMWare for a clean fix.

0 Kudos
SVRCFL
Contributor
Contributor

The VMware Tools are CD image files (.iso) - you can copy them over to your Player installation from a full Workstation bundle install and then mount them as a CD image.

0 Kudos
MihaiSapteCai
Contributor
Contributor

Unfortunately I don't have the Workstation, but only the player. I'll try the trick with moving the VM to another host and try to install it there - it's a pain, but if it works, it's worth it.

M.

0 Kudos
kissanej
Enthusiast
Enthusiast

Thanks for posting the workaround. I use the same Windows images when I'm setting these up on new PC's so I'll just install the VMware tools package there using Player 3.0 under Fedora 10.

0 Kudos
MihaiSapteCai
Contributor
Contributor

Did the workaround work for you? It certainly did not for me: I moved the guest VM (Windows 7) on a different host (WinXP in my case), installed the VMTools in the guest OS, then moved the guest VM back to the original host (Fedora12) and still no network adapter. Even worse, this time the network adapter says that the cable is disconnected, so it doesn't even try to get an IP address. VMTools work fine in Fedora12 as I was able to share a directory (something that didn't previously work until I installed VMTools).

As far as I see it, I'm a bit in a worse position with the network (as now I don't even have the "cable" plugged in), but in a better position with sharing directories - at least now I can move things in and out of the machine via the shared directory.

I'm still hoping for a solution to the network problem - today is the one week aniversary of Fedora12 - how long do this things take before they get fixed (I'm new at VMWare and have no idea if it's going to be a week, a month, or a year)...

Thanks,

M.

0 Kudos
kissanej
Enthusiast
Enthusiast

Yes it worked fine, I copied the XP image onto a Fedora 10 PC also running Player 3.0, updated the VMware tools (& installed the latest batch of MS updates) and then used sysprep to seal it again. I reran a test build of an F12 PC today and the XP image worked ok.

0 Kudos
ogooreck
Contributor
Contributor

It is somehow releated to updates checking settings.

in ~/.vmware/preferences

pref.vmplayer.downloadPermission = "deny"

(other values "ask" or "allow")

allows vmplayer to start

In GUI parameter is linked to File -> Preferences -> Check for new software components as needed.

--ed

I think this is due to libcurl or libssl shipped with vmplayer wich are used because fc12 version don't have c-ares support needed by vmplayer.. I crafted my own version. for fc12 which works. I removed ipv6 and enabled ssl and c-ares compilation options. One can use it, but it should be noted that many programs use libcurl (124 installed on my computer) so it can break things, because i'm not eble to do all possible tests Also, c-ares should be installed.

yum install c-ares -devel

sudo yum reinstall curl-7.19.6-10.fc12.i686.rpm libcurl-7.19.6-10.fc12.i686.rpm

Message was edited by: ogooreck

0 Kudos
waby38
Contributor
Contributor

Great ! Well spoted !http://communities.vmware.com/!! !http://communities.vmware.com/images/emoticons/happy.gif!

I've just installed updated curl(s) packages, and now VMPlayer-3.0 work fine on Fedora 12 even for download update of VMWare-tools !!

Why did you remove IPv6 support ?

Here what I've done (based on your SRPM) to recompile curl (without removing IPv6)

I just need to remove test as it alway failled (even with vanilla curl package...)

 </p></p>
<p><p>-----------8&lt; -----------8&lt;-----------8&lt;-----------8&lt;-----------8&lt;-----------8&lt;-----------8&lt;---</p></p>
<p><p>diff -r -Nup old/curl-7.19.7-2.fc12.src/curl.spec new/curl-7.19.7-2.fc12.src/curl.spec<br/>
--- old/curl-7.19.7-2.fc12.src/curl.spec        2009-11-26 20:00:12.000000000 +0100<br/>
+++ new/curl-7.19.7-2.fc12.src/curl.spec        2009-11-30 12:05:38.000000000 +0100<br/>
@@ -27,7 +27,9 @@ BuildRequires: pkgconfig<br/>
 BuildRequires: stunnel<br/>
 BuildRequires: valgrind<br/>
 BuildRequires: zlib-devel<br/>
+BuildRequires: c-ares-devel<br/>
 Requires: libcurl = %{version}-%{release}<br/>
+Requires: c-ares<br/>
<br/><br/>
 %description<br/>
 cURL is a tool for getting files from HTTP, FTP, FILE, LDAP, LDAPS,<br/>
@@ -76,6 +78,7 @@ use cURL's capabilities internally.<br/>
 %patch101 -p1<br/>
 %patch102 -p1<br/>
 %patch103 -p1<br/>
+export PKG_CONFIG_PATH=`which pkg-config`<br/>
 autoconf<br/>
<br/>
 # Convert docs to UTF-8<br/>
@@ -85,10 +88,10 @@ for f in CHANGES README; do<br/>
 done<br/>
<br/>
 %build<br/>
-%configure --without-ssl --with-nss --enable-ipv6 \<br/>
+%configure --with-ssl --with-nss --enable-ipv6 \<br/>
        --with-ca-bundle=%{_sysconfdir}/pki/tls/certs/ca-bundle.crt \<br/>
        --with-gssapi=%{_prefix}/kerberos --with-libidn \<br/>
-       --enable-ldaps --disable-static --with-libssh2 --enable-manual<br/>
+       --enable-ldaps --disable-static --with-libssh2 --enable-manual --enable-ares<br/>
 sed -i -e 's,-L/usr/lib ,,g;s,-L/usr/lib64 ,,g;s,-L/usr/lib$,,g;s,-L/usr/lib64$,,g' \<br/>
        Makefile libcurl.pc<br/>
 # Remove bogus rpath<br 
@@ -101,7 +104,7 @@ make %{?_smp_mflags}<br />
 %check<br/>
 export LD_LIBRARY_PATH=$RPM_BUILD_ROOT%{_libdir}<br/>
 make %{?_smp_mflags} -C tests<br/>
-cd tests && ./runtests.pl -a -k -p -v<br/>
+# cd tests && ./runtests.pl -a -k -p -v<br/>
<br/>
 %install<br/>
 rm -rf $RPM_BUILD_ROOT</p>
<p><p>-----------8&lt; -----------8&lt;-----------8&lt;-----------8&lt;-----------8&lt;-----------8&lt;-----------8&lt;---</p></p>
<p><p> 

</p>

I've also checked in SRPM of Fedora 11, and there is no mention about "ares" and "ssl"....

So, Why it work under Fedora 11 ??

Anyway, your workarround is perfect for me

0 Kudos
ogooreck
Contributor
Contributor

I disabled ipv6 just because of faiiled tests, without it tests passed. You disabled tests, same effect Smiley Happy but seriously Your solution may be better.

As of FC11 I thik that libcurl (or libssl) shipped .with vmplayer just works on fc11. You can check in /tmp//vmware-user/apploader-xxxx.log which version is used (system or shipped). If system version has all needed features vmplayer seems to use system version if not shipped version. Default system libcurl version doesn't support ares on fc11 and fc12 but shipped version fails on fc12 and I guess it doesn't fail on fc11. With new libcurl installed vmplayer uses system version, which works.

0 Kudos
MihaiSapteCai
Contributor
Contributor

Hmmm.... is there a clean way to solve the networking problem? Even after installing VMTools on a different machine I still do not have networking working in Windows... I updated FC12, but it didn't help. I'd try the long and involved procedure, but it seems that there is a lot of scope to mess up the installation!

0 Kudos
MihaiSapteCai
Contributor
Contributor

Semi-good news: after updating Linux it seems that it got an update for vmware. SELinux does not allow it to install, but after disabling SELinux it installed and networking started working - all versions - NAT, bridge, host only - they all work. But if I enable SELinux back it stops working. I disable it and it starts again.

I'm a bit uncomfortable with disabling SELinux - anybody knows a fix for the problem? The warning in SELinux seems to be about labeling of vmnet0...

Thanks,

Mihai

0 Kudos
MihaiSapteCai
Contributor
Contributor

OK, it finally works!!! To solve the SELinux problem I just followed the advice in the SELinux error (about changing the type of the virtual interfaces in /dev) and it just worked OK:

# restorecon -v /dev/vmnet8

restorecon reset /dev/vmnet8 context unconfined_u:object_r:device_t:s0-&gt;system_u:object_r:vmware_device_t:s0

# restorecon -v /dev/vmnet0

restorecon reset /dev/vmnet0 context unconfined_u:object_r:device_t:s0-&gt;system_u:object_r:vmware_device_t:s0

# ls -Za /dev/vmne*

crw-------. root root system_u:object_r:vmware_device_t:s0 /dev/vmnet0

crw-------. root root unconfined_u:object_r:device_t:s0 /dev/vmnet1

crw-------. root root system_u:object_r:vmware_device_t:s0 /dev/vmnet8

#

After that SELinux stopped complaining and networking works fine in Windows 7.

M.

0 Kudos