JeZLee
Enthusiast
Enthusiast

Linux Host/Windows 10 Pro 64 Guest - Bad Audio?

Jump to solution

Hi,

Host: Linux Mint 18.1 MATE 64Bit / Guest: Windows 10 Pro 64Bit

I've been using VMWare Player for many years on Linux hosts with no problems.

I recently updated Linux VMWare Player and now have a problem:

In my Windows 10 Pro 64Bit guest I have bad audio?

When a sound is played in Win 10 virtual machine the sound is heavily distorted?

I do have current VMWare Tools for Windows installed.

This issue happened recently after updating Linux VMWare Player.

Any help in fixing this problem would be appreciated, thank you!

Jesse

1 Solution

Accepted Solutions
bluefirestorm
Champion
Champion

It is odd that it did not pick up VMware Audio drivers. If I am not mistaken, if it is hdaudio, it will be using the Microsoft audio drivers; not the VMware Audio drivers.

Try this:

  1. Invoke Reinstall VMware Tools but do not invoke the setup.
  2. Instead go to command line: d:\>setup64 /a The setup64 /a will prompt you to specify a folder destination for extracting the drivers.
  3. Go to Device Manager and select the Multimedia Audio Controller and update the driver manually. And specify the folder in step 2 as the source.

If you drill down the folder you will find <Your extract folder>\VMware\VMware Tools\VMware\Drivers\audio\Vista

This is the VMware Audio device and not the High Definition Audio that would have been present with hdaudio settings.

View solution in original post

18 Replies
bluefirestorm
Champion
Champion

This bad audio on Windows VM seems to be occur on Linux hosts a lot.

Some have removed the following entry in the vmx configuration of the VM and resolved their Windows guest VM audio quality problem.

sound.virtualdev = "hdaudio"

0 Kudos
JeZLee
Enthusiast
Enthusiast

Hi,

Tried removing " sound.virtualdev = "hdaudio" " and booted up the Win 10 Pro 64Bit VM.

Doing the above make the Win VM have no audio.

Any other ideas?

Thanks!

Jesse

0 Kudos
bluefirestorm
Champion
Champion

What is the audio device in the Windows 10 VM in Device Manager and what is the driver used?


For both of my Windows 10 x64 Pro VMs, they have VMware VMaudio.

When the sound.virtualdev = "hdaudio" is removed, is there still an audio device in the Device Manager of the Windows VM?

0 Kudos
JeZLee
Enthusiast
Enthusiast

Hi,

There is an unknown "Multimedia Audio Controller" in Windows 10 Device Manager.

after deleting:  sound.virtualdev = "hdaudio"  & no audio in Win 10 VM.

I tried reinstalling the current VMWare Tools for Windows guests but still no audio in Win 10 VM.

Anyone know how to fix bad audio with:  sound.virtualdev = "hdaudio" or no audio when deleting:  sound.virtualdev = "hdaudio" ?

Thanks!

Jesse

0 Kudos
JeZLee
Enthusiast
Enthusiast

Just a note: I am using Windows 10 Pro 64Bit with the "Creator's Update" 1703.

Also my Windows 10 is "Genuine" and licensed.

Hope this audio issue can be fixed soon as I use audio editors on Win 10 VM frequently.

Jesse

0 Kudos
bluefirestorm
Champion
Champion

It is odd that it did not pick up VMware Audio drivers. If I am not mistaken, if it is hdaudio, it will be using the Microsoft audio drivers; not the VMware Audio drivers.

Try this:

  1. Invoke Reinstall VMware Tools but do not invoke the setup.
  2. Instead go to command line: d:\>setup64 /a The setup64 /a will prompt you to specify a folder destination for extracting the drivers.
  3. Go to Device Manager and select the Multimedia Audio Controller and update the driver manually. And specify the folder in step 2 as the source.

If you drill down the folder you will find <Your extract folder>\VMware\VMware Tools\VMware\Drivers\audio\Vista

This is the VMware Audio device and not the High Definition Audio that would have been present with hdaudio settings.

View solution in original post

JeZLee
Enthusiast
Enthusiast

Ok, we have some improvement with audio on Win 10 VM.

No more distortion, but there is a little static?

Well, this is satisfactory for now until VMWare Player is updated with a fix.

Thanks!

Jesse

0 Kudos
tl5k5
Contributor
Contributor

This did not work for me. Windows let me install the driver manually, but upon reboot it could not use the driver and went into it's troubleshooting mode.

Any newer ideas on how to fix this audio problem on a Linux host?

0 Kudos
tl5k5
Contributor
Contributor

BTW...I deleted all Audio devices in Windows 10 Device Manager, powered down, deleted the VM's sound device, added a new sound device and it works better.

It has bad distortion for the first couple seconds, but after that it seems good.  I'll update if anything changes.

0 Kudos
sshapirorva
Contributor
Contributor

I had some initial static/distortion when playing audio when I routed sound via displayport or hdmi audio. Switching to the onboard audio card resolved the problem.

0 Kudos
tl5k5
Contributor
Contributor

Well, my distorted audio came back.

I'm not hooked into an HDMI capable monitor, so I have not HDMI audio option.

Any other ideas?

0 Kudos
bluefirestorm
Champion
Champion

I have no idea why your Windows VM went into troubleshooting mode. But I suggest you give the removal of the line

sound.virtualdev = "hdaudio"

from the vmx configuration file another try.

Because that should make the audio controller in the Windows 7/8/10 VM to be VMware Audio instead of the Microsoft High Definition Audio.

If that doesn't work, you could look for

hpet.present = "TRUE" or

hpet0.present = "TRUE"

and set it to FALSE instead. This turns off the virtual high precision event timer as the timer device of the VM.

If either or both still don't work and consistent quality audio is important in your VM, maybe a hardware solution is the next step. There are USB 2.0/3.0 sound devices that you can pass through to the VM (just like USB thumb drives are done). These devices can cost around US$15 but it could go into the hundreds depending on features.

tl5k5
Contributor
Contributor

Removing the sound.virtualdev = "hdaudio" from the .vmx file seems to have fixed the issue!

Thanks so much!

0 Kudos
antus
Contributor
Contributor

Same problem here.

I had to comment out and reboot:

sound.virtualDev = "hdaudio"

Then do the setup64 /a to extract drivers and manually update the "Multimedia Audio Controller" as described by bluefirestorm to restore audio.

This seems to have done the trick.

That aside, I think the root cause of this problem could be on the Linux side as I noticed that changing the volume in the VM makes no difference but cranking it up and down on the Host a couple of times makes the crackle go away for a while.

Kernel 3.10.0-693.11.6.el7.x86_64, CentOS Linux release 7.4.1708 (Core)

$ rpm -qa |grep pulse

alsa-plugins-pulseaudio-1.1.1-1.el7.x86_64

pulseaudio-libs-glib2-10.0-3.el7.x86_64

pulseaudio-gdm-hooks-10.0-3.el7.x86_64

pulseaudio-10.0-3.el7.x86_64

pulseaudio-libs-10.0-3.el7.i686

pulseaudio-module-bluetooth-10.0-3.el7.x86_64

pulseaudio-module-x11-10.0-3.el7.x86_64

pulseaudio-utils-10.0-3.el7.x86_64

pulseaudio-libs-10.0-3.el7.x86_64

$ lspci

00:00.0 Host bridge: Intel Corporation Xeon E3-1200 v3 Processor DRAM Controller (rev 06)

00:01.0 PCI bridge: Intel Corporation Xeon E3-1200 v3/4th Gen Core Processor PCI Express x16 Controller (rev 06)

00:14.0 USB controller: Intel Corporation 8 Series/C220 Series Chipset Family USB xHCI (rev 05)

00:16.0 Communication controller: Intel Corporation 8 Series/C220 Series Chipset Family MEI Controller #1 (rev 04)

00:16.3 Serial controller: Intel Corporation 8 Series/C220 Series Chipset Family KT Controller (rev 04)

00:19.0 Ethernet controller: Intel Corporation Ethernet Connection I217-LM (rev 05)

00:1a.0 USB controller: Intel Corporation 8 Series/C220 Series Chipset Family USB EHCI #2 (rev 05)

00:1b.0 Audio device: Intel Corporation 8 Series/C220 Series Chipset High Definition Audio Controller (rev 05)

00:1c.0 PCI bridge: Intel Corporation 8 Series/C220 Series Chipset Family PCI Express Root Port #1 (rev d5)

00:1c.3 PCI bridge: Intel Corporation 8 Series/C220 Series Chipset Family PCI Express Root Port #4 (rev d5)

00:1d.0 USB controller: Intel Corporation 8 Series/C220 Series Chipset Family USB EHCI #1 (rev 05)

00:1f.0 ISA bridge: Intel Corporation C226 Series Chipset Family Server Advanced SKU LPC Controller (rev 05)

00:1f.2 RAID bus controller: Intel Corporation SATA Controller [RAID mode] (rev 05)

00:1f.3 SMBus: Intel Corporation 8 Series/C220 Series Chipset Family SMBus Controller (rev 05)

01:00.0 VGA compatible controller: NVIDIA Corporation GK107GL [Quadro K600] (rev a1)

01:00.1 Audio device: NVIDIA Corporation GK107 HDMI Audio Controller (rev a1)

03:00.0 PCI bridge: Integrated Technology Express, Inc. IT8893E PCIe to PCI Bridge (rev 52)

0 Kudos
deckoff
Contributor
Contributor

Can I have more details on that, please - such as hardware selected in the VM config, more detailed explanation of the process. Cant seem to replicate it in VMplayer 14

Edit:

had to be

d:\>setup64.exe /a

to work.

Just in case I deleted sound.virtualDev = "hdaudio", and rebooted. Works fine for now.

ObamaPhoneHome
Contributor
Contributor

I can't get the sound to work properly because windows 10 will not allow me to use the supplied vmware driver.   It either says it's incompatible or smugly states the microsoft driver is better.  Neither updating the driver or deleting it and adding a new sound device seems to work.  Windows refuses the vmware driver.

I also commented out the line,

sound.virtualDev = "hdaudio",

I wonder if this has anything to do with the spring 2018 windows 10 update.

tommyjs
Contributor
Contributor

Thank-you @antus for clarifying the need of a two step process. The combination of commenting out 'sound.virtualDev = "hdaudio"' and reinstalling the drivers in Windows 10 worked for me.

Host: Debian Stretch

Guest: Windows 10 Enterprise

vmWare Version 12 Pro (v12.5.9 build-7535481)

0 Kudos
JeZLee
Enthusiast
Enthusiast

Hi,

Left VMWare Player Linux some time ago and started using VirtualBox.
I came back to VMWare Player Linux today and can't believe the audio issues have not been fixed?

Does VMWare even care about this?
It's been an issue for years.

Just my 2 cents...

Jesse

0 Kudos