geep999
Contributor
Contributor

[HOWTO] Slackware 13.0 Linux Guest + VMware Tools on Slackware 12.2 Linux Host, VMWare Player 3.0

Hi,

Configured VMWare Player 3.0.0 on a Slackware 12.2 Linux host, with guest Slackware 13.0 + KDE.

But there are a few little wrinkles to iron out to install the VMWare Tools on the guest.

Once Tools are installed they usually run OK: mouse + copy and paste text, window resize.

A few times the mouse judders at the edge of the guest window, copy and paste text failed,

and the mouse on the host failed to select properly. Had to revert to a text window (CTRLALTF6) to reboot the host.

Network (bridged) and sound also OK, but these don't need the Tools.

Didn't test: any USB peripherals, Unity Mode, Shared Folders.

There may be other ways to configure all this, but this recipe works for me.

Maybe interesting for other Slackware users out there...

1/ Installed VMWare Player 3.0.0 on host.

During installation it downloaded all the VMWare Tools .iso images into /usr/lib/vmware/isoimages/

No problems.

2/ Installed Slackware 13.0 from .iso image as "Other Linux 2.6.x kernel" using the

default 2.6.29.6-smp huge kernel and the Slackware default LILO boot loader.

Virtual Machine Settings: Hardware: Selected Network Adaptor > Bridged.

Virtual Machine Settings: Options: Shared Folders Disabled

No problems.

3/ Start the Slackware guest and login as root.

4/ At this point there isn't an /etc/X11/xorg.conf.

Maybe it isn't necessary, but vmware-install.pl will probably complain about lack of xorg.conf.

Used this xorg.conf was copied from xubuntu:

Section "Device"
Identifier      "Configured Video Device"
EndSection

Section "Monitor"
Identifier      "Configured Monitor"
EndSection

Section "Screen"
Identifier      "Default Screen"
Monitor         "Configured Monitor"
Device          "Configured Video Device"
EndSection

5/ Create this directory:

mkdir /etc/pam.d

In the past vmware-install.pl complained if it did not exist. So I always create it.

6/ vmware-install.pl will complain that it can't restart hal daemon. It's looking for /etc/rc.d/init.d/haldaemon

To fix this:

cp -a /etc/rc.d/rc.hald /etc/rc.d/init.d/haldaemon

rc.hald and haldaemon must be executable.

7/ startx to start KDE.

8/ Mount the VMWare tools /usr/lib/vmware/isoimages/linux.iso

Expand the tools archive file: VMwareTools-8.1.3-203739.tar.gz.

I expanded from /root so the installer is /root/vmware-tools-distrib/vmware-install.pl

9/ Start two konsole windows.

From the first konsole execute the installer vmware-install.pl

I used the defaults for ALL the answers.

It should compile lots of kernel modules and then the screen will flash and X windows should restart.

The konsole should then be displaying:

(++) Using config file: "/etc/X11/xorg.conf"

X is running fine with the new config file.

But the install script has not finished; there is no command prompt. Read on...

10/ From the second console window type

top

You should see that the command mkinitrd is taking lots of cpu but seems to be achieving nothing.

Note the PID of mkinitrd.

stop the mkinitrd process:

kill -9 PID

The first console window should now display the following messages.

Note that HGFS failed, I assume because I had previously disabled Shared Folders.

(I use NFS to handle guest/host shared folders. In the past I found HGFS more trouble than it is worth).

I did not change anything in /boot.

Creating a new initrd boot image for the kernel.
Nothing found at location /boot/initrd-tree, so we will create an
initrd directory structure there... done.                        

Now cd to /boot/initrd-tree and install some modules in your
module directory (lib/modules/2.6.29.6-smp).  Then see init 
for more information (there are a few other files to edit). 
Finally, run mkinitrd again once the initrd-tree is ready,  
and /boot/initrd.gz will be created from it.                

Checking acpi hot plug                                  [OK]
Starting VMware Tools services in the virtual machine:             
Switching to guest configuration:                       [OK]
Paravirtual SCSI module:                                [OK]
Guest filesystem driver:                                [OK]
Mounting HGFS shares:                                   [FAILED]
Guest memory manager:                                   [OK]
Guest vmxnet fast network device:                       [OK]
VM communication interface:                             [OK]
VM communication interface socket family:               [OK]
Blocking file system:                                   [OK]
File system sync driver:                                [OK]
Guest operating system daemon:                          [OK]
Virtual Printing daemon:                                [OK]

The configuration of VMware Tools 8.1.3 build-203739 for Linux for this running
kernel completed successfully.                                                 

You must restart your X session before any mouse or graphics changes take 
effect.                                                                   

You can now run VMware Tools by invoking the following command: 
"/usr/bin/vmware-toolbox" during an X server session.           

To enable advanced X features (e.g., guest resolution fit, drag and drop, and 
file and text copy/paste), you will need to do one (or more) of the following:
1. Manually start /usr/bin/vmware-user                                        
2. Log out and log back into your desktop session; and,                       
3. Restart your X session.                                                    

Use of uninitialized value $network_path in concatenation (.) or string at /usr/bin/vmware-config-tools.pl line 11806.                                          
To use the vmxnet driver, restart networking using the following commands:      
stop
rmmod pcnet32
Use of uninitialized value $network_path in concatenation (.) or string at /usr/bin/vmware-config-tools.pl line 11812.
rmmod vmxnet
modprobe vmxnet
start

Enjoy,

--the VMware team

12/ So that the Tools daemons are started automatically I added 3 lines to /etc/rc.d/rc.local:

echo "Starting vmware tools"
/etc/rc.d/init.d/vmware-tools start
/etc/rc.d/init.d/vmware-tools status

13/ To start the Tools when a user logs in, create a file vmware-user.desktop

[Desktop Entry]
Type=Application
Encoding=UTF-8
Exec=vmware-user
Name=VMware User Agent
X-KDE-autostart-phase=1
NoDisplay=true

Every user needs a copy of vmware-user.desktop in their ~/.kde/Autostart/ directory

This causes /usr/bin/vmware-user to be executed automatically when the user logs in.

14/ If you are having problems selecting between the CD and Hard Disk for booting,

you can slow down the guest startup and change BIOS boot parameters. F2 for BIOS setup.

Edit the .vmx file manually, and add this line:

bios.bootDelay = "10000" 

This will give you 10 seconds to select the BIOS or allow normally booting.

Or use another value if you prefer.

(I added it after memsize = ).

Cheers,

Peter

0 Kudos
7 Replies
continuum
Immortal
Immortal

thanks for posting this

Ulli

___________________________________

VMX-parameters- VMware-liveCD - VM-Sickbay


________________________________________________
Do you need support with a VMFS recovery problem ? - send a message via skype "sanbarrow"
I do not support Workstation 16 at this time ...

0 Kudos
icetoad
Contributor
Contributor

Having an issue with the compile on 13.0 slackware.

It does this:

Then just sits there until the CPU shows 100% load.

Edit: Nevermind, reading is fundamental.

Just to update again.... THANKS! works like a charm!

0 Kudos
geep999
Contributor
Contributor

Just an update - the same recipe for installing the VMWare Tools works fine with a Slackware 13.1 x86_64 guest on a Slackware 13.0 x86_64 host.

VMWare Player Version 3.1.0, build 261024

VMWare Tools Version 8.4.2, build 261024

Cheers,

Peter

0 Kudos
geep999
Contributor
Contributor

Just another update - the same recipe for installing the VMWare Tools works  fine with a Slackware 13.37 x86_64 guest on a Slackware 13.37 x86_64 host.

VMWare Player Version 3.1.4 + latest VMWare Tools.

To prevent KDE from crashing on startup you may need to follow this guidance from Slackware's CHANGES_AND_HINTS.TXT, which is to be found at the top level of the distribution DVD:

Regardless of your chipset (though it seems more common with intel), if KDE
  crashes on startup, try disabling the Composite extension (which will also
  disable all of the fancy desktop effects).  Place the following content in
  a file at /etc/X11/xorg.conf.d/disable-composite.conf:
    Section "Extensions"
      Option "Composite" "Disable"
    EndSection

Cheers,

Peter

0 Kudos
badassbob
Contributor
Contributor

I can confirm that these instructions work fantasic for Window 7 VMware Workstation Host, and Slackware 13.37 Guest.

0 Kudos
mythryll
Contributor
Contributor

Hello.

I am trying to use your instructions to install vmware tools on a 13.37 slack guest (32bit) based on esxi v.4.1 update 1.

I followed your instructions to the letter, When I run vmtools install script after some point I get the following:

Detected Xorg X server version 1.9.5.

Distribution provided drivers for Xorg X server are used.

Skipping X configuration because X drivers are not included.

Then it just stays that way, demands no input, does nothying. I have tried pressing enter a few times, still nothing. Any advice on how to overcome this?

Should I use the following step on your instructions and kill the process?

Also I don't undestand what you are describing about x-windows restarting but you still get back your console windows. Is that possible?

Thank you.

John

0 Kudos
geep999
Contributor
Contributor

Hi John,

Yes - kill the mkinitrd process which is taking 100% cpu. In this example it would be: kill -9 10545

snapshot1.png

Then continue with the instructions.

Also I don't undestand what you are describing about x-windows  restarting but you still get back your console windows. Is that  possible?

I just did a re-installation of the tools and this time the screen didn't flash and X didn't restart. (Note that I always do the installation from a konsole window - I'm running KDE). I noted in the past that X restarted as I described. Maybe something is different in 13.37 or maybe it's because it's a reinstall, not a clean first install. Any which way, just kill mkinitrd and continue.

Also note - the installation finishes with this rather ominous message, which I just ignore! I've not had any networking problems. I usually setup the network adapter as Bridged so that my router allocates the IP address using DHCP.

Use of uninitialized value $network_path in concatenation (.) or string at /usr/bin/vmware-config-tools.pl line 12696.
To use the vmxnet driver, restart networking using the following commands:
stop
rmmod pcnet32
Use of uninitialized value $network_path in concatenation (.) or string at /usr/bin/vmware-config-tools.pl line 12702.
rmmod vmxnet
modprobe vmxnet
start

Enjoy,

--the VMware team

Cheers,

Peter

0 Kudos