dominicus
Contributor
Contributor

Guest display split into identical panes

I have Ubuntu 12.04 LTS linux running in a VMWare Player 6 VM, in a Win7 host.

This install has been stable for >2yrs, but after some Ubuntu updates today, my screen now boots into 3 repeated and truncated panes.  See bottom of msg for how the display shows.

I found this VMWare KB article that describes the issue, but I'm unsure this applies to Player6:

VMware KB: Linux Guest Display Splits into Multiple Panes with Identical Content

I had installed VMWare Tools using the Player controls, but running the prescribed command in Ubuntu terminal:

sudo vmware-config-tools.pl --overwritesvga

....doesn't do anything, just gets me to the man pages for this config package.

Help appreciated!  I'm unable to use this VM as is.

Ubuntu_12.04_.PNG

30 Replies
hux12
Contributor
Contributor

I have exact the same issue here, ever since the ubuntu update on 06/07/2014. I also run vwmare player 6.0.2 on windows 7 hosting a guest os ubuntu 12.04 LTS.

I also would really appreciate any help for this. Many thanks in advance!

0 Kudos
hux12
Contributor
Contributor

I looked up the update history of packages that have been update on Sat. 06/07/2014. A list is given below. After these updateds, the display driver stoped working as pointed out by the original post of this thread. At least one of these updates has affected display driver. But I have no idea which one/s of these may have caused the problem. looks like they are mostly open-ssl related updates. I would really appreciate if anyone could give a hint.

Start-Date: 2014-06-07  15:04:46

Commandline: aptdaemon role='role-commit-packages' sender=':1.65'

Install: linux-headers-3.2.0-64:amd64 (3.2.0-64.97), linux-image-3.2.0-64-generic:amd64 (3.2.0-64.97), linux-headers-3.2.0-64-generic:amd64 (3.2.0-64.97)

Upgrade: iproute:amd64 (20111117-1ubuntu2.1, 20111117-1ubuntu2.3), libknewstuff3-4:amd64 (4.8.5-0ubuntu0.2, 4.8.5-0ubuntu0.3), libkdeclarative5:amd64 (4.8.5-0ubuntu0.2, 4.8.5-0ubuntu0.3), libnepomukquery4a:amd64 (4.8.5-0ubuntu0.2, 4.8.5-0ubuntu0.3), libgnutls-openssl27:amd64 (2.12.14-5ubuntu3.7, 2.12.14-5ubuntu3.8), libthreadweaver4:amd64 (4.8.5-0ubuntu0.2, 4.8.5-0ubuntu0.3), libkdecore5:amd64 (4.8.5-0ubuntu0.2, 4.8.5-0ubuntu0.3), libnepomukutils4:amd64 (4.8.5-0ubuntu0.2, 4.8.5-0ubuntu0.3), libktexteditor4:amd64 (4.8.5-0ubuntu0.2, 4.8.5-0ubuntu0.3), linux-generic:amd64 (3.2.0.63.75, 3.2.0.64.76), libkmediaplayer4:amd64 (4.8.5-0ubuntu0.2, 4.8.5-0ubuntu0.3), libkrosscore4:amd64 (4.8.5-0ubuntu0.2, 4.8.5-0ubuntu0.3), libgnutls26:amd64 (2.12.14-5ubuntu3.7, 2.12.14-5ubuntu3.8), libgnutls26:i386 (2.12.14-5ubuntu3.7, 2.12.14-5ubuntu3.8), libsolid4:amd64 (4.8.5-0ubuntu0.2, 4.8.5-0ubuntu0.3), libnepomuk4:amd64 (4.8.5-0ubuntu0.2, 4.8.5-0ubuntu0.3), libkdnssd4:amd64 (4.8.5-0ubuntu0.2, 4.8.5-0ubuntu0.3), libkparts4:amd64 (4.8.5-0ubuntu0.2, 4.8.5-0ubuntu0.3), kdoctools:amd64 (4.8.5-0ubuntu0.2, 4.8.5-0ubuntu0.3), libssl-dev:amd64 (1.0.1-4ubuntu5.13, 1.0.1-4ubuntu5.14), libssl-doc:amd64 (1.0.1-4ubuntu5.13, 1.0.1-4ubuntu5.14), libkidletime4:amd64 (4.8.5-0ubuntu0.2, 4.8.5-0ubuntu0.3), linux-headers-generic:amd64 (3.2.0.63.75, 3.2.0.64.76), linux-image-generic:amd64 (3.2.0.63.75, 3.2.0.64.76), libkcmutils4:amd64 (4.8.5-0ubuntu0.2, 4.8.5-0ubuntu0.3), libkfile4:amd64 (4.8.5-0ubuntu0.2, 4.8.5-0ubuntu0.3), libkpty4:amd64 (4.8.5-0ubuntu0.2, 4.8.5-0ubuntu0.3), libkntlm4:amd64 (4.8.5-0ubuntu0.2, 4.8.5-0ubuntu0.3), libplasma3:amd64 (4.8.5-0ubuntu0.2, 4.8.5-0ubuntu0.3), libkemoticons4:amd64 (4.8.5-0ubuntu0.2, 4.8.5-0ubuntu0.3), kdelibs-bin:amd64 (4.8.5-0ubuntu0.2, 4.8.5-0ubuntu0.3), libkdewebkit5:amd64 (4.8.5-0ubuntu0.2, 4.8.5-0ubuntu0.3), libkjsembed4:amd64 (4.8.5-0ubuntu0.2, 4.8.5-0ubuntu0.3), libkio5:amd64 (4.8.5-0ubuntu0.2, 4.8.5-0ubuntu0.3), libkjsapi4:amd64 (4.8.5-0ubuntu0.2, 4.8.5-0ubuntu0.3), openssl:amd64 (1.0.1-4ubuntu5.13, 1.0.1-4ubuntu5.14), kdelibs5-data:amd64 (4.8.5-0ubuntu0.2, 4.8.5-0ubuntu0.3), linux-libc-dev:amd64 (3.2.0-63.95, 3.2.0-64.97), libkde3support4:amd64 (4.8.5-0ubuntu0.2, 4.8.5-0ubuntu0.3), libknotifyconfig4:amd64 (4.8.5-0ubuntu0.2, 4.8.5-0ubuntu0.3), kdelibs5-plugins:amd64 (4.8.5-0ubuntu0.2, 4.8.5-0ubuntu0.3), libkhtml5:amd64 (4.8.5-0ubuntu0.2, 4.8.5-0ubuntu0.3), libkdeui5:amd64 (4.8.5-0ubuntu0.2, 4.8.5-0ubuntu0.3), libkdesu5:amd64 (4.8.5-0ubuntu0.2, 4.8.5-0ubuntu0.3), libssl1.0.0:amd64 (1.0.1-4ubuntu5.13, 1.0.1-4ubuntu5.14), libssl1.0.0:i386 (1.0.1-4ubuntu5.13, 1.0.1-4ubuntu5.14)

End-Date: 2014-06-07  15:09:08

0 Kudos
ptarso
Contributor
Contributor

See http://askubuntu.com/questions/480758/ubuntu-12-04-screen-issue-after-updating/480939#480939 and https://communities.vmware.com/message/2388970#2388970.

More users are reporting the same problem with VMware virtual machines after the update.

I used my VM previous snapshot to reproduce the problem.

Previous kernel: 3.2.0-63. VM running ok.

1) I applied all updates (including openssl) but NOT the kernel. After rebooting, the VM screen is OK.

2) I updated again (only the kernel packages, version 3.2.0-64 were pending: complete kernel, headers and kernel image) and rebooted: split / doubled screen shows up!

3) I ran vmware-config-tools.pl in other to generate modules for the new kernel and rebooted:  the split screen persists. Not solved.

4) also tried a full power off / power on: the problem persists.

It seems to be definitely a kernel 3.2.0-64 - related issue.

Suggestion: apply all updates (the openssl update is critical), but skip the kernel packages for now, until we get a fix from VMware or the Ubuntu team.

(AND: ALWAYS create a snapshot before you update anything !!)

Mensagem editada por: ptarso

0 Kudos
Engeeaitch
Contributor
Contributor

Hi - I also have exactly the same problem (Ubuntu 12.04, VMware Player, running on Windows 8.1 host). Unfortunately, I don't have a recent snapshot to go back to.

I have renamed the following file:  /usr/lib/xorg/modules/drivers/vmware_drv.so, followed by a reboot, and this makes the system just a little bit more useable - it seems to apply a basic screen driver in place of the correct one.  I now have a 800x600 screen with just one desktop, but can't increase the size at all.  The mouse inside the VM is also very sluggish.

The driver file that I renamed is dated May 18 2012, so I doubt that this file is the actual cause of the problem (even though the VM knowledgebase article seemed to suggest this was the problem).

I hope that there is a solution soon.  This is driving me nuts.

0 Kudos
Slay68
Contributor
Contributor

Same problem here. First for my Ubuntu VM and later also for my Lubuntu (very smart to update this one as well after the problems on Ubuntu...).

But: since the cause is in the kernel update, I thought I could try and reboot a previous version of the kernel. By pressing the shift-key while booting, the grub-menu appears and then you can select to boot one of the "Previous Linux Versions". Here I picked the top-one (most likely 3.2.0.63, depending on the update frequency)  and this boots just fine with a normal screen layout.

Until this kernel / VMWare problem is fixed, this can be used as workaround.

By the way: I use player version 3.0.1, so it does not seem to be related to player version 6.02.

0 Kudos
wbcbln
Contributor
Contributor

Downgrading the kernel to version 3.2.0-63 is also a viable workaround if you didn't save a snapshot before installing the updates (like me).

To do this, first resize the window such that only one of split panes remains visible.  This makes the environment somewhat usable.

Then start System Tools->Administration->Synaptic Package Manger and mark linux-image-3.2.0-64-generic and linux-headers-3.2.0-64-generic for removal and mark linux-image-3.2.0-63-generic and linux-headers-3.2.0-63-generic for reinstallation.  Then hit apply.  Reboot the VM when update has completed.

Engeeaitch
Contributor
Contributor

Hi - thanks for the suggestions.  I couldn't get the Grub screen to come up (Using VMware Player 6.0.2) so in the end I edited /etc/default/grub and commented out the line GRUB_HIDDEN_TIMEOUT=0 (by adding a # at the start of the line).  Then ran sudo update-grub. This caused the grub menu to appear on startup, and selecting 3.2.0.63 did the trick.

I hope they (is that VMware or Ubuntu?) come out with a proper fix in due course.

0 Kudos
dominicus
Contributor
Contributor

Great...video rendering is restored reverting back to the 3.2.0.63 kernel.

So the issue is the updated 3.2.0.64 kernel interacting badly with the vmware video driver packaged with Ubuntu, while in a VMware Player (v5 or v6) VM.

This KB article aludes to this failure mode experienced in other (past) vmware versions and linux distros:

VMware KB: Linux Guest Display Splits into Multiple Panes with Identical Content

The solution involves doing various tricks (depending on VMware product) to force the vmware-config-tools.pl script to replace the vmware video driver packaged with the linux distribution, with the one contained in the installation package for VMware Tools.

I couldn't find any way to force this replacement in Player 6.  The script detects the installed X drivers in Ubuntu and skips over this step.

The vmware-config-tools.pl script doesn't support the mentioned --overwritesvga option, and the driver file vmware_drv.o cannot be found in my file system.

I'm assuming, since 12.04 is LTS, eventually a future kernel and/or X driver will be released that fixes this regression...in the meantime...stuck on 63.

0 Kudos
syviad
Contributor
Contributor

Hi, I had the same problem after some Ubuntu updates. After reading some articles how to get back to previous versions of kernel I tried to update the kernel to newer version (v3.3.1). And it works. Just try to run the commands mention in the following discussion: How to update kernel to the latest mainline version without any Distro-upgrade? - Ask Ubuntu.

0 Kudos
dominicus
Contributor
Contributor

Taking on custom installs of kernels, IMO, defeats the purpose of sticking to LTS flavor of Ubuntu.

I have limited interest for self-managing installed packages through terminal, and while I don't mind following terminal-based install instructions, I only go there to fix something or get some feature I really need.

For now, I plan to run my VM with 12.04 LTS with last working kernel version.  When Ubuntu decides to push current 12.04 LTS users to 14.04 LTS, I'll do a full backup and try the new LTS version.  May try a fresh 14.04 install and migrate my data if I can find a good tutorial.

I shall miss the times when I didn't worry about doing full backups of my 30GB VM before installing the regularly-pushed updates (Player doesn't support snapshots!).   Ignorance was bliss.

0 Kudos
Gork
Enthusiast
Enthusiast

Just updated to 3.2.0-65 and am having the same problem as was introduced when I upgraded to 3.2.0-64.  Like others in this thread I am booting to 3.2.0-63 and I haven't been able to locate an official response from either Ubuntu or VMware via Google searches.

0 Kudos
rojer9
Contributor
Contributor

i tracked down the patch in 3.2.0-64 that causes this.

reported on launchpad here: https://bugs.launchpad.net/ubuntu/+source/xserver-xorg-video-vmware/+bug/1328898

0 Kudos
cfriedt
Contributor
Contributor

This is likely a bug in xorg-video-vmware, not in vmwgfx.

0 Kudos
cfriedt
Contributor
Contributor

correction. might be an issue with vmwgfx kms / fbdev. further discussion is happening on LKML.

0 Kudos
thellstrom
Contributor
Contributor

I'm having trouble reproducing this. Is there anyone that could try gzip a faulty VM (OVF or vmware directory is fine) that isn't too big and send it to me?

Thanks

Thomas Hellström

0 Kudos
vmtester602
Contributor
Contributor

Hello Thomas,

Below, the download link of an Ubuntu 12.04 VM image with the "split screen" issue.
Username : user
Password : user

http://dl.free.fr/hapWaVIAI

thellstrom
Contributor
Contributor

OK. Thanks for the VM. I could reproduce the problem.

Here's what's happening: The VM is created on a very old version of player or workstation, and it's official virtualHW version is 7. This causes the X server driver dispatcher to enable the old legacy driver that is not at all compatible with vmware fbdev. Still Ubuntu has forced fbdev on for 12.04, and there is a clash. By coincidence it happens with this upgrade, but it could have happened much earlier.

Remedy: 1: Update the VMs view of the virtual hardware:

0. BE SURE TO BACKUP YOUR VM, BE IT USING SNAPSHOTS OR A COPY

1a, For Workstation 9 or above owners, just run "Upgrade this VM"

1b (Completely unsupported and unrecommended) For player players: Get a recent vmware player, Change the .vmx file line virtualHW.version = "7" to "9" and fire up the VM. Verify that everything seems to work before proceeding.

Remedy 2: Disable vmwgfx fbdev in ubuntu.

0. BE SURE TO BACKUP YOUR VM, BE IT USING SNAPSHOTS OR A COPY

1. Edit the VM file /etc/modprobe.d/vmwgfx-fbdev.conf to say

options vmwgfx enable_fbdev=0

2. Run

sudo update-initramfs -u

3. Reboot

Eventually we might release a patched xf86-video-vmware that enables the newer modesetting driver whenever fbdev thinks the hardware version is new enough...

Thanks,

Thomas

cfriedt
Contributor
Contributor

Wow - excellent work Thomas.

Is there a possible SVGA register or other indicative virtual hardware register that can be queried, so that in vmwgfx_fb initialization, the FB driver can just log a message that the virtual hardware is too old, disabling the fbdev interface?

0 Kudos
thellstrom
Contributor
Contributor

In fact, the kernel driver is doing that already, but the problem is that the kernel driver and the X driver dispatcher don't fully agree about when the device is "too old". If they had done that, this problem would never had occured.

The permanent solution I'm thinking of is to remove the check for the "screen object 2" capability in vmwgfx/vmwgfx_driver.c in xf86-video-vmware. It seems too restrictive and the faulty VM I downloaded works just fine if I remove that test. That makes the dispatcher choose the modern KMS driver more or less whenever the kernel module is loaded, which is what we want.

/Thomas