JohanL1974
Contributor
Contributor

Docker - Cannot enable hypervisor in workstation

Hello,

 

For Docker i need the hyperv service but when docker is starting it is telling me hyperv service can not be started. I understand this was not possible before to start hyperv in a vmware but should work with the newer versions. 

Can you tell me how to activate hyperv service within vmware?

 

Thansks!

 

0 Kudos
2 Replies
RaSystemlord
Expert
Expert

I don't know if this is possible or not, but how does it look in Windows Features? What are your host and guest anyway - they may make a difference?

I mean the settings visible in the attached picture. Do you have in VM Settings all the virtualization parameters selected and possible to select? If you don't you cannot get Hyper-V active - it says so in gray in the menu. One of the features is  gray also in my system (guest Windows 10 20H2, host i7 Kubuntu 20.04.2), as you see in the picture, but that shouldn't make any difference because that feature is not part of virtualization.

EDIT: To clarify the process that I was going for ... after the Expert answer below.

1. First: Check from Windows Features now and also later what is enabled and what is not. It's easy to miss out some selections, because you cannot see if they are gray or not, unless you open them with + -sign.

2. Second: Check the VM (virtual computer) settings in VMware that they are right and can enable virtualization. Check Features within VM-computer again.

3. Third: If none of the above works, change "the firmware of VM computer", like the bios of VM-computer. This means editing the control-ASCII file of the VM-computer. These instructions have to come from somebody else ... like you already got them. Check the Features in VM-computer again.

4. Finally: Install all relevant Features within the VM-computer.

5. Then: Check again your application if it works.

Tags (1)
0 Kudos
fabio1975
Expert
Expert

Ciao 

in the configurations of the VM where you want to install hyper-v try to enable these options

fabio1975_0-1631655572697.png

 


then always in the VM but in the VMX configuration file insert these lines

hypervisor.cpuid.v0 = "FALSE"
mce.enable = "TRUE"
vhv.enable = "TRUE"

 

Then try to log into the VM and install the Hyper-V role

Fabio
BLOG: https://vmvirtual.blog

if satisfied give me a kudos
0 Kudos