VMware Communities

ssh host to guest : packet_write_wait

I have an odd networking issue. I am running MacOS 10.14 and Fusion 11 Pro.

I have two mac’s running fusion, I have a ubuntu server vm on each mac. Separate installs. Both using bridged networking. Both VM’s have an ip from the router. DHCP lease is set to 5 weeks.

The following SSH connections work as expected:

Mac_host_1 -> Mac_host_2

Mac_host_1 -> VM on mac_host_2

Mac_host_2 -> VM on Mac_host_1

Vm on mac_host_1 -> vm on mac_host_2

Mac_host_1 -> any host on the internet

Mac_host_2 -> any host on the internet

The following suffers from odd behaviour of the following error “packet_write_wait: Connection to x: Broken Pipe”

Mac_host_1 -> vm on mac_host_1

Mac_host_2 -> vm on mac_host_2

As an additional test, I installed a second VM on both mac hosts and ssh’ed between them, the same error

Vm1 on mac_host_1 -> vm2 on mac_host_1

Vm1 on mac_host_2 -> vm2 on mac_host_2

I am completely confused by this, tcpdump does not show anything when the connection drops, it’s like the system did not see it, the logs I have found do not show anything relating to dropped network.

The other very odd thing is, the error appears 1m 55s after ssh'ing to the machine, which i don't get either

SSH keep a live and timeout settings have been tried with no effect.

So the issue is SSH’ing from host machine to vm on host machine using a lan ip

I am out of ideas


0 Kudos
1 Reply

Because this is the top result on duckduckgo, I created an account and wanted to help.

Add this to the /etc/ssh/ssh_config your client computer:

IPQoS throughput

Hope this helps

0 Kudos