Gianluca84
Contributor
Contributor

Yosemite and Fusion 7 - Very Very Slow

Jump to solution

Hi guys,

I have a problem with my iMac with Yosemite and Fusion 7. All works fine but I have very poor video performance. My VM work if I move mouse cursor ONLY. If I do nothing it stops to run everything! It seems to go in standby mode! With Mavericks and Fusion 6 it was perfect! Any Help?


Tanks!!!

1 Solution

Accepted Solutions
dariusd
Leadership
Leadership

You've bumped into an Apple bug, affecting all hypervisor programs running on Yosemite on mid-2011 iMacs.  Apple is aware of the issue.

You can work around it by opening Terminal, and running the following command:

   sudo nvram boot-args=debug=0x10

Then, restart your Mac.  Fusion should then perform normally.

Cheers,

--

Darius

View solution in original post

45 Replies
dariusd
Leadership
Leadership

You've bumped into an Apple bug, affecting all hypervisor programs running on Yosemite on mid-2011 iMacs.  Apple is aware of the issue.

You can work around it by opening Terminal, and running the following command:

   sudo nvram boot-args=debug=0x10

Then, restart your Mac.  Fusion should then perform normally.

Cheers,

--

Darius

View solution in original post

Gianluca84
Contributor
Contributor

Works Perfectly!!!!!!

Tank you very very much! It was impossible to work with!!!

markn456
Enthusiast
Enthusiast

This fixed my issue on my home computer! works great. I applied the same fix to my iMac at the office.... No improvement. Then I realized my iMac at the office is a i7 Late 2009.  I hope I didn't screw anything up. Is there a command to reverse this setting?

-Mark

dariusd
Leadership
Leadership

You can reverse it by running:

   sudo nvram -d boot-args

at a Terminal prompt, and you can verify the current status by running:

   sudo nvram boot-args

at a Terminal prompt: If there is no setting (as in the default state), there will be no output.

Cheers,

--

Darius

0 Kudos
WoodyZ
Immortal
Immortal

dariusd wrote: at a Terminal prompt, and you can verify the current status by running:

   sudo nvram boot-args

at a Terminal prompt: If there is no setting (as in the default state), there will be no output.

Darius, my output is: nvram: Error getting variable - 'boot-args': (iokit/common) data was not found

Should I have a boot-args variable there but just empty?

0 Kudos
dariusd
Leadership
Leadership

Ah, yes, I forgot that there's now that error message for a nonexistent variable...  There should not be any boot-args variable there by default.

Thanks,

--

Darius

0 Kudos
WoodyZ
Immortal
Immortal

Thanks for the update.

0 Kudos
DN12345
Contributor
Contributor

I had exactly the same problem on the same platform and the same Yosemite and Fusion 7 mix and DariusD's suggestion here has worked great - Thank you DariusD.

I had first upgraded from Fusion 6.05 Pro to 7 Pro in the thought it might fix it but that didn't - I still had the same weird freezing unless I moved the mouse experience before and after the upgrade to Fusion 7 Pro.

I think the problem is with Apple and Yosemite - another sorely missed feature as a result of moving to Yosemite is that the arrow that used to be in the top right corner of a guest that you could use to maximise or vice versa disappears so that lovely fluid feature that worked in Mavericks is gone (and note that it's gone as a result of Yosemite and not Fusion).  Now there is a unity view button in it's place.

0 Kudos
DN12345
Contributor
Contributor

update to my case if it helps anyone - Since applying the sudo command as I last responded my windows 7 guest booted fine and very quickly - however if I ran anything in the guest that involved a network connection such as internet explorer the entire guest would then complete freeze - only option then would be to shutdown the guest.

then tried the sudo command recommended here which made the boot process slow again as expected and still had guest freezing on any network connection

then tried putting down guest, shutdown vmware fusion - reboot - open vmware fusion (and not guest) - then sleep the host - then wake from sleep - then run the guest (which was fast) - then try the network connection in the guest which froze again...

so I then raised a call with Apple (as I have a care plan) they don't know what the problem is and have not heard of it but after raising a case (Case Number 6866-99809) the engineer suggested doing something to completely reset the boot-args....

shutdown fusion, shutdown iMac...

power on and hold down CMD+ALT+P+R  - after the first chime - let go...

next boot - boot into os fine - open fusion 7 pro - fine - start guest - slow and jittery as before - once guest is up several minutes later - ran IE in the guest which was very slow but NO FREEZE...

so that is where I am at the moment - any suggestions anyone as Apple don't know what it is but their recommendation did help a bit so thought I would share it with you.

They also recommended trying a disk permissions check following this which I have yet to do..

0 Kudos
jacksonstev1
Contributor
Contributor

I Had the same issue and decided to reinstall Yosemite after fusion 7 update. Seems to work now...

0 Kudos
DN12345
Contributor
Contributor

I saw late on the 28th Oct that VMWare released Fusion 7.01.. I ended up rebuilding my guest... 

0 Kudos
pav62
Contributor
Contributor

Hi Darius

You are a star!

Just for the record and maybe help for others:-

I own a mid-2011 iMac (i7)

I upgraded to Fusion 6.0.5 last week. I also upgraded to Yosemite on 25 Oct.

My Win2012 Guest was performing fine since I upgraded to Yosemite.


I had to completely shutdown my iMac two days ago. When I started the guest it took 30 minutes to become usable but was very slow.

Even tried installing a fresh Win2012 guest but even that would not start up.

I completely uninstalled Fusion 6.0.5 and brought in my backup of the guest prior to upgrading to Yosemite. Still no joy. What on earth was going on?

I then upgraded to a trial Fusion 7.0.1 thinking that it would fix any issues. The guest was still slow!!

Saw your tip, applied it and bingo... back to full speed.

What a hellish few days of trying to work out if I had changed something or corrupted some config.

Many many thanks

0 Kudos
SmudgeSpot
Contributor
Contributor

I'd like to mention that this issue and fix is not only for the 2011 iMacs.  I've been fighting with this problem on two MacBook Pro laptops, 1 early and 1 late 2011 models.

Setting the boot-args debug option immediately resolved it on both laptops.

Thanks!

Also to note, before running the above nvram command, you should check if there are any existing boot-args values (this is rare but possible).  The command Darius posted above would remove any existing options and replace it with only the debug=0x10 option.

$ sudo nvram -p | grep boot-args

boot-args        kext-dev-mode=1

If the nvram -p command didn't return anything, you are fine to run the sudo nvram boot-args=debug=0x10 command.

If it returned an existing value (shown here in red), then you will need to modify the new command to include the existing values.  They are simply joined with spaces and wrapped in double quotes.

$ sudo nvram boot-args="debug=0x10 kext-dev-mode=1"

If the command was successful (no errors were reported), run the nvram -p command to confirm both arguments have been added.

$ sudo nvram -p | grep boot-args

boot-args        debug=0x10 kext-dev-mode=1

Now reboot your Mac and enjoy your improved VM experience.

When Apple fixes this issue and you want to remove this option, you will not want to use the sudo nvram -d boot-args command as Darius mentioned later.  That will delete the entire boot-args setting.

Instead, just set the boot-args value to whatever you originally had.

$ sudo nvram boot-args=kext-dev-mode=1

Hope this helps.  Thanks again to Darius for informing us of the simple fix.

It's not God that I have a problem with. It is his fan club that I can not stand.
alaselva
Contributor
Contributor

That command has fixed my issue Smiley HappySmiley Happy

Well spotted !!

Now my Windows 7 has come back to normal

0 Kudos
alantv7
Contributor
Contributor

I ran into the same thing with Parallels and they couldn't help. So I upgraded VMware fusion to the 7.0.1 and the SAME thing! I have a mid 2011 iMac as well. The text line supplied here worked! I really don't like windows but I need some functions from home to vpn into work gear.

Thanks for the answers!

0 Kudos
WoodyZ
Immortal
Immortal

alantv7 wrote: I ran into the same thing with Parallels and they couldn't help.

Considering this issue was resolved in the Parallels forum before the VMware forum and Parallels has a KB Article on it I find that hard to believe! Smiley Wink

0 Kudos
alantv7
Contributor
Contributor

Yes, and I followed the instructions. Something in their script which needs to be run from sudo was not right. I was running it as sudo and it would tell me I needed to be root. The instructions just wouldn't work and they couldn't fix it for me.

0 Kudos
carrera
Contributor
Contributor

How do i activiate my terminal! When,i types in the correct info hè isnasking fior a osseworst wicht i do not have on this computert!! Restpartijen and problem,is the same.

How do i need to usenterminal,innthe different steps, .....

Please help

0 Kudos
alantv7
Contributor
Contributor

go to applications -> utilities      You will find terminal here.

0 Kudos