jhollin
Contributor
Contributor

Windows cannot access \\vmware-host\shared folders\desktop

I seem to have successfully moved the virtual machine to a shared folder and given this folder and all the package contents of my windows 7 virtual machine read and write permissions. Windows 7 will start-up in my other user accounts, however I get the message: Windows cannot access
vmware-host\shared folders\desktop. As it turns out, none of the folders in this folder (
vmware-host)(Z:) are accessible. Any suggestions?

30 Replies
brucegordon
Contributor
Contributor

Please email me if you found a solution. I'm having the same problem. Thanks.

Bruce

blgordon@una.edu

0 Kudos
jhollin
Contributor
Contributor

I have not. For now, I deleted the virtual machine and reinstalled it and windows in a shared directory. I have yet to try and add another account user and try it again.

0 Kudos
sirhc_mcd
Contributor
Contributor

I had the same problem and just figured out how to fix it.

What caused the problem for me was that I moved a Windows 7 vm that I had initially built using Fusion 3 on a different MacBook - which coincidentally also had a different user account name (but that may not be a factor).

Each time I started the migrated Windows 7 VM or launched the Windows Explorer on the new MacBook, a window was displayed with the error "Windows cannot access
vmware-host\shared folders\desktop".

To fix the issue, while logged into the Windows 7 VM on the new MacBook, I went into the VM properties and removed all the Shared Folders that were set up for it - including the Mirroring settings for Desktop, Documents, Music and Pictures. This cuased my Windows 7 VM to automatically log me out of the session and re-login again. Once I relogged in, the errors were gone - but then of course were were also my mirrored settings.

So, I then had to recreate the mirrored/shared folders by just going back into the VM properties (while still logged into the same new Windows 7 session immediately following the previous removal effort) and selecting "Share Folders on your Mac" and selecting the mirrored folders I wanted again (e.g. Desktop, Documents, etc.). This once again automatically prompted me to log out of the current Windows 7 session in the VM... once I re-logged back in the shared folders and mirroring settings were working again as I wanted - still without the errors.

Hope this helps anyone with the same issue!

Cheers! -chris

kayakjamie
Contributor
Contributor

The problem can be fixed by creating a symbolic link

sudo ln -s /users/myuser /users/olderuser

The result is:

myhost:Users myuser$ ls -la olduser

lrwxr-xr-x 1 root admin 5 Oct 30 23:16 olduser -> myuser

I discovered the answer by looking at the shared folders under vmware settings. I saw there was a share configured as follows. By setting up the symbolic link, it now points at the correct folder.

Name folder

"olduser On My Mac olduser

0 Kudos
Cardinale
Contributor
Contributor

I fixed the problem by unchecking each of the four mirrored folders then logging off windows. Logging back in, renable all four mirrored folders and then logg out and back in and all seemed to be right in the world. It might not hurt to add your home directory as a shared folder at the top, but don't think that is required

APACC
Contributor
Contributor

This just started for me once I did the new update. Now I can't solve it. I've tried everything in this thread that I am comfortable trying and none of it works. Any suggestions?

0 Kudos
Cardinale
Contributor
Contributor

This problem usually occurs after copying or moving the VM file or changing the path to the VM in any way. All you did was apply the update?

0 Kudos
mbookspan
Contributor
Contributor

Same problem - tried the VM Tools uninstall/reinstall - no go. Did not try the symlink. VM wasn't moved.

M

0 Kudos
APACC
Contributor
Contributor

Same thing. I didn't do one thing other than update VMware when I was prompted that there was an update. That's it. Just the update and now it's all screwed.

0 Kudos
WoodyZ
Immortal
Immortal

APACC wrote:

Same thing. I didn't do one thing other than update VMware when I was prompted that there was an update. That's it. Just the update and now it's all screwed.

Have you tried reverting to the previous version so at least things might again be working properly?

0 Kudos
APACC
Contributor
Contributor

I'm not sure I know how to revert to the old version.

0 Kudos
WoodyZ
Immortal
Immortal

I'm not sure I know how to revert to the old version.

Uninstall VMware Tools.

Uninstall the current version of VMware Fusion.

Install the previous version of VMware Fusion.

Hint: VMware Fusion (menu bar) > Help > Search > type uninstall

0 Kudos
mbookspan
Contributor
Contributor

The problem is that 3.1.2 doesn’t support Win7 SP1. So, any other workarounds?

0 Kudos
WoodyZ
Immortal
Immortal

The problem is that 3.1.2 doesn’t support Win7 SP1. So, any other workarounds?

It may not officially support it however I have Windows 7 SP1 x86 and x64 running under VMware Fusion 3.1.2 without any problems.  Of course, YMMV.

0 Kudos
APACC
Contributor
Contributor

Still nothing on this? No resolve?

0 Kudos
smooney
Contributor
Contributor

This worked, thanks sirhc_mcd!

Sam

0 Kudos
tmacg65
Contributor
Contributor

Hi Chris

I had been serching for a few days, I followed your instructions and have finally loaded Neatbeans 7.2

Cheers

Tanai

0 Kudos
auguste999
Contributor
Contributor

I had the same problem after an upgrade to VMWare 5.  I tried everything in here with no luck.  What did finally work for me was reinstalling the VMWare tools on the windows vm.  A few restarts later and it's working again.

0 Kudos
MortgageLaw
Contributor
Contributor

I used every idea here and the one from Auguste999 was the trick. Found it here http://kb.vmware.com/selfservice/microsites/search.do?cmd=displayKC&docType=kc&docTypeID=DT_KB_1_1&e...

Bottom line, Sharing does not work without vmware tools. You have to install vmware tools from inside of windows. Once I followed the above KB and then re logged into my widows session, everything was restored.

0 Kudos