tonyespy
Contributor
Contributor

VMWareTools v7.6.2 install breaks networking ( NAT / Wireless ) on Ubuntu 7.10

I've been running VMWare Fusion for a few months on a fairly new Macbook Pro running Leopard. I use it primarily for Ubuntu development.

I recently updated to VMWare Fusion 1.1 and had no problems until I installed the new version of VMWare Tools ( v7.6.2 build 62573 ). As soon as I did so, my network ( NAT to my Macbook's WiFi ) connection died.

It seems that this is a pretty common problem. There are quite a few posts on this board, and there's also a Ubuntu network-manager bug for this problem.

As pointed out in the Ubuntu NM bug, the problem seems to stem from the fact that the device link is missing from /sys/class/net/eth0. This in turn prevents NetworkManager ( via Hal ) from seeing the device, so it's never started.

I've tried re-installing VMWare Tools several times, to no avail. I also made sure to run the steps output by vmware-config-tools.pl ( eg. stopping networking, rmmod pcnet32, vmxnet, etc... ).

As an experiment, I installed a fresh version of Ubuntu 7.04 and then installed VMWare Tools, ran vmware-config-tools.pl and everything worked fine. If I check the /sys/class/net/eth0 dir, I see the following device link:

  • device -> ../../../devices/pci0000:00/0000:00:11.0/0000:02:00.0

The other difference I've found is that if I cd to to the device link, and do an `ls -l', the driver link in this directory is different between the two guests. On the working system, I see:

  • driver -> ../../../../bus/pci/drivers/pcnet32

If I cd directly to the pci device dir on the broken guest ( /sys/devices/pci000:00/0000:11.0/0000:02:00.0 ) and run `ls-l`, I see:

  • driver -> ../../../../bus/pci/drivers/vmxnet

There also is a missing link in this dir. On the working system, the following link exists:

  • net:eth0 -> ../../../../../class/net/eth0

FYI, Ubuntu 7.04 is running an earlier version of the kernel ( 2.6.20-15-generic ), whereas Ubuntu 7.10 is running 2.6.22-14-generic.

There is a temporary workaround which involves using network-admin to disable roaming for the Wired Connection ( this adds eth0 to /etc/network/interfaces and removes the device from NM's control ).

I tried a fresh install of Ubuntu 7.10 just to make sure the problem wasn't with any of the post-release updates, and it breaks networking just the same.

It looks like this is a problem with the vmware-config-tools.pl script, as the network doesn't go offline, till this script is run ( ie. it's OK after the initial install of the tools ).

0 Kudos
5 Replies
tonyespy
Contributor
Contributor

Here's a log of the fresh install of VMWareTools on a fresh install of Ubuntu 7.10.

0 Kudos
rcardona2k
Immortal
Immortal

VMware does not technically support Ubuntu 7.10 yet in the Tools (according to the VMware GoS Guide ) hence the admirable work in the community. Certainly network should work, but until there's "formal" support you're doing the right thing in raising awareness, asking for help and perhaps opening a support item that documents any pieces VMware might be missing. The Ubuntu side, the proper issue should be logged with Canonical and hopefully there will be a Gibbon patch combined with a rev of the VMware Tools that will work "out of the box"

tonyespy
Contributor
Contributor

I've been using VMWare Fusion 1.x with Ubuntu 7.10 for a few months now and it worked just fine until I installed the version of VMWareTools that comes bundled with Fusion 1.1.

I actually work for Canonical, and I made sure to include a link to the Ubuntu NetworkManager bug ( #153635 ) in my original post. That said, I'm pretty sure this is a bug in the vmware-config-tools.pl script where the setup for vmxnet driver isn't 100% correct when run on Ubuntu 7.10. That said, I'd be more than willing to help debug this problem if someone at VMWare wants to contact me.

Finally, networking can be made to work by disabling roaming; although I sometimes have to manually mark eth0 up, and then run dhclient.

0 Kudos
mykmelez
Enthusiast
Enthusiast

networking can be made to work by disabling roaming

That's true, but there's one problem with it: applications like Firefox and Epiphany (and I think also Pidgin) that query NetworkManager for network status go into "offline" mode on startup if NetworkManager is running and reports that there isn't a working network connection. The only workaround for that is to disable NetworkManager or tediously go "online" in those applications after starting them.

0 Kudos
mykmelez
Enthusiast
Enthusiast

FWIW, I worked around the problem by uninstalling Network Manager, since I don't need it in the VM anyway (given that the VM's network connectivity is managed by the host OS):

sudo apt-get remove network-manager network-manager-gnome

0 Kudos